summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2014-09-19 17:52:21 +0000
committerLars Wendler <polynomial-c@gentoo.org>2014-09-19 17:52:21 +0000
commit689396db13bacda00c7011e4ddde49f3630e79b1 (patch)
tree4b16a5de3a87b37c411630d04dbf159367f97eec /sys-apps/sg3_utils
parentRemove dependency of <sys-power/upower-0.99 from || ( ) construct. (diff)
downloadgentoo-2-689396db13bacda00c7011e4ddde49f3630e79b1.tar.gz
gentoo-2-689396db13bacda00c7011e4ddde49f3630e79b1.tar.bz2
gentoo-2-689396db13bacda00c7011e4ddde49f3630e79b1.zip
Don't install scsi_* scripts twice in /usr/(s)bin (bug #506362)
(Portage version: 2.2.13/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'sys-apps/sg3_utils')
-rw-r--r--sys-apps/sg3_utils/ChangeLog8
-rw-r--r--sys-apps/sg3_utils/sg3_utils-1.39-r1.ebuild44
2 files changed, 51 insertions, 1 deletions
diff --git a/sys-apps/sg3_utils/ChangeLog b/sys-apps/sg3_utils/ChangeLog
index 1285d45d5f7c..9eaad982780d 100644
--- a/sys-apps/sg3_utils/ChangeLog
+++ b/sys-apps/sg3_utils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/sg3_utils
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sg3_utils/ChangeLog,v 1.119 2014/08/16 21:14:43 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sg3_utils/ChangeLog,v 1.120 2014/09/19 17:52:21 polynomial-c Exp $
+
+*sg3_utils-1.39-r1 (19 Sep 2014)
+
+ 19 Sep 2014; Lars Wendler <polynomial-c@gentoo.org>
+ +sg3_utils-1.39-r1.ebuild:
+ Don't install scsi_* scripts twice in /usr/(s)bin (bug #506362).
*sg3_utils-1.39 (16 Aug 2014)
diff --git a/sys-apps/sg3_utils/sg3_utils-1.39-r1.ebuild b/sys-apps/sg3_utils/sg3_utils-1.39-r1.ebuild
new file mode 100644
index 000000000000..0e75145b9bb6
--- /dev/null
+++ b/sys-apps/sg3_utils/sg3_utils-1.39-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sg3_utils/sg3_utils-1.39-r1.ebuild,v 1.1 2014/09/19 17:52:21 polynomial-c Exp $
+
+EAPI="4"
+
+inherit eutils multilib
+
+DESCRIPTION="Apps for querying the sg SCSI interface"
+HOMEPAGE="http://sg.danny.cz/sg/"
+SRC_URI="http://sg.danny.cz/sg/p/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="static-libs"
+
+DEPEND="sys-devel/libtool"
+RDEPEND=""
+PDEPEND=">=sys-apps/rescan-scsi-bus-1.24"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.26-stdint.patch
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ dodoc COVERAGE doc/README examples/*.txt
+ newdoc scripts/README README.scripts
+
+ # Better fix for bug 231089; some packages look for sgutils2
+ local path lib
+ path="/usr/$(get_libdir)"
+ for lib in "${ED}"${path}/libsgutils2.*; do
+ lib=${lib##*/}
+ dosym "${lib}" "${path}/${lib/libsgutils2/libsgutils}"
+ done
+
+ prune_libtool_files
+}