summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenrik Brix Andersen <brix@gentoo.org>2006-06-13 18:00:18 +0000
committerHenrik Brix Andersen <brix@gentoo.org>2006-06-13 18:00:18 +0000
commitb5dae5a55a2aabcc8f1a11309d39f7e730893605 (patch)
treeeb4439f52caa181176fb246482bc3baed4f9dd3d /sys-apps/suspend2-userui/suspend2-userui-0.6.4-r1.ebuild
parentivman bug 136292 (diff)
downloadgentoo-2-b5dae5a55a2aabcc8f1a11309d39f7e730893605.tar.gz
gentoo-2-b5dae5a55a2aabcc8f1a11309d39f7e730893605.tar.bz2
gentoo-2-b5dae5a55a2aabcc8f1a11309d39f7e730893605.zip
Added 'static' USE flag based on a patch from Alon Bar-Lev. Useful when using the binaries in initramfs/initrd.
(Portage version: 2.1)
Diffstat (limited to 'sys-apps/suspend2-userui/suspend2-userui-0.6.4-r1.ebuild')
-rw-r--r--sys-apps/suspend2-userui/suspend2-userui-0.6.4-r1.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/sys-apps/suspend2-userui/suspend2-userui-0.6.4-r1.ebuild b/sys-apps/suspend2-userui/suspend2-userui-0.6.4-r1.ebuild
new file mode 100644
index 000000000000..7e3a91d98ecc
--- /dev/null
+++ b/sys-apps/suspend2-userui/suspend2-userui-0.6.4-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/suspend2-userui/suspend2-userui-0.6.4-r1.ebuild,v 1.1 2006/06/13 18:00:18 brix Exp $
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="User Interface for Software Suspend 2"
+HOMEPAGE="http://www.suspend2.net"
+SRC_URI="http://www.suspend2.net/downloads/all/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="fbsplash static"
+DEPEND="virtual/libc
+ fbsplash? ( sys-libs/zlib
+ media-libs/freetype
+ media-libs/jpeg
+ media-libs/lcms
+ >=media-libs/libmng-1.0.5
+ media-libs/libpng )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${P}-remove-debug.patch
+}
+
+src_compile() {
+ # allow for static linking for use in initramfs/initrd
+ use static && LDFLAGS="${LDFLAGS} -static"
+
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
+ suspend2ui_text || die "emake suspend2ui_text failed"
+
+ if use fbsplash; then
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
+ fbsplash || die "emake fbsplash failed"
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
+ suspend2ui_fbsplash || die "emake suspend2ui_fbsplash failed"
+ fi
+}
+
+src_install() {
+ into /
+ dosbin suspend2ui_text
+ use fbsplash && dosbin suspend2ui_fbsplash
+
+ dodoc AUTHORS ChangeLog KERNEL_API README TODO USERUI_API
+}
+
+pkg_postinst() {
+ if use fbsplash; then
+ einfo
+ einfo "You must create a symlink from /etc/splash/suspend2"
+ einfo "to the theme you want suspend2ui_fbsplash to use, e.g.:"
+ einfo
+ einfo " # ln -sfn /etc/splash/emergence /etc/splash/suspend2"
+ fi
+
+ einfo
+ einfo "Please see /usr/share/doc/${PF}/README.gz for further"
+ einfo "instructions."
+ einfo
+}