summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2001-12-18 22:24:14 +0000
committerDaniel Robbins <drobbins@gentoo.org>2001-12-18 22:24:14 +0000
commit1df580f8620263e30e5a8866594161f74bfa4065 (patch)
tree95a33588210d5c8a424075c02517dcd02d1d37ed /sys-apps/tar
parentremoved kde-apps/quanta-2.0_pre2, since quanta 2.0.1 is out ;o) (diff)
downloadgentoo-2-1df580f8620263e30e5a8866594161f74bfa4065.tar.gz
gentoo-2-1df580f8620263e30e5a8866594161f74bfa4065.tar.bz2
gentoo-2-1df580f8620263e30e5a8866594161f74bfa4065.zip
some fixes for tar
Diffstat (limited to 'sys-apps/tar')
-rw-r--r--sys-apps/tar/tar-1.13.25.ebuild61
1 files changed, 22 insertions, 39 deletions
diff --git a/sys-apps/tar/tar-1.13.25.ebuild b/sys-apps/tar/tar-1.13.25.ebuild
index 18580c08cbd3..414c3cd25b4c 100644
--- a/sys-apps/tar/tar-1.13.25.ebuild
+++ b/sys-apps/tar/tar-1.13.25.ebuild
@@ -1,59 +1,42 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/tar/tar-1.13.25.ebuild,v 1.1 2001/12/17 14:19:13 azarah Exp $
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/tar/tar-1.13.25.ebuild,v 1.2 2001/12/18 22:24:14 drobbins Exp $
-A=${P}.tar.gz
S=${WORKDIR}/${P}
DESCRIPTION="Use this to try make tarballs :)"
-SRC_URI="ftp://alpha.gnu.org/gnu/tar/"${A}
+SRC_URI="ftp://alpha.gnu.org/gnu/tar/${P}.tar.gz"
HOMEPAGE="http://www.gnu.org/software/tar/"
-DEPEND="virtual/glibc
- nls? ( sys-devel/gettext-0.10.35 )"
+DEPEND="virtual/glibc nls? ( sys-devel/gettext-0.10.35 )"
RDEPEND="virtual/glibc"
-src_unpack() {
- unpack ${A}
- cd ${S}/src
- patch -p0 < ${FILESDIR}/${PF}-gentoo.diff
-}
-
src_compile() {
-
- local myconf
- if [ -z "`use nls`" ]
- then
- myconf="--disable-nls"
- fi
- try ./configure --prefix=/usr --bindir=/bin --libexecdir=/usr/lib/misc \
- --infodir=/usr/share/info --host=${CHOST} ${myconf}
-
- if [ -z "`use static`" ]
- then
- try make ${MAKEOPTS}
- else
- try make ${MAKEOPTS} LDFLAGS=-static
- fi
+ local myconf
+ [ -z "`use nls`" ] && myconf="--disable-nls"
+ ./configure --prefix=/usr --bindir=/bin --libexecdir=/usr/lib/misc \
+ --infodir=/usr/share/info --host=${CHOST} ${myconf} || die
+ if [ -z "`use static`" ]
+ then
+ emake || die
+ else
+ emake LDFLAGS=-static || die
+ fi
}
src_install() {
- try make DESTDIR=${D} install
+ make DESTDIR=${D} install || die
#FHS 2.1 stuff
dodir /usr/sbin
cd ${D}
mv usr/lib/misc/rmt usr/sbin/rmt.gnu
dosym rmt.gnu /usr/sbin/rmt
- if [ -z "`use build`" ] && [ -z "`use bootcd`" ]
- then
- dodoc AUTHORS ChangeLog* COPYING NEWS README* PORTS THANKS
-
- #we're using Schilly's enhanced rmt command included with star
-# rm -rf ${D}/usr/lib
- else
- rm -rf ${D}/usr/share
- fi
-
+ if [ -z "`use build`" ]
+ then
+ dodoc AUTHORS ChangeLog* COPYING NEWS README* PORTS THANKS
+ else
+ rm -rf ${D}/usr/share
+ fi
}