summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-11-09 23:44:17 +0000
committerMike Frysinger <vapier@gentoo.org>2006-11-09 23:44:17 +0000
commit19c204a2267950456eb972c15aa2b1370fd61309 (patch)
tree59a6e8b3b70c0745967587fd0ceb365f8f0dd56e /sys-apps/texinfo
parentstable x86, bug #154204 (diff)
downloadgentoo-2-19c204a2267950456eb972c15aa2b1370fd61309.tar.gz
gentoo-2-19c204a2267950456eb972c15aa2b1370fd61309.tar.bz2
gentoo-2-19c204a2267950456eb972c15aa2b1370fd61309.zip
Version bump #154316.
(Portage version: 2.1.2_rc1-r5)
Diffstat (limited to 'sys-apps/texinfo')
-rw-r--r--sys-apps/texinfo/ChangeLog9
-rw-r--r--sys-apps/texinfo/files/digest-texinfo-4.8-r53
-rw-r--r--sys-apps/texinfo/files/texinfo-4.8-buf-overflow-CVE-2006-4810.patch15
-rw-r--r--sys-apps/texinfo/texinfo-4.8-r5.ebuild77
4 files changed, 103 insertions, 1 deletions
diff --git a/sys-apps/texinfo/ChangeLog b/sys-apps/texinfo/ChangeLog
index db1ab8e3557a..a42d662ffa02 100644
--- a/sys-apps/texinfo/ChangeLog
+++ b/sys-apps/texinfo/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/texinfo
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/texinfo/ChangeLog,v 1.75 2006/10/17 06:41:51 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/texinfo/ChangeLog,v 1.76 2006/11/09 23:44:17 vapier Exp $
+
+*texinfo-4.8-r5 (09 Nov 2006)
+
+ 09 Nov 2006; Mike Frysinger <vapier@gentoo.org>
+ +files/texinfo-4.8-buf-overflow-CVE-2006-4810.patch,
+ +texinfo-4.8-r5.ebuild:
+ Version bump #154316.
17 Oct 2006; Roy Marples <uberlord@gentoo.org> texinfo-4.8-r4.ebuild:
Added ~sparc-fbsd keyword.
diff --git a/sys-apps/texinfo/files/digest-texinfo-4.8-r5 b/sys-apps/texinfo/files/digest-texinfo-4.8-r5
new file mode 100644
index 000000000000..8bfc6f00eb18
--- /dev/null
+++ b/sys-apps/texinfo/files/digest-texinfo-4.8-r5
@@ -0,0 +1,3 @@
+MD5 6ba369bbfe4afaa56122e65b3ee3a68c texinfo-4.8.tar.bz2 1521822
+RMD160 5cb82cd240d1f22da813c7142df8828b4f6f1ea4 texinfo-4.8.tar.bz2 1521822
+SHA256 f6bb61fb9c1d6a65523c786a4a74ab61e455420469e09a86929f2d403d9a21bb texinfo-4.8.tar.bz2 1521822
diff --git a/sys-apps/texinfo/files/texinfo-4.8-buf-overflow-CVE-2006-4810.patch b/sys-apps/texinfo/files/texinfo-4.8-buf-overflow-CVE-2006-4810.patch
new file mode 100644
index 000000000000..a842b56335f8
--- /dev/null
+++ b/sys-apps/texinfo/files/texinfo-4.8-buf-overflow-CVE-2006-4810.patch
@@ -0,0 +1,15 @@
+fix for buffer overflow CVE-2006-4810
+
+http://bugs.gentoo.org/154316
+
+--- util/texindex.c
++++ util/texindex.c
+@@ -858,7 +857,7 @@
+ {
+ buffer = (char *) xrealloc (buffer, linebuffer->size *= 2);
+ p += buffer - linebuffer->buffer;
+- end += buffer - linebuffer->buffer;
++ end = buffer + linebuffer->size;
+ linebuffer->buffer = buffer;
+ }
+ if (c < 0 || c == '\n')
diff --git a/sys-apps/texinfo/texinfo-4.8-r5.ebuild b/sys-apps/texinfo/texinfo-4.8-r5.ebuild
new file mode 100644
index 000000000000..09c4ad73c23f
--- /dev/null
+++ b/sys-apps/texinfo/texinfo-4.8-r5.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/texinfo/texinfo-4.8-r5.ebuild,v 1.1 2006/11/09 23:44:17 vapier Exp $
+
+inherit flag-o-matic eutils toolchain-funcs
+
+DESCRIPTION="The GNU info program and utilities"
+HOMEPAGE="http://www.gnu.org/software/texinfo/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="nls build static"
+
+RDEPEND="!build? ( >=sys-libs/ncurses-5.2-r2 )
+ !build? ( nls? ( virtual/libintl ) )"
+DEPEND="${RDEPEND}
+ !build? ( nls? ( sys-devel/gettext ) )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-freebsd.patch
+ epatch "${FILESDIR}"/${P}-tempfile-owl.patch #114499
+ epatch "${FILESDIR}"/${P}-bounds-check.patch #140902
+ epatch "${FILESDIR}"/${P}-buf-overflow-CVE-2006-4810.patch #154316
+
+ cd doc
+ # Get the texinfo info page to have a proper name of texinfo.info
+ sed -i 's:setfilename texinfo:setfilename texinfo.info:' texinfo.txi
+ sed -i \
+ -e 's:INFO_DEPS = texinfo:INFO_DEPS = texinfo.info:' \
+ -e 's:texinfo\::texinfo.info\::' \
+ Makefile.in
+}
+
+src_compile() {
+ local myconf=
+ if ! use nls || use build ; then
+ myconf="--disable-nls"
+ fi
+ use static && append-ldflags -static
+
+ econf ${myconf} || die
+
+ # Cross-compile workaround #133429
+ if tc-is-cross-compiler ; then
+ emake -C tools || die "emake tools"
+ fi
+
+ # work around broken dependency's in info/Makefile.am #85540
+ emake -C lib || die "emake lib"
+ emake -C info makedoc || die "emake makedoc"
+ emake -C info doc.c || die "emake doc.c"
+ emake || die "emake"
+}
+
+src_install() {
+ if use build ; then
+ newbin util/ginstall-info install-info
+ dobin makeinfo/makeinfo util/{texi2dvi,texindex}
+ else
+ make DESTDIR="${D}" install || die "install failed"
+ dosbin ${FILESDIR}/mkinfodir
+ # tetex installs this guy #76812
+ has_version '<app-text/tetex-3' && rm -f "${D}"/usr/bin/texi2pdf
+
+ if [[ ! -f ${D}/usr/share/info/texinfo.info ]] ; then
+ die "Could not install texinfo.info!!!"
+ fi
+
+ dodoc AUTHORS ChangeLog INTRODUCTION NEWS README TODO
+ newdoc info/README README.info
+ newdoc makeinfo/README README.makeinfo
+ fi
+}