summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-03-31 05:59:41 +0000
committerMike Frysinger <vapier@gentoo.org>2013-03-31 05:59:41 +0000
commit19f68a3a9306c0ea373e0117e66cb2e6d7ab11c6 (patch)
tree2e0dbe07e0ecf6be03f3a8a8afe9c54c5023b4aa /sys-apps/texinfo
parentBackport some crash fixes from upstream. (diff)
downloadgentoo-2-19f68a3a9306c0ea373e0117e66cb2e6d7ab11c6.tar.gz
gentoo-2-19f68a3a9306c0ea373e0117e66cb2e6d7ab11c6.tar.bz2
gentoo-2-19f68a3a9306c0ea373e0117e66cb2e6d7ab11c6.zip
Version bump #462944 by Manuel Rüger.
(Portage version: 2.2.0_alpha169/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'sys-apps/texinfo')
-rw-r--r--sys-apps/texinfo/ChangeLog7
-rw-r--r--sys-apps/texinfo/texinfo-5.1.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/sys-apps/texinfo/ChangeLog b/sys-apps/texinfo/ChangeLog
index bbd7f4bbd168..8779e1333690 100644
--- a/sys-apps/texinfo/ChangeLog
+++ b/sys-apps/texinfo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/texinfo
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/texinfo/ChangeLog,v 1.117 2013/03/03 14:57:57 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/texinfo/ChangeLog,v 1.118 2013/03/31 05:59:41 vapier Exp $
+
+*texinfo-5.1 (31 Mar 2013)
+
+ 31 Mar 2013; Mike Frysinger <vapier@gentoo.org> +texinfo-5.1.ebuild:
+ Version bump #462944 by Manuel Rüger.
03 Mar 2013; Samuli Suominen <ssuominen@gentoo.org> texinfo-4.13-r2.ebuild,
+files/texinfo-4.13-tinfo.patch:
diff --git a/sys-apps/texinfo/texinfo-5.1.ebuild b/sys-apps/texinfo/texinfo-5.1.ebuild
new file mode 100644
index 000000000000..4c9fd29d9c17
--- /dev/null
+++ b/sys-apps/texinfo/texinfo-5.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/texinfo/texinfo-5.1.ebuild,v 1.1 2013/03/31 05:59:41 vapier Exp $
+
+EAPI="3"
+
+inherit flag-o-matic
+
+DESCRIPTION="The GNU info program and utilities"
+HOMEPAGE="http://www.gnu.org/software/texinfo/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+IUSE="nls static"
+
+RDEPEND="!=app-text/tetex-2*
+ >=sys-libs/ncurses-5.2-r2
+ dev-lang/perl
+ dev-perl/libintl-perl
+ dev-perl/Unicode-EastAsianWidth
+ dev-perl/Text-Unidecode
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ nls? ( sys-devel/gettext )"
+
+src_configure() {
+ use static && append-ldflags -static
+ econf \
+ --with-external-libintl-perl \
+ --with-external-Unicode-EastAsianWidth \
+ --with-external-Text-Unidecode \
+ $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README TODO
+ newdoc info/README README.info
+}