summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-04-25 23:39:54 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-04-25 23:39:54 +0000
commit0a1fa0eae97e1ba4b7451c0be550d35c5e5727db (patch)
tree83a3605b589e1e4615398dba7464b84e8009f8d4 /sys-apps/thinkpad
parentnew sudo ebuild - security fix (see bugtraq) (diff)
downloadgentoo-2-0a1fa0eae97e1ba4b7451c0be550d35c5e5727db.tar.gz
gentoo-2-0a1fa0eae97e1ba4b7451c0be550d35c5e5727db.tar.bz2
gentoo-2-0a1fa0eae97e1ba4b7451c0be550d35c5e5727db.zip
New package
Diffstat (limited to 'sys-apps/thinkpad')
-rw-r--r--sys-apps/thinkpad/ChangeLog13
-rw-r--r--sys-apps/thinkpad/files/digest-thinkpad-3.21
-rw-r--r--sys-apps/thinkpad/files/thinkpad10
-rw-r--r--sys-apps/thinkpad/thinkpad-3.2.ebuild55
4 files changed, 79 insertions, 0 deletions
diff --git a/sys-apps/thinkpad/ChangeLog b/sys-apps/thinkpad/ChangeLog
new file mode 100644
index 000000000000..3302edc9ecf9
--- /dev/null
+++ b/sys-apps/thinkpad/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for sys-apps/thinkpad
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/thinkpad/ChangeLog,v 1.1 2002/04/25 23:35:59 rphillips Exp $
+
+*thinkpad-3.2 (25 April 2002)
+
+ 25 April 2002; Wout Mertens <Wout.Mertens@advalvas.be> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/sys-apps/thinkpad/files/digest-thinkpad-3.2 b/sys-apps/thinkpad/files/digest-thinkpad-3.2
new file mode 100644
index 000000000000..92ef91fe42d1
--- /dev/null
+++ b/sys-apps/thinkpad/files/digest-thinkpad-3.2
@@ -0,0 +1 @@
+MD5 545dbc10f694b98075c2a57a01638278 thinkpad_3.2.tar.gz 64386
diff --git a/sys-apps/thinkpad/files/thinkpad b/sys-apps/thinkpad/files/thinkpad
new file mode 100644
index 000000000000..250c62bffcba
--- /dev/null
+++ b/sys-apps/thinkpad/files/thinkpad
@@ -0,0 +1,10 @@
+keep
+path[thinkpad]=/lib/modules/`uname -r`/thinkpad
+#options thinkpad enable_smapi=1 enable_superio=1 enable_rtcmosram=1 enable_thinkpadpm=1
+alias char-major-10-170 thinkpad
+alias /dev/thinkpad thinkpad
+alias /dev/thinkpad/thinkpad thinkpad
+alias /dev/thinkpad/smapi smapi
+alias /dev/thinkpad/superio superio
+alias /dev/thinkpad/rtcmosram rtcmosram
+alias /dev/thinkpad/thinkpadpm thinkpadpm
diff --git a/sys-apps/thinkpad/thinkpad-3.2.ebuild b/sys-apps/thinkpad/thinkpad-3.2.ebuild
new file mode 100644
index 000000000000..3381373440df
--- /dev/null
+++ b/sys-apps/thinkpad/thinkpad-3.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Wout Mertens <Wout.Mertens@advalvas.be>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/thinkpad/thinkpad-3.2.ebuild,v 1.1 2002/04/25 23:35:59 rphillips Exp $
+
+#transform P to match tarball versioning
+MYPV=${PV/_beta/beta}
+MYP="${PN}_${MYPV}"
+KV=""
+DESCRIPTION="Thinkpad system control kernel modules"
+SRC_URI="http://prdownloads.sourceforge.net/tpctl/${MYP}.tar.gz"
+HOMEPAGE="http://tpctl.sourceforge.net/tpctlhome.htm"
+
+#virtual/glibc should depend on specific kernel headers
+DEPEND="virtual/glibc"
+
+pkg_setup() {
+ #thinkpad will compile modules for the kernel pointed to by /usr/src/linux
+ KV=`readlink /usr/src/linux`
+ if [ $? -ne 0 ] ; then
+ echo
+ echo "/usr/src/linux symlink does not exist; cannot continue."
+ echo
+ die
+ else
+ KV=${KV/linux-/}
+ fi
+}
+
+src_compile () {
+
+ emake || die "Make failed"
+
+}
+
+src_install () {
+
+ dodoc AUTHORS COPYING ChangeLog README SUPPORTED-MODELS TECHNOTES
+ dodir /lib/modules/${KV}/thinkpad
+ cp ${S}/drivers/{thinkpad,smapi,superio,rtcmosram,thinkpadpm}.o \
+ ${D}/lib/modules/${KV}/thinkpad
+ insinto /etc/modules.d
+ doins ${FILESDIR}/thinkpad
+ (cat /etc/devfsd.conf; echo; echo '# Thinkpad config';
+ echo 'REGISTER ^thinkpad/.*$ PERMISSIONS root.thinkpad 0664') \
+ > ${D}/etc/devfsd.conf
+}
+
+pkg_postinst () {
+ /usr/sbin/update-modules || return 0
+}
+
+pkg_prerm () {
+ /sbin/modprobe -r smapi superion rtcmosram thinkpadpm thinkpad
+}