summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWout Mertens <wmertens@gentoo.org>2003-02-17 15:41:05 +0000
committerWout Mertens <wmertens@gentoo.org>2003-02-17 15:41:05 +0000
commite2c3a9f5a38a2262e34a7c68f5b0098e7b0d84d0 (patch)
tree3e1d61f008d288a20ecc0ea6ce3bf2d898a639a8 /sys-apps/thinkpad
parentAdded patch and keyword for hppa. (diff)
downloadgentoo-2-e2c3a9f5a38a2262e34a7c68f5b0098e7b0d84d0.tar.gz
gentoo-2-e2c3a9f5a38a2262e34a7c68f5b0098e7b0d84d0.tar.bz2
gentoo-2-e2c3a9f5a38a2262e34a7c68f5b0098e7b0d84d0.zip
Version bump
Diffstat (limited to 'sys-apps/thinkpad')
-rw-r--r--sys-apps/thinkpad/ChangeLog7
-rw-r--r--sys-apps/thinkpad/files/digest-thinkpad-4.11
-rw-r--r--sys-apps/thinkpad/files/thinkpad9
-rw-r--r--sys-apps/thinkpad/thinkpad-4.1.ebuild53
4 files changed, 67 insertions, 3 deletions
diff --git a/sys-apps/thinkpad/ChangeLog b/sys-apps/thinkpad/ChangeLog
index 1fd2ebea5bf4..007a2e5c4c46 100644
--- a/sys-apps/thinkpad/ChangeLog
+++ b/sys-apps/thinkpad/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/thinkpad
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/thinkpad/ChangeLog,v 1.4 2003/02/12 09:10:00 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/thinkpad/ChangeLog,v 1.5 2003/02/17 15:41:05 wmertens Exp $
+
+*thinkpad-4.1 (17 Feb 2003)
+
+ 17 Feb 2003); Wout Mertens <wmertens@gentoo.org>:
+ version bump and correct kernel version detection
*thinkpad-3.2 (25 April 2002)
diff --git a/sys-apps/thinkpad/files/digest-thinkpad-4.1 b/sys-apps/thinkpad/files/digest-thinkpad-4.1
new file mode 100644
index 000000000000..98f0219e8da1
--- /dev/null
+++ b/sys-apps/thinkpad/files/digest-thinkpad-4.1
@@ -0,0 +1 @@
+MD5 d077a0081553e236e0231fc6076b5128 thinkpad_4.1.tar.gz 84278
diff --git a/sys-apps/thinkpad/files/thinkpad b/sys-apps/thinkpad/files/thinkpad
index 250c62bffcba..c333d880777f 100644
--- a/sys-apps/thinkpad/files/thinkpad
+++ b/sys-apps/thinkpad/files/thinkpad
@@ -1,7 +1,12 @@
keep
-path[thinkpad]=/lib/modules/`uname -r`/thinkpad
+path[thinkpad]=/lib/modules/%KV%/thinkpad
+
+# Uncomment this with the options you like.
#options thinkpad enable_smapi=1 enable_superio=1 enable_rtcmosram=1 enable_thinkpadpm=1
-alias char-major-10-170 thinkpad
+
+# Uncomment this if you are not using devfs for some reason, and comment the
+# rest. Otherwise, leave it as is.
+#alias char-major-10-170 thinkpad
alias /dev/thinkpad thinkpad
alias /dev/thinkpad/thinkpad thinkpad
alias /dev/thinkpad/smapi smapi
diff --git a/sys-apps/thinkpad/thinkpad-4.1.ebuild b/sys-apps/thinkpad/thinkpad-4.1.ebuild
new file mode 100644
index 000000000000..0a6985ebf395
--- /dev/null
+++ b/sys-apps/thinkpad/thinkpad-4.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/thinkpad/thinkpad-4.1.ebuild,v 1.1 2003/02/17 15:41:05 wmertens Exp $
+
+#transform P to match tarball versioning
+MYPV=${PV/_beta/beta}
+MYP="${PN}_${MYPV}"
+DESCRIPTION="Thinkpad system control kernel modules"
+SRC_URI="mirror://sourceforge/tpctl/${MYP}.tar.gz"
+HOMEPAGE="http://tpctl.sourceforge.net/tpctlhome.htm"
+KEYWORDS="x86 -ppc"
+SLOT="0"
+LICENSE="GPL-2"
+
+#virtual/glibc should depend on specific kernel headers
+DEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A} || die
+ cd ${S}
+
+ # These instructions come from the webpage and make it compile
+ # on Linux 2.4
+ mkdir 2.5
+ mv drivers include 2.5
+ ln -s 2.4/drivers drivers
+ ln -s 2.4/include include
+}
+
+src_compile() {
+ check_KV
+ emake DIR_MOD_VER=/lib/modules/${KV} || die "Make failed"
+}
+
+src_install() {
+ dodoc AUTHORS COPYING ChangeLog README SUPPORTED-MODELS TECHNOTES
+ dodir /lib/modules/${KV}/thinkpad
+ cp ${S}/drivers/{thinkpad,smapi,superio,rtcmosram,thinkpadpm}.o \
+ ${D}/lib/modules/${KV}/thinkpad
+ dodir /etc/modules.d
+ sed 's/%KV%/'${KV}'/g' ${FILESDIR}/thinkpad > ${D}/etc/modules.d/thinkpad
+ (cat /etc/devfsd.conf; echo; echo '# Thinkpad config';
+ echo 'REGISTER ^thinkpad/.*$ PERMISSIONS root.thinkpad 0664') \
+ > ${D}/etc/devfsd.conf
+}
+
+pkg_postinst() {
+ /usr/sbin/update-modules || return 0
+}
+
+pkg_prerm() {
+ /sbin/modprobe -r smapi superion rtcmosram thinkpadpm thinkpad
+}