summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWout Mertens <wmertens@gentoo.org>2003-02-17 16:17:07 +0000
committerWout Mertens <wmertens@gentoo.org>2003-02-17 16:17:07 +0000
commit2d0aa67f0f81c18033f14dded5fe6078be161016 (patch)
tree9bc0f1c30ad1cdc3053333c86b566c8c0ad2610b /sys-apps/tpctl
parentInitial QAT ebuild (diff)
downloadgentoo-2-2d0aa67f0f81c18033f14dded5fe6078be161016.tar.gz
gentoo-2-2d0aa67f0f81c18033f14dded5fe6078be161016.tar.bz2
gentoo-2-2d0aa67f0f81c18033f14dded5fe6078be161016.zip
Version bump
Diffstat (limited to 'sys-apps/tpctl')
-rw-r--r--sys-apps/tpctl/ChangeLog7
-rw-r--r--sys-apps/tpctl/files/digest-tpctl-4.21
-rw-r--r--sys-apps/tpctl/tpctl-4.2.ebuild54
3 files changed, 61 insertions, 1 deletions
diff --git a/sys-apps/tpctl/ChangeLog b/sys-apps/tpctl/ChangeLog
index 1364ba7a0fc9..609be3887867 100644
--- a/sys-apps/tpctl/ChangeLog
+++ b/sys-apps/tpctl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/tpctl
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/tpctl/ChangeLog,v 1.4 2003/02/12 09:10:29 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/tpctl/ChangeLog,v 1.5 2003/02/17 16:17:07 wmertens Exp $
+
+*tpctl-4.2 (17 Feb 2003)
+
+ 17 Feb 2003; Wout Mertens (wmertens@gentoo.org):
+ Version bump
*tpctl-3.2 (25 April 2002)
diff --git a/sys-apps/tpctl/files/digest-tpctl-4.2 b/sys-apps/tpctl/files/digest-tpctl-4.2
new file mode 100644
index 000000000000..66a9834e67b3
--- /dev/null
+++ b/sys-apps/tpctl/files/digest-tpctl-4.2
@@ -0,0 +1 @@
+MD5 2f4aa4ae73f6ac33fe2565830fd3375a tpctl_4.2.tar.gz 82900
diff --git a/sys-apps/tpctl/tpctl-4.2.ebuild b/sys-apps/tpctl/tpctl-4.2.ebuild
new file mode 100644
index 000000000000..74eb8eddc784
--- /dev/null
+++ b/sys-apps/tpctl/tpctl-4.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/tpctl/tpctl-4.2.ebuild,v 1.1 2003/02/17 16:17:07 wmertens Exp $
+
+IUSE="ncurses tpctlir perl"
+
+#transform P to match tarball versioning
+MYPV=${PV/_beta/beta}
+MYP="${PN}_${MYPV}"
+
+DESCRIPTION="Thinkpad system control user space programs"
+SRC_URI="mirror://sourceforge/tpctl/${MYP}.tar.gz"
+HOMEPAGE="http://tpctl.sourceforge.net/tpctlhome.htm"
+KEYWORDS="x86 -ppc"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="$DEPEND >=sys-apps/thinkpad-4.1 ncurses? ( sys-libs/ncurses )"
+RDEPEND="$RDEPEND sys-apps/thinkpad ncurses? ( sys-libs/ncurses ) perl? ( sys-devel/perl )"
+
+src_compile() {
+ emake -C lib || die "lib make failed"
+ emake -C tpctl || die "tpctl make failed"
+ if use ncurses > /dev/null; then
+ emake -C ntpctl || die "ntpctl make failed"
+ fi
+
+ # Only for thinkpad models 760 and 765
+ # build with:
+ # $ USE=tpctlir emerge tpctl
+ if use tpctlir > /dev/null; then
+ emake -C tpctlir || die "tpctlir make failed"
+ fi
+}
+
+src_install() {
+ dodoc AUTHORS COPYING ChangeLog README SUPPORTED-MODELS TROUBLESHOOTING \
+ VGA-MODES
+ dolib lib/libsmapidev.so.2.0
+ dobin tpctl/tpctl
+ [ -e ntpctl/ntpctl ] && dobin ntpctl/ntpctl
+ if use tpctlir > /dev/null && [ -e tpctlir/tpctlir ]; then
+ mv tpctlir/README README.tpctlir
+ dodoc README.tpctlir
+ dobin tpctlir/tpctlir
+ fi
+ if use perl > /dev/null; then
+ mv apmiser/README README.apmiser
+ dodoc README.apmiser
+ dosbin apmiser/apmiser
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/apmiser.rc apmiser
+ fi
+}