summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-12-01 04:52:17 +0000
committerMike Frysinger <vapier@gentoo.org>2009-12-01 04:52:17 +0000
commit3ac431ba9826d3d60d1d11e2320eb100a578dff7 (patch)
tree015196f04d6ffa2fe6b4eed6abc178af57e622f9 /sys-apps/util-linux/util-linux-9999.ebuild
parentSwitch to new tc-has-tls function rather than USE=elibc_uclibc. (diff)
downloadgentoo-2-3ac431ba9826d3d60d1d11e2320eb100a578dff7.tar.gz
gentoo-2-3ac431ba9826d3d60d1d11e2320eb100a578dff7.tar.bz2
gentoo-2-3ac431ba9826d3d60d1d11e2320eb100a578dff7.zip
Disable tls if the toolchain lacks support.
(Portage version: 2.2_rc51/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/util-linux/util-linux-9999.ebuild')
-rw-r--r--sys-apps/util-linux/util-linux-9999.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/sys-apps/util-linux/util-linux-9999.ebuild b/sys-apps/util-linux/util-linux-9999.ebuild
index c4ffe5b36f8f..ce78d71967f6 100644
--- a/sys-apps/util-linux/util-linux-9999.ebuild
+++ b/sys-apps/util-linux/util-linux-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-9999.ebuild,v 1.12 2009/11/26 21:19:38 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-9999.ebuild,v 1.13 2009/12/01 04:52:17 vapier Exp $
EAPI="2"
@@ -72,7 +72,8 @@ src_configure() {
--without-pam \
$(use unicode || echo --with-ncurses) \
$(use_with selinux) \
- $(use_with slang)
+ $(use_with slang) \
+ $(tc-has-tls || echo --disable-tls)
}
src_install() {