summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-08-16 18:33:27 +0000
committerMike Frysinger <vapier@gentoo.org>2009-08-16 18:33:27 +0000
commit409da46acddecf9f154afe9f287f23ad97e1dad2 (patch)
tree9c675c1d061555b3a3ab32f7a3f1090a6da6680a /sys-apps/util-linux
parentold (diff)
downloadgentoo-2-409da46acddecf9f154afe9f287f23ad97e1dad2.tar.gz
gentoo-2-409da46acddecf9f154afe9f287f23ad97e1dad2.tar.bz2
gentoo-2-409da46acddecf9f154afe9f287f23ad97e1dad2.zip
Add fix from upstream for detecting ext2 filesystems with ext4-only #279054 by sl.
(Portage version: 2.2_rc38/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/util-linux')
-rw-r--r--sys-apps/util-linux/ChangeLog10
-rw-r--r--sys-apps/util-linux/files/0001-libblkid-fix-ext2-detection-on-systems-with-ext4-onl.patch53
-rw-r--r--sys-apps/util-linux/util-linux-2.16-r1.ebuild91
3 files changed, 153 insertions, 1 deletions
diff --git a/sys-apps/util-linux/ChangeLog b/sys-apps/util-linux/ChangeLog
index 8b07df15ca8b..e2f7b093d59c 100644
--- a/sys-apps/util-linux/ChangeLog
+++ b/sys-apps/util-linux/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-apps/util-linux
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/ChangeLog,v 1.274 2009/07/26 20:06:00 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/ChangeLog,v 1.275 2009/08/16 18:33:27 vapier Exp $
+
+*util-linux-2.16-r1 (16 Aug 2009)
+
+ 16 Aug 2009; Mike Frysinger <vapier@gentoo.org>
+ +files/0001-libblkid-fix-ext2-detection-on-systems-with-ext4-onl.patch,
+ +util-linux-2.16-r1.ebuild:
+ Add fix from upstream for detecting ext2 filesystems with ext4-only
+ #279054 by sl.
26 Jul 2009; Mike Frysinger <vapier@gentoo.org>
-util-linux-2.13.1.1.ebuild, util-linux-2.14.2.ebuild,
diff --git a/sys-apps/util-linux/files/0001-libblkid-fix-ext2-detection-on-systems-with-ext4-onl.patch b/sys-apps/util-linux/files/0001-libblkid-fix-ext2-detection-on-systems-with-ext4-onl.patch
new file mode 100644
index 000000000000..fe2838dbf1ae
--- /dev/null
+++ b/sys-apps/util-linux/files/0001-libblkid-fix-ext2-detection-on-systems-with-ext4-onl.patch
@@ -0,0 +1,53 @@
+https://bugs.gentoo.org/279054
+
+From 92cf3ab964266603cf36272d0eec96cd07fa083c Mon Sep 17 00:00:00 2001
+From: Karel Zak <kzak@redhat.com>
+Date: Thu, 13 Aug 2009 21:55:43 +0200
+Subject: [PATCH] libblkid: fix ext2 detection on systems with ext4 only
+
+Address-Red-Hat-Bug: #513104
+Signed-off-by: Karel Zak <kzak@redhat.com>
+---
+ shlibs/blkid/src/probers/ext.c | 12 ++++++------
+ 1 files changed, 6 insertions(+), 6 deletions(-)
+
+diff --git a/shlibs/blkid/src/probers/ext.c b/shlibs/blkid/src/probers/ext.c
+index 671e556..a4d35d1 100644
+--- a/shlibs/blkid/src/probers/ext.c
++++ b/shlibs/blkid/src/probers/ext.c
+@@ -483,11 +483,6 @@ static int probe_ext4(blkid_probe pr, const struct blkid_idmag *mag)
+ if (fi & EXT3_FEATURE_INCOMPAT_JOURNAL_DEV)
+ return -BLKID_ERR_PARAM;
+
+- /* Ext4 has at least one feature which ext3 doesn't understand */
+- if (!(frc & EXT3_FEATURE_RO_COMPAT_UNSUPPORTED) &&
+- !(fi & EXT3_FEATURE_INCOMPAT_UNSUPPORTED))
+- return -BLKID_ERR_PARAM;
+-
+ /*
+ * If the filesystem does not have a journal and ext2 is not
+ * present, then force this to be detected as an ext2
+@@ -498,6 +493,12 @@ static int probe_ext4(blkid_probe pr, const struct blkid_idmag *mag)
+ get_linux_version() >= EXT4_SUPPORTS_EXT2)
+ goto force_ext4;
+
++ /* Ext4 has at least one feature which ext3 doesn't understand */
++ if (!(frc & EXT3_FEATURE_RO_COMPAT_UNSUPPORTED) &&
++ !(fi & EXT3_FEATURE_INCOMPAT_UNSUPPORTED))
++ return -BLKID_ERR_PARAM;
++
++force_ext4:
+ /*
+ * If the filesystem is a OK for use by in-development
+ * filesystem code, and ext4dev is supported or ext4 is not
+@@ -513,7 +514,6 @@ static int probe_ext4(blkid_probe pr, const struct blkid_idmag *mag)
+ return -BLKID_ERR_PARAM;
+ }
+
+-force_ext4:
+ ext_get_info(pr, 4, es);
+ return 0;
+ }
+--
+1.6.3.3
+
diff --git a/sys-apps/util-linux/util-linux-2.16-r1.ebuild b/sys-apps/util-linux/util-linux-2.16-r1.ebuild
new file mode 100644
index 000000000000..10b50b05b388
--- /dev/null
+++ b/sys-apps/util-linux/util-linux-2.16-r1.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.16-r1.ebuild,v 1.1 2009/08/16 18:33:27 vapier Exp $
+
+EAPI="2"
+
+EGIT_REPO_URI="git://git.kernel.org/pub/scm/utils/util-linux-ng/util-linux-ng.git"
+inherit eutils toolchain-funcs
+[[ ${PV} == "9999" ]] && inherit git autotools
+
+MY_PV=${PV/_/-}
+MY_P=${PN}-ng-${MY_PV}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Various useful Linux utilities"
+HOMEPAGE="http://www.kernel.org/pub/linux/utils/util-linux-ng/"
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="mirror://kernel/linux/utils/util-linux-ng/v${PV:0:4}/${MY_P}.tar.bz2
+ loop-aes? ( http://loop-aes.sourceforge.net/updates/util-linux-ng-2.16-20090725.diff.bz2 )"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="crypt loop-aes nls old-linux selinux slang uclibc unicode"
+
+RDEPEND="!sys-process/schedutils
+ !sys-apps/setarch
+ >=sys-libs/ncurses-5.2-r2
+ !<sys-libs/e2fsprogs-libs-1.41.8
+ !<sys-fs/e2fsprogs-1.41.8
+ selinux? ( sys-libs/libselinux )
+ slang? ( sys-libs/slang )"
+DEPEND="${RDEPEND}
+ >=sys-devel/libtool-2
+ nls? ( sys-devel/gettext )
+ virtual/os-headers"
+
+src_prepare() {
+ if [[ ${PV} == "9999" ]] ; then
+ autopoint --force
+ eautoreconf
+ else
+ epatch "${FILESDIR}"/0001-libblkid-fix-ext2-detection-on-systems-with-ext4-onl.patch #279054
+ use loop-aes && epatch "${WORKDIR}"/util-linux-ng-*.diff
+ fi
+ use uclibc && sed -i -e s/versionsort/alphasort/g -e s/strverscmp.h/dirent.h/g mount/lomount.c
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ --enable-agetty \
+ --enable-cramfs \
+ $(use_enable old-linux elvtune) \
+ --disable-init \
+ --disable-kill \
+ --disable-last \
+ --disable-mesg \
+ --enable-partx \
+ --enable-raw \
+ --enable-rdev \
+ --enable-rename \
+ --disable-reset \
+ --disable-login-utils \
+ --enable-schedutils \
+ --disable-wall \
+ --enable-write \
+ --without-pam \
+ $(use unicode || echo --with-ncurses) \
+ $(use_with selinux) \
+ $(use_with slang)
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "install failed"
+ dodoc AUTHORS NEWS README* TODO docs/*
+
+ # need the libs in /
+ gen_usr_ldscript -a blkid uuid
+ # e2fsprogs-libs didnt install .la files, and .pc work fine
+ rm -f "${D}"/usr/$(get_libdir)/*.la
+
+ if use crypt ; then
+ newinitd "${FILESDIR}"/crypto-loop.initd crypto-loop || die
+ newconfd "${FILESDIR}"/crypto-loop.confd crypto-loop || die
+ fi
+}