summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2007-11-27 01:59:51 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2007-11-27 01:59:51 +0000
commit76717c321443cb519e8bf968784c714677f0035c (patch)
treec1fb28bdd342837a83193887b1dcf6301285cac7 /sys-apps/x86info
parentMarking actionwebservice-1.2.6 ppc64 for bug 200159 (diff)
downloadgentoo-2-76717c321443cb519e8bf968784c714677f0035c.tar.gz
gentoo-2-76717c321443cb519e8bf968784c714677f0035c.tar.bz2
gentoo-2-76717c321443cb519e8bf968784c714677f0035c.zip
Version bump.
(Portage version: 2.1.3.19)
Diffstat (limited to 'sys-apps/x86info')
-rw-r--r--sys-apps/x86info/ChangeLog8
-rw-r--r--sys-apps/x86info/files/1.21-pic.patch15
-rw-r--r--sys-apps/x86info/files/digest-x86info-1.213
-rw-r--r--sys-apps/x86info/x86info-1.21.ebuild48
4 files changed, 73 insertions, 1 deletions
diff --git a/sys-apps/x86info/ChangeLog b/sys-apps/x86info/ChangeLog
index cf69825a097d..3116f7320e9c 100644
--- a/sys-apps/x86info/ChangeLog
+++ b/sys-apps/x86info/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/x86info
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/x86info/ChangeLog,v 1.17 2007/04/24 07:36:37 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/x86info/ChangeLog,v 1.18 2007/11/27 01:59:50 robbat2 Exp $
+
+*x86info-1.21 (27 Nov 2007)
+
+ 27 Nov 2007; Robin H. Johnson <robbat2@gentoo.org> +files/1.21-pic.patch,
+ +x86info-1.21.ebuild:
+ Version bump.
24 Apr 2007; Christian Faulhammer <opfer@gentoo.org> x86info-1.20.ebuild:
stable amd64, bug 175732
diff --git a/sys-apps/x86info/files/1.21-pic.patch b/sys-apps/x86info/files/1.21-pic.patch
new file mode 100644
index 000000000000..ddf24b293e14
--- /dev/null
+++ b/sys-apps/x86info/files/1.21-pic.patch
@@ -0,0 +1,15 @@
+diff -Nuar x86info-1.21.orig/bench/benchmarks.c x86info-1.21/bench/benchmarks.c
+--- x86info-1.21.orig/bench/benchmarks.c 2007-11-26 17:53:58.278467889 -0800
++++ x86info-1.21/bench/benchmarks.c 2007-11-26 17:54:32.014318066 -0800
+@@ -19,7 +19,10 @@
+ #ifdef __linux__
+ TIME(asm volatile("int $0x80" :"=a" (tmp) :"0" (__NR_getppid)), "int 0x80");
+ #endif
+- TIME(asm volatile("cpuid": : :"ax", "dx", "cx", "bx"), "cpuid");
++ TIME(asm volatile("movl %%ebx,%%edi\n"
++ "cpuid\n"
++ "movl %%edi,%%ebx\n"
++ : : :"%eax", "%edx", "%ecx", "%edi"), "cpuid");
+
+ TIME(asm volatile("addl $1,0(%esp)"), "addl");
+ TIME(asm volatile("lock ; addl $1,0(%esp)"), "locked add");
diff --git a/sys-apps/x86info/files/digest-x86info-1.21 b/sys-apps/x86info/files/digest-x86info-1.21
new file mode 100644
index 000000000000..d5f88628ed46
--- /dev/null
+++ b/sys-apps/x86info/files/digest-x86info-1.21
@@ -0,0 +1,3 @@
+MD5 1fbfaa392170e2636006603659dec0f0 x86info-1.21.tgz 59354
+RMD160 6eeb9f63d11117a536282f75af871579a9472a02 x86info-1.21.tgz 59354
+SHA256 2bb3fb33832e073452657adf9f946b2d73d32c7382382f2136750c29d2637fe1 x86info-1.21.tgz 59354
diff --git a/sys-apps/x86info/x86info-1.21.ebuild b/sys-apps/x86info/x86info-1.21.ebuild
new file mode 100644
index 000000000000..0df14f5c5f68
--- /dev/null
+++ b/sys-apps/x86info/x86info-1.21.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/x86info/x86info-1.21.ebuild,v 1.1 2007/11/27 01:59:50 robbat2 Exp $
+
+inherit eutils
+
+DESCRIPTION="Dave Jones' handy, informative x86 CPU diagnostic utility"
+HOMEPAGE="http://www.codemonkey.org.uk/projects/x86info/"
+SRC_URI="http://www.codemonkey.org.uk/projects/x86info/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/1.21-pic.patch
+}
+
+src_compile() {
+ emake x86info CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ dobin x86info || die
+
+ insinto /etc/modules.d
+ newins "${FILESDIR}"/x86info-modules.conf-rc x86info
+
+ dodoc TODO README ChangeLog
+ doman x86info.1
+ insinto /usr/share/doc/${PF}
+ doins -r results
+ prepalldocs
+}
+
+pkg_postinst() {
+ ewarn "Your kernel must be built with the following options"
+ ewarn "set to Y or M"
+ ewarn " Processor type and features ->"
+ ewarn " [*] /dev/cpu/*/msr - Model-specific register support"
+ ewarn " [*] /dev/cpu/*/cpuid - CPU information support"
+}