summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-07-23 05:00:11 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-07-23 05:00:11 +0000
commit0cbd149509d0b711fd603dccd292ccf00e97529c (patch)
tree504e45a4816fadea7191916131cb775ce6ad74dd /sys-apps
parentNew snapshot, resolves bug 476950 by Ben Kohler. (diff)
downloadgentoo-2-0cbd149509d0b711fd603dccd292ccf00e97529c.tar.gz
gentoo-2-0cbd149509d0b711fd603dccd292ccf00e97529c.tar.bz2
gentoo-2-0cbd149509d0b711fd603dccd292ccf00e97529c.zip
Import 60-keyboard.hwdb file from systemd git for virtual/udev >= 206. Because this file will conflict with the old keymap feature, be strict with the virtual/udev dependency.
(Portage version: 2.2.0_alpha188/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/hwids/ChangeLog10
-rw-r--r--sys-apps/hwids/hwids-20130717-r1.ebuild47
-rw-r--r--sys-apps/hwids/hwids-99999999.ebuild4
3 files changed, 58 insertions, 3 deletions
diff --git a/sys-apps/hwids/ChangeLog b/sys-apps/hwids/ChangeLog
index 04084569617a..cd44e4f2aa77 100644
--- a/sys-apps/hwids/ChangeLog
+++ b/sys-apps/hwids/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-apps/hwids
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/ChangeLog,v 1.112 2013/07/17 20:21:16 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/ChangeLog,v 1.113 2013/07/23 05:00:11 ssuominen Exp $
+
+*hwids-20130717-r1 (23 Jul 2013)
+
+ 23 Jul 2013; Samuli Suominen <ssuominen@gentoo.org>
+ +hwids-20130717-r1.ebuild, hwids-99999999.ebuild:
+ Import 60-keyboard.hwdb file from systemd git for virtual/udev >= 206.
+ Because this file will conflict with the old keymap feature, be strict with
+ the virtual/udev dependency.
*hwids-20130717 (17 Jul 2013)
diff --git a/sys-apps/hwids/hwids-20130717-r1.ebuild b/sys-apps/hwids/hwids-20130717-r1.ebuild
new file mode 100644
index 000000000000..6e478889f0d4
--- /dev/null
+++ b/sys-apps/hwids/hwids-20130717-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/hwids-20130717-r1.ebuild,v 1.1 2013/07/23 05:00:11 ssuominen Exp $
+
+EAPI=5
+inherit udev eutils
+
+DESCRIPTION="Hardware (PCI, USB, OUI, IAB) IDs databases"
+HOMEPAGE="https://github.com/gentoo/hwids"
+SRC_URI="https://github.com/gentoo/hwids/archive/${P}.tar.gz
+ http://dev.gentoo.org/~ssuominen/${P}-keyboard.patch.xz"
+
+LICENSE="|| ( GPL-2 BSD ) public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="+udev"
+
+DEPEND="udev? (
+ dev-lang/perl
+ >=virtual/udev-206
+)"
+RDEPEND="!<sys-apps/pciutils-3.1.9-r2
+ !<sys-apps/usbutils-005-r1"
+
+S=${WORKDIR}/hwids-${P}
+
+src_prepare() {
+ sed -i -e '/udevadm hwdb/d' Makefile || die
+ # Import required 60-keyboard.hwdb for sys-fs/udev >= 206
+ epatch "${WORKDIR}"/${P}-keyboard.patch
+}
+
+src_compile() {
+ emake UDEV=$(usex udev)
+}
+
+src_install() {
+ emake UDEV=$(usex udev) install \
+ DOCDIR="${EPREFIX}/usr/share/doc/${PF}" \
+ MISCDIR="${EPREFIX}/usr/share/misc" \
+ HWDBDIR="${EPREFIX}$(get_udevdir)/hwdb.d" \
+ DESTDIR="${D}"
+}
+
+pkg_postinst() {
+ use udev && udevadm hwdb --update --root="${ROOT%/}"
+}
diff --git a/sys-apps/hwids/hwids-99999999.ebuild b/sys-apps/hwids/hwids-99999999.ebuild
index b1563ab6fcf8..55f59cd033d6 100644
--- a/sys-apps/hwids/hwids-99999999.ebuild
+++ b/sys-apps/hwids/hwids-99999999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/hwids-99999999.ebuild,v 1.20 2013/03/10 16:43:18 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/hwids-99999999.ebuild,v 1.21 2013/07/23 05:00:11 ssuominen Exp $
EAPI=5
inherit udev eutils git-2
@@ -17,7 +17,7 @@ IUSE="+udev"
DEPEND="udev? (
net-misc/curl
dev-lang/perl
- >=virtual/udev-197-r1
+ >=virtual/udev-206
)"
RDEPEND="!<sys-apps/pciutils-3.1.9-r2
!<sys-apps/usbutils-005-r1"