summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-09-25 06:05:06 +0000
committerMike Frysinger <vapier@gentoo.org>2004-09-25 06:05:06 +0000
commit1a4d24e760832c79d721d09a6091db84daa80040 (patch)
tree1252fd3cae54a4e6764d4adf88f0622543af28b0 /sys-apps
parentMarked stable on mips. (Manifest recommit) (diff)
downloadgentoo-2-1a4d24e760832c79d721d09a6091db84daa80040.tar.gz
gentoo-2-1a4d24e760832c79d721d09a6091db84daa80040.tar.bz2
gentoo-2-1a4d24e760832c79d721d09a6091db84daa80040.zip
ver bump #64957
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/iproute2/ChangeLog8
-rw-r--r--sys-apps/iproute2/files/2.6.9.20040831-make-install.patch10
-rw-r--r--sys-apps/iproute2/files/digest-iproute2-2.6.9.200408311
-rw-r--r--sys-apps/iproute2/iproute2-2.6.9.20040831.ebuild63
4 files changed, 81 insertions, 1 deletions
diff --git a/sys-apps/iproute2/ChangeLog b/sys-apps/iproute2/ChangeLog
index 5259c5fbcfd9..22d36dedacb4 100644
--- a/sys-apps/iproute2/ChangeLog
+++ b/sys-apps/iproute2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/iproute2
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute2/ChangeLog,v 1.15 2004/09/13 09:17:17 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute2/ChangeLog,v 1.16 2004/09/25 06:05:06 vapier Exp $
+
+*iproute2-2.6.9.20040831 (25 Sep 2004)
+
+ 25 Sep 2004; Mike Frysinger <vapier@gentoo.org>
+ +files/2.6.9.20040831-make-install.patch, +iproute2-2.6.9.20040831.ebuild:
+ Version bump #64957 by David Holm.
*iproute2-2.6.7.20040608-r1 (13 Sep 2004)
diff --git a/sys-apps/iproute2/files/2.6.9.20040831-make-install.patch b/sys-apps/iproute2/files/2.6.9.20040831-make-install.patch
new file mode 100644
index 000000000000..439bac7982a2
--- /dev/null
+++ b/sys-apps/iproute2/files/2.6.9.20040831-make-install.patch
@@ -0,0 +1,10 @@
+--- Makefile.orig 2004-09-25 01:52:39.886249224 -0400
++++ Makefile 2004-09-25 01:48:37.942030336 -0400
+@@ -41,6 +41,7 @@
+ install -m 0755 -d $(DESTDIR)$(CONFDIR)
+ install -m 0755 -d $(DESTDIR)$(DOCDIR)/examples
+ install -m 0755 -d $(DESTDIR)$(DOCDIR)/examples/diffserv
++ install -m 0755 -d $(DESTDIR)$(MANDIR)/man8
+ install -m 0644 README.iproute2+tc $(shell find examples -type f -maxdepth 1) \
+ $(DESTDIR)$(DOCDIR)/examples
+ install -m 0644 $(shell find examples/diffserv -type f -maxdepth 1) \
diff --git a/sys-apps/iproute2/files/digest-iproute2-2.6.9.20040831 b/sys-apps/iproute2/files/digest-iproute2-2.6.9.20040831
new file mode 100644
index 000000000000..9d1cb4f2b1b3
--- /dev/null
+++ b/sys-apps/iproute2/files/digest-iproute2-2.6.9.20040831
@@ -0,0 +1 @@
+MD5 4079036ec0283341d37f96ce9ae1a932 iproute2-2.6.9-ss040831.tar.gz 283969
diff --git a/sys-apps/iproute2/iproute2-2.6.9.20040831.ebuild b/sys-apps/iproute2/iproute2-2.6.9.20040831.ebuild
new file mode 100644
index 000000000000..0805ce1bc8af
--- /dev/null
+++ b/sys-apps/iproute2/iproute2-2.6.9.20040831.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute2/iproute2-2.6.9.20040831.ebuild,v 1.1 2004/09/25 06:05:06 vapier Exp $
+
+inherit eutils gcc
+
+MY_PV="${PV:0:5}"
+SNAP="${PV:${#PV}-6}"
+DESCRIPTION="kernel routing and traffic control utilities"
+HOMEPAGE="http://developer.osdl.org/dev/iproute2/"
+SRC_URI="http://developer.osdl.org/dev/iproute2/download/${PN}-${MY_PV}-ss${SNAP}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="atm minimal"
+
+RDEPEND="virtual/libc
+ !minimal? ( sys-libs/db )
+ atm? ( net-dialup/linux-atm )"
+DEPEND="${RDEPEND}
+ >=virtual/os-headers-2.4.21
+ >=sys-apps/sed-4"
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i -e "s:-O2:${CFLAGS}:g" Makefile || die "sed Makefile failed"
+ epatch ${FILESDIR}/${PV}-make-install.patch
+}
+
+src_compile() {
+ # non-standard configure script
+ ./configure || die "configure"
+ use atm \
+ && sed -i '/TC_CONFIG_ATM/s:=.*:=y:' Config \
+ || sed -i '/TC_CONFIG_ATM/s:=.*:=n:' Config
+
+ local SUBDIRS="lib ip tc misc"
+ use minimal && SUBDIRS="lib tc"
+ emake \
+ CC="$(gcc-getCC)" \
+ KERNEL_INCLUDE="${ROOT}/usr/include" \
+ SUBDIRS="${SUBDIRS}" || die "make"
+}
+
+src_install() {
+ if use minimal; then
+ into /
+ dosbin tc/tc || die "minimal"
+ return 0
+ fi
+
+ make \
+ DESTDIR=${D} \
+ SBINDIR=/sbin \
+ DOCDIR=/usr/share/doc/${PF} \
+ install || die "make install failed"
+ into /
+ dosbin ip/{ifcfg,rtpr} || die "dosbin failed"
+}