summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-04-18 16:34:13 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-04-18 16:34:13 +0000
commit4a29f32a11ff1bc265a95f73e48509b91f997454 (patch)
treea19661df99d5029d5201c9b13ab8d5f569b0815a /sys-apps
parentVersion bump (diff)
downloadgentoo-2-4a29f32a11ff1bc265a95f73e48509b91f997454.tar.gz
gentoo-2-4a29f32a11ff1bc265a95f73e48509b91f997454.tar.bz2
gentoo-2-4a29f32a11ff1bc265a95f73e48509b91f997454.zip
Replace libintl patch on latest version with one that actually disables nls support instead of forcing linking against libintl. Update deps to add virtual/libintl.
(Portage version: 2.1_pre7-r5)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/grep/ChangeLog8
-rw-r--r--sys-apps/grep/files/grep-2.5.1a-nls.patch39
-rw-r--r--sys-apps/grep/grep-2.5.1a.ebuild6
3 files changed, 49 insertions, 4 deletions
diff --git a/sys-apps/grep/ChangeLog b/sys-apps/grep/ChangeLog
index e0527b712333..72c719f65f50 100644
--- a/sys-apps/grep/ChangeLog
+++ b/sys-apps/grep/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/grep
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/grep/ChangeLog,v 1.64 2006/04/07 08:08:07 exg Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/grep/ChangeLog,v 1.65 2006/04/18 16:34:13 flameeyes Exp $
+
+ 18 Apr 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/grep-2.5.1a-nls.patch, grep-2.5.1a.ebuild:
+ Replace libintl patch on latest version with one that actually disables nls
+ support instead of forcing linking against libintl. Update deps to add
+ virtual/libintl.
07 Apr 2006; Emanuele Giaquinta <exg@gentoo.org> grep-2.5.1a.ebuild:
Stable on ppc.
diff --git a/sys-apps/grep/files/grep-2.5.1a-nls.patch b/sys-apps/grep/files/grep-2.5.1a-nls.patch
new file mode 100644
index 000000000000..91fb49798b3b
--- /dev/null
+++ b/sys-apps/grep/files/grep-2.5.1a-nls.patch
@@ -0,0 +1,39 @@
+Index: grep-2.5.1a/src/dfa.c
+===================================================================
+--- grep-2.5.1a.orig/src/dfa.c
++++ grep-2.5.1a/src/dfa.c
+@@ -102,7 +102,7 @@ extern void free();
+ /* If we (don't) have I18N. */
+ /* glibc defines _ */
+ #ifndef _
+-# ifdef HAVE_LIBINTL_H
++# if defined(ENABLE_NLS) && defined(HAVE_LIBINTL_H)
+ # include <libintl.h>
+ # ifndef _
+ # define _(Str) gettext (Str)
+Index: grep-2.5.1a/lib/obstack.c
+===================================================================
+--- grep-2.5.1a.orig/lib/obstack.c
++++ grep-2.5.1a/lib/obstack.c
+@@ -451,7 +451,7 @@ _obstack_memory_used (h)
+
+ /* Define the error handler. */
+ #ifndef _
+-# ifdef HAVE_LIBINTL_H
++# if defined(ENABLE_NLS) && defined(HAVE_LIBINTL_H)
+ # include <libintl.h>
+ # ifndef _
+ # define _(Str) gettext (Str)
+Index: grep-2.5.1a/lib/regex.c
+===================================================================
+--- grep-2.5.1a.orig/lib/regex.c
++++ grep-2.5.1a/lib/regex.c
+@@ -112,7 +112,7 @@
+ #endif
+
+ /* This is for other GNU distributions with internationalized messages. */
+-#if HAVE_LIBINTL_H || defined _LIBC
++#if ENABLE_NLS && (HAVE_LIBINTL_H || defined _LIBC)
+ # include <libintl.h>
+ # ifdef _LIBC
+ # undef gettext
diff --git a/sys-apps/grep/grep-2.5.1a.ebuild b/sys-apps/grep/grep-2.5.1a.ebuild
index 77b3436c164e..bbb7ba0ad21c 100644
--- a/sys-apps/grep/grep-2.5.1a.ebuild
+++ b/sys-apps/grep/grep-2.5.1a.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/grep/grep-2.5.1a.ebuild,v 1.6 2006/04/07 08:08:07 exg Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/grep/grep-2.5.1a.ebuild,v 1.7 2006/04/18 16:34:13 flameeyes Exp $
inherit flag-o-matic eutils
@@ -14,7 +14,7 @@ SLOT="0"
KEYWORDS="alpha ~amd64 arm hppa ia64 m68k ~mips ppc ~ppc-macos ppc64 s390 sh ~sparc ~x86 ~x86-fbsd"
IUSE="build nls static"
-RDEPEND=""
+RDEPEND="nls? ( virtual/libintl )"
DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )"
@@ -34,8 +34,8 @@ src_unpack() {
epatch "${FILESDIR}"/${PN}-2.5.1-restrict_arr.patch
epatch "${FILESDIR}"/2.5.1-utf8-case.patch
epatch "${FILESDIR}"/${PN}-2.5.1-perl-segv.patch #95495
- epatch "${FILESDIR}"/${PN}-2.5.1-libintl.patch #92586
epatch "${FILESDIR}"/${PN}-2.5.1-fix-devices-skip.patch #113640
+ epatch "${FILESDIR}"/${P}-nls.patch
# retarded
sed -i 's:__mempcpy:mempcpy:g' lib/*.c || die