summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2002-01-19 22:48:33 +0000
committerDaniel Robbins <drobbins@gentoo.org>2002-01-19 22:48:33 +0000
commit68cb4aa7dbf134db5fdd2d91dcf6dc837f8ffc0f (patch)
tree22ebddb9e527efe695f8b04198e724741581552a /sys-apps
parentupdated to latest version and removed old version (diff)
downloadgentoo-2-68cb4aa7dbf134db5fdd2d91dcf6dc837f8ffc0f.tar.gz
gentoo-2-68cb4aa7dbf134db5fdd2d91dcf6dc837f8ffc0f.tar.bz2
gentoo-2-68cb4aa7dbf134db5fdd2d91dcf6dc837f8ffc0f.zip
misc. updates. We're going back to the old "snapshot" shadow until we
can remove libshadow dependencies from other apps. Missing stunnel patch.
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/shadow/files/digest-shadow-4.0.1-r21
-rw-r--r--sys-apps/shadow/shadow-4.0.1-r2.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/sys-apps/shadow/files/digest-shadow-4.0.1-r2 b/sys-apps/shadow/files/digest-shadow-4.0.1-r2
new file mode 100644
index 000000000000..9f758695f192
--- /dev/null
+++ b/sys-apps/shadow/files/digest-shadow-4.0.1-r2
@@ -0,0 +1 @@
+MD5 0d81d40d11ff7d1e0b061e4ab7976a9e shadow-4.0.1.tar.gz 962560
diff --git a/sys-apps/shadow/shadow-4.0.1-r2.ebuild b/sys-apps/shadow/shadow-4.0.1-r2.ebuild
new file mode 100644
index 000000000000..86ae67a89cde
--- /dev/null
+++ b/sys-apps/shadow/shadow-4.0.1-r2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/shadow/shadow-4.0.1-r2.ebuild,v 1.1 2002/01/19 22:48:33 drobbins Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Utilities to deal with user accounts"
+SRC_URI="ftp://ftp.pld.org.pl/software/shadow/${P}.tar.gz"
+DEPEND=">=sys-libs/pam-0.73 sys-devel/gettext"
+RDEPEND=">=sys-libs/pam-0.73"
+
+src_compile() {
+ ./configure \
+ --disable-desrpc \
+ --with-libcrypt \
+ --with-libcrack \
+ --with-libpam \
+ --enable-shared=yes \
+ --enable-static=yes \
+ --host=${CHOST} || die "bad configure"
+ # Parallel make fails sometimes
+ make LDFLAGS="" || die "compile problem"
+}
+
+src_install() {
+ dodir /etc/default /etc/skel
+
+ make \
+ prefix=${D}/usr \
+ exec_prefix=${D} \
+ mandir=${D}/usr/share/man \
+ install || die "install problem"
+
+ mv ${D}/lib ${D}/usr
+ dosed -e "s:/lib:/usr/lib:" -e "s: libshadow.so':':" /usr/lib/libshadow.la
+ dosym /usr/bin/newgrp /usr/bin/sg
+ dosym /usr/sbin/useradd /usr/sbin/adduser
+ dosym /usr/sbin/vipw /usr/sbin/vigr
+ # remove dead links
+ rm -f ${D}/bin/{sg,vipw}
+
+ insinto /etc
+ # Using a securetty with devfs device names added
+ # (compat names kept for non-devfs compatibility)
+ insopts -m0600 ; doins ${FILESDIR}/securetty
+ insopts -m0600 ; doins ${S}/etc/login.access
+ insopts -m0644 ; doins ${S}/etc/limits
+ insopts -m0644 ; doins ${FILESDIR}/login.defs
+ insinto /etc/pam.d ; insopts -m0644
+ doins ${FILESDIR}/shadow
+ newins ${FILESDIR}/shadow groupadd
+ newins ${FILESDIR}/shadow useradd
+ doins ${FILESDIR}/chage chage
+ cd ${S}/doc
+ dodoc ANNOUNCE INSTALL LICENSE README WISHLIST
+ docinto txt
+ dodoc HOWTO LSM README.* *.txt
+
+ # install missing manpages
+ doman ${S}/man/{shadow.3,shadowconfig.8}
+}