summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-01-04 03:43:28 +0000
committerMike Frysinger <vapier@gentoo.org>2005-01-04 03:43:28 +0000
commit6e91f3e189fbe6397ba92ca8b9c8a74cc7008cd3 (patch)
treed258021587953845a5d931e639e94175cec6f676 /sys-apps
parentRemoved obsolete version. (Manifest recommit) (diff)
downloadgentoo-2-6e91f3e189fbe6397ba92ca8b9c8a74cc7008cd3.tar.gz
gentoo-2-6e91f3e189fbe6397ba92ca8b9c8a74cc7008cd3.tar.bz2
gentoo-2-6e91f3e189fbe6397ba92ca8b9c8a74cc7008cd3.zip
Add patch to fix i18n support #71689 by S.Caglar Onur.
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/diffutils/ChangeLog10
-rw-r--r--sys-apps/diffutils/diffutils-2.8.4-r4.ebuild4
-rw-r--r--sys-apps/diffutils/diffutils-2.8.7-r1.ebuild51
-rw-r--r--sys-apps/diffutils/files/digest-diffutils-2.8.7-r12
4 files changed, 63 insertions, 4 deletions
diff --git a/sys-apps/diffutils/ChangeLog b/sys-apps/diffutils/ChangeLog
index 9adaf1a24d3a..9efbd828a745 100644
--- a/sys-apps/diffutils/ChangeLog
+++ b/sys-apps/diffutils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/diffutils
-# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/diffutils/ChangeLog,v 1.39 2004/12/17 13:14:48 gustavoz Exp $
+# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/diffutils/ChangeLog,v 1.40 2005/01/04 03:43:27 vapier Exp $
+
+*diffutils-2.8.7-r1 (03 Jan 2005)
+
+ 03 Jan 2005; Mike Frysinger <vapier@gentoo.org>
+ +diffutils-2.8.7-r1.ebuild:
+ Add patch to fix i18n support #71689 by S.Caglar Onur.
17 Dec 2004; Gustavo Zacarias <gustavoz@gentoo.org> diffutils-2.8.7.ebuild:
Stable on sparc
diff --git a/sys-apps/diffutils/diffutils-2.8.4-r4.ebuild b/sys-apps/diffutils/diffutils-2.8.4-r4.ebuild
index 3dd82434e4db..2cdcd7edcb5a 100644
--- a/sys-apps/diffutils/diffutils-2.8.4-r4.ebuild
+++ b/sys-apps/diffutils/diffutils-2.8.4-r4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/diffutils/diffutils-2.8.4-r4.ebuild,v 1.21 2004/12/09 05:07:21 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/diffutils/diffutils-2.8.4-r4.ebuild,v 1.22 2005/01/04 03:43:28 vapier Exp $
inherit eutils flag-o-matic
diff --git a/sys-apps/diffutils/diffutils-2.8.7-r1.ebuild b/sys-apps/diffutils/diffutils-2.8.7-r1.ebuild
new file mode 100644
index 000000000000..eec74556f00e
--- /dev/null
+++ b/sys-apps/diffutils/diffutils-2.8.7-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/diffutils/diffutils-2.8.7-r1.ebuild,v 1.1 2005/01/04 03:43:28 vapier Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Tools to make diffs and compare files"
+HOMEPAGE="http://www.gnu.org/software/diffutils/diffutils.html"
+SRC_URI="ftp://alpha.gnu.org/gnu/diffutils/${P}.tar.gz
+ mirror://gentoo/${P}-i18n.patch.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="nls static"
+
+RDEPEND="virtual/libc"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Removes waitpid() call after pclose() on piped diff stream, closing
+ # bug #11728, thanks to D Wollmann <converter@dalnet-perl.org>
+ epatch ${FILESDIR}/diffutils-2.8.4-sdiff-no-waitpid.patch
+
+ # Fix utf8 support. Patch from MDK. #71689
+ epatch ${WORKDIR}/${P}-i18n.patch
+
+ # Make sure we don't try generating the manpages ... this requires
+ # 'help2man' which is a perl app which is not available in a
+ # stage2 / stage3 ... don't DEPEND on it or we get a DEPEND loop :(
+ # for more info, see #55479
+ touch man/*.1
+}
+
+src_compile() {
+ econf $(use_enable nls) || die "econf"
+ use static && append-ldflags -static
+ emake LDFLAGS="${LDFLAGS}" || die "make"
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+ dodoc ChangeLog NEWS README
+
+ # use the manpage from 'sys-apps/man-pages'
+ rm -f "${D}"/usr/share/man/man1/diff.1*
+}
diff --git a/sys-apps/diffutils/files/digest-diffutils-2.8.7-r1 b/sys-apps/diffutils/files/digest-diffutils-2.8.7-r1
new file mode 100644
index 000000000000..a31132fd3a74
--- /dev/null
+++ b/sys-apps/diffutils/files/digest-diffutils-2.8.7-r1
@@ -0,0 +1,2 @@
+MD5 18d6587cb915e7aa110a5d463d6ed156 diffutils-2.8.7.tar.gz 1057977
+MD5 406c758a923f531f350edb82423aef56 diffutils-2.8.7-i18n.patch.bz2 4388