summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-03-30 09:58:53 +0000
committerMike Gilbert <floppym@gentoo.org>2013-03-30 09:58:53 +0000
commit867a8291babd1f477c5278be85fb902c6a22ca5c (patch)
tree78d5cbe05d64b32b3281d5f1cf3deda73ad8b1e9 /sys-apps
parentStable for x86, wrt bug #463678 (diff)
downloadgentoo-2-867a8291babd1f477c5278be85fb902c6a22ca5c.tar.gz
gentoo-2-867a8291babd1f477c5278be85fb902c6a22ca5c.tar.bz2
gentoo-2-867a8291babd1f477c5278be85fb902c6a22ca5c.zip
Copy last two changes from live ebuild.
(Portage version: 2.2.0_alpha170/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/systemd/ChangeLog6
-rw-r--r--sys-apps/systemd/systemd-200.ebuild11
-rw-r--r--sys-apps/systemd/systemd-9999.ebuild4
3 files changed, 16 insertions, 5 deletions
diff --git a/sys-apps/systemd/ChangeLog b/sys-apps/systemd/ChangeLog
index dc9327710085..18692aa6a106 100644
--- a/sys-apps/systemd/ChangeLog
+++ b/sys-apps/systemd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/systemd
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/ChangeLog,v 1.107 2013/03/30 09:37:50 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/ChangeLog,v 1.108 2013/03/30 09:58:53 floppym Exp $
+
+ 30 Mar 2013; Mike Gilbert <floppym@gentoo.org> systemd-200.ebuild,
+ systemd-9999.ebuild:
+ Copy last two changes from live ebuild.
30 Mar 2013; Mike Gilbert <floppym@gentoo.org> systemd-9999.ebuild:
Update hwids version per ssuominen.
diff --git a/sys-apps/systemd/systemd-200.ebuild b/sys-apps/systemd/systemd-200.ebuild
index 92060a8f4dab..6cea869cad13 100644
--- a/sys-apps/systemd/systemd-200.ebuild
+++ b/sys-apps/systemd/systemd-200.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/systemd-200.ebuild,v 1.1 2013/03/29 15:49:38 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/systemd-200.ebuild,v 1.2 2013/03/30 09:58:53 floppym Exp $
EAPI=5
@@ -42,7 +42,6 @@ COMMON_DEPEND=">=sys-apps/dbus-1.6.8-r1
# baselayout-2.2 has /run
RDEPEND="${COMMON_DEPEND}
>=sys-apps/baselayout-2.2
- >=sys-apps/hwids-20130309-r1[udev]
|| (
>=sys-apps/util-linux-2.22
<sys-apps/sysvinit-2.88-r4
@@ -51,6 +50,8 @@ RDEPEND="${COMMON_DEPEND}
!<sys-libs/glibc-2.10
!sys-fs/udev"
+PDEPEND=">=sys-apps/hwids-20130326.1[udev]"
+
# sys-fs/quota is necessary to store correct paths in unit files
DEPEND="${COMMON_DEPEND}
app-arch/xz-utils
@@ -202,6 +203,12 @@ pkg_postinst() {
fi
systemd_update_catalog
+ # Keep this here in case the database format changes so it gets updated
+ # when required. Despite that this file is owned by sys-apps/hwids.
+ if has_version "sys-apps/hwids[udev]"; then
+ udevadm hwdb --update --root="${ROOT%/}"
+ fi
+
if [[ ! -L "${ROOT}"/etc/mtab ]]; then
ewarn "Upstream suggests that the /etc/mtab file should be a symlink to /proc/mounts."
ewarn "It is known to cause users being unable to unmount user mounts. If you don't"
diff --git a/sys-apps/systemd/systemd-9999.ebuild b/sys-apps/systemd/systemd-9999.ebuild
index 754d3335700b..94a3c8c84f19 100644
--- a/sys-apps/systemd/systemd-9999.ebuild
+++ b/sys-apps/systemd/systemd-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/systemd-9999.ebuild,v 1.35 2013/03/30 09:37:50 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/systemd-9999.ebuild,v 1.36 2013/03/30 09:58:53 floppym Exp $
EAPI=5
@@ -235,7 +235,7 @@ pkg_postinst() {
# Keep this here in case the database format changes so it gets updated
# when required. Despite that this file is owned by sys-apps/hwids.
- if use hwdb && has_version "sys-apps/hwids[udev]"; then
+ if has_version "sys-apps/hwids[udev]"; then
udevadm hwdb --update --root="${ROOT%/}"
fi