summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris PeBenito <pebenito@gentoo.org>2004-09-13 03:31:44 +0000
committerChris PeBenito <pebenito@gentoo.org>2004-09-13 03:31:44 +0000
commita975f620c9d5283b1b1526053cf1bba7bad11af4 (patch)
tree3cdc155de41e7889a7ae180304eb05919c5c24e8 /sys-apps
parentrm old (Manifest recommit) (diff)
downloadgentoo-2-a975f620c9d5283b1b1526053cf1bba7bad11af4.tar.gz
gentoo-2-a975f620c9d5283b1b1526053cf1bba7bad11af4.tar.bz2
gentoo-2-a975f620c9d5283b1b1526053cf1bba7bad11af4.zip
rm old
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/checkpolicy/checkpolicy-1.4-r1.ebuild36
-rw-r--r--sys-apps/checkpolicy/files/checkpolicy-1.4-negset.diff82
-rw-r--r--sys-apps/checkpolicy/files/digest-checkpolicy-1.4-r11
-rw-r--r--sys-apps/policycoreutils/files/digest-policycoreutils-1.4-r12
-rw-r--r--sys-apps/policycoreutils/files/selinux-init33
-rw-r--r--sys-apps/policycoreutils/policycoreutils-1.4-r1.ebuild63
6 files changed, 0 insertions, 217 deletions
diff --git a/sys-apps/checkpolicy/checkpolicy-1.4-r1.ebuild b/sys-apps/checkpolicy/checkpolicy-1.4-r1.ebuild
deleted file mode 100644
index 5c9d1d5737b0..000000000000
--- a/sys-apps/checkpolicy/checkpolicy-1.4-r1.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/checkpolicy/checkpolicy-1.4-r1.ebuild,v 1.5 2004/06/24 22:00:09 agriffis Exp $
-
-inherit eutils
-
-IUSE=""
-
-DESCRIPTION="SELinux policy compiler"
-HOMEPAGE="http://www.nsa.gov/selinux"
-SRC_URI="http://www.nsa.gov/selinux/archives/${P}.tgz"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86 ppc sparc"
-
-DEPEND="sys-devel/flex
- sys-devel/bison"
-
-RDEPEND="sec-policy/selinux-base-policy"
-
-src_unpack() {
- unpack ${A}
-
- cd ${S}
- epatch ${FILESDIR}/checkpolicy-1.4-negset.diff
- sed -i -e "s:-Wall:-Wall ${CFLAGS}:g" Makefile
-}
-
-src_compile() {
- cd ${S}
- emake YACC="bison -y" || die
-}
-
-src_install() {
- make DESTDIR="${D}" install
-}
diff --git a/sys-apps/checkpolicy/files/checkpolicy-1.4-negset.diff b/sys-apps/checkpolicy/files/checkpolicy-1.4-negset.diff
deleted file mode 100644
index f0cf8157cf50..000000000000
--- a/sys-apps/checkpolicy/files/checkpolicy-1.4-negset.diff
+++ /dev/null
@@ -1,82 +0,0 @@
-diff -ruN checkpolicy.old/policy_parse.y checkpolicy/policy_parse.y
---- checkpolicy.old/policy_parse.y 2003-10-15 07:15:18.431551648 -0400
-+++ checkpolicy/policy_parse.y 2003-10-15 07:19:00.550784392 -0400
-@@ -1,6 +1,10 @@
-
- /*
- * Author : Stephen Smalley, <sds@epoch.ncsc.mil>
-+ *
-+ * Modified October 14, 2003 David Caplan, <dac@tresys.com>
-+ * - allow exclusion of types and attributes in type/attribute lists
-+ *
- */
-
- /* FLASK */
-@@ -1660,6 +1664,7 @@
- {
- type_datum_t *t;
- unsigned int i;
-+ int add = TRUE;
-
- if (strcmp(id, "*") == 0) {
- /* set all types */
-@@ -1674,14 +1679,27 @@
- for (i = 0; i < policydbp->p_types.nprim; i++) {
- if (ebitmap_get_bit(set, i))
- ebitmap_set_bit(set, i, FALSE);
-- else
-+ else
- ebitmap_set_bit(set, i, TRUE);
- }
- free(id);
- return 0;
- }
-
-- t = hashtab_search(policydbp->p_types.table, id);
-+ /* see if we want to exclude type/attribute */
-+ if (id[0] == '-') {
-+ if (strlen(id) == 1) {
-+ sprintf(errormsg, "illegal identifier %s", id);
-+ yyerror(errormsg);
-+ free(id);
-+ return -1;
-+ }
-+ add = FALSE;
-+ t = hashtab_search(policydbp->p_types.table, id+1);
-+ } else {
-+ t = hashtab_search(policydbp->p_types.table, id);
-+ }
-+
- if (!t) {
- sprintf(errormsg, "unknown type %s", id);
- yyerror(errormsg);
-@@ -1693,12 +1711,13 @@
- /* set all types with this attribute */
- for (i = ebitmap_startbit(&t->types); i < ebitmap_length(&t->types); i++) {
- if (!ebitmap_get_bit(&t->types, i))
-- continue;
-- ebitmap_set_bit(set, i, TRUE);
-+ continue;
-+ /* set or clear bit depending on add */
-+ ebitmap_set_bit(set, i, add);
- }
- } else {
-- /* set one type */
-- ebitmap_set_bit(set, t->value - 1, TRUE);
-+ /* set or clear (depending on add) one type */
-+ ebitmap_set_bit(set, t->value - 1, add);
- }
-
- free(id);
-diff -ruN checkpolicy.old/policy_scan.l checkpolicy/policy_scan.l
---- checkpolicy.old/policy_scan.l 2003-10-15 07:15:18.426552408 -0400
-+++ checkpolicy/policy_scan.l 2003-10-15 07:10:39.149009048 -0400
-@@ -127,7 +127,7 @@
- t2 |
- T2 { return(T2); }
- "/"({letter}|{digit}|_|"."|"-"|"/")* { return(PATH); }
--{letter}({letter}|{digit}|_)* { return(IDENTIFIER); }
-+({letter}|"-")({letter}|{digit}|_)* { return(IDENTIFIER); }
- {letter}({letter}|{digit}|_|"."|"-")* { return(USER_IDENTIFIER); }
- {digit}{digit}* { return(NUMBER); }
- #[^\n]* { /* delete comments */ }
diff --git a/sys-apps/checkpolicy/files/digest-checkpolicy-1.4-r1 b/sys-apps/checkpolicy/files/digest-checkpolicy-1.4-r1
deleted file mode 100644
index e7d618ba2532..000000000000
--- a/sys-apps/checkpolicy/files/digest-checkpolicy-1.4-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 126851036aba68c53a115f32758d6e38 checkpolicy-1.4.tgz 68703
diff --git a/sys-apps/policycoreutils/files/digest-policycoreutils-1.4-r1 b/sys-apps/policycoreutils/files/digest-policycoreutils-1.4-r1
deleted file mode 100644
index 37d4748f8ab2..000000000000
--- a/sys-apps/policycoreutils/files/digest-policycoreutils-1.4-r1
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 c047074b07068e979274ab13a7dfbc7d policycoreutils-1.4.tgz 32204
-MD5 7745af898c624e8d9c5080da4c671957 policycoreutils-extra-1.0.tar.bz2 5949
diff --git a/sys-apps/policycoreutils/files/selinux-init b/sys-apps/policycoreutils/files/selinux-init
deleted file mode 100644
index 1603c57768e2..000000000000
--- a/sys-apps/policycoreutils/files/selinux-init
+++ /dev/null
@@ -1,33 +0,0 @@
-#!/bin/bash
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/policycoreutils/files/selinux-init,v 1.3 2004/07/15 00:47:52 agriffis Exp $
-
-mount -n -t proc none /proc
-
-# see if selinuxfs is available
-for i in $(cat /proc/filesystems); do
- [ "$i" == "selinuxfs" ] && ENABLED=y
-done
-
-umount -n /proc
-
-if [ -n ${ENABLED} ]; then
- # only try to load policy on SELinux kernels
-
- mount -n -t selinuxfs none /selinux
-
- # determine the policy version
- [ -f /selinux/policyvers ] && \
- POLICYVER=$(cat /selinux/policyvers) || \
- POLICYVER=15
-
- # load the policy if it exists
- if [ -f /etc/security/selinux/policy.${POLICYVER} ]; then
- /usr/sbin/load_policy /etc/security/selinux/policy.${POLICYVER}
- else
- echo "Unable to load policy: /etc/security/selinux/policy.${POLICYVER} missing."
- fi
-fi
-
-exec /sbin/init
diff --git a/sys-apps/policycoreutils/policycoreutils-1.4-r1.ebuild b/sys-apps/policycoreutils/policycoreutils-1.4-r1.ebuild
deleted file mode 100644
index f95baf56c327..000000000000
--- a/sys-apps/policycoreutils/policycoreutils-1.4-r1.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/policycoreutils/policycoreutils-1.4-r1.ebuild,v 1.6 2004/08/08 00:38:07 slarti Exp $
-
-IUSE="build"
-
-EXTRAS_VER="1.0"
-
-DESCRIPTION="SELinux core utilities"
-HOMEPAGE="http://www.nsa.gov/selinux"
-SRC_URI="http://www.nsa.gov/selinux/archives/${P}.tgz
- mirror://gentoo/policycoreutils-extra-${EXTRAS_VER}.tar.bz2"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86 ppc sparc"
-
-DEPEND=">=sys-libs/libselinux-${PV}
- sys-devel/gettext
- !build? ( sys-libs/pam )"
-
-RDEPEND="${DEPEND}"
-
-S2=${WORKDIR}/policycoreutils-extra
-
-src_unpack() {
- unpack ${A}
-
- # trivial fix to audit2allow
- sed -i -e 's:newrules:$0:' ${S}/audit2allow/audit2allow
-
- # fix up to accept Gentoo CFLAGS
- local SUBDIRS="load_policy newrole run_init setfiles audit2allow"
- for i in ${SUBDIRS}; do
- sed -i -e "s:-Wall:-Wall ${CFLAGS}:g" ${S}/${i}/Makefile \
- || die "${i} Makefile CFLAGS fix failed."
- done
-}
-
-src_compile() {
- if use build; then
- einfo "Compiling setfiles"
- emake -C ${S}/setfiles || die
- else
- einfo "Compiling policycoreutils"
- emake -C ${S} || die
- einfo "Compiling policycoreutils-extra"
- emake -C ${S2} || die
- fi
-}
-
-src_install() {
- if use build; then
- dosbin ${S}/setfiles/setfiles
- else
- einfo "Installing policycoreutils"
- make DESTDIR="${D}" -C ${S} install || die
- einfo "Installing policycoreutils-extra"
- make DESTDIR="${D}" -C ${S2} install || die
-
- exeinto /sbin
- newexe ${FILESDIR}/selinux-init seinit
- fi
-}