summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-02-14 18:49:48 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-02-14 18:49:48 +0000
commitac16bf5259123d5c4d6787ef7bc26852c7bf2c6f (patch)
tree5b1e5de9155b1a41613183034fcd050a148296d1 /sys-apps
parentAdded one more einfo. (diff)
downloadgentoo-2-ac16bf5259123d5c4d6787ef7bc26852c7bf2c6f.tar.gz
gentoo-2-ac16bf5259123d5c4d6787ef7bc26852c7bf2c6f.tar.bz2
gentoo-2-ac16bf5259123d5c4d6787ef7bc26852c7bf2c6f.zip
Added pid in init-script.
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/dcron/ChangeLog12
-rw-r--r--sys-apps/dcron/dcron-2.7-r10.ebuild72
-rw-r--r--sys-apps/dcron/files/dcron.rc66
-rw-r--r--sys-apps/dcron/files/digest-dcron-2.7-r101
4 files changed, 85 insertions, 6 deletions
diff --git a/sys-apps/dcron/ChangeLog b/sys-apps/dcron/ChangeLog
index 7aff27369ad6..20a25b9f4edb 100644
--- a/sys-apps/dcron/ChangeLog
+++ b/sys-apps/dcron/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/dcron
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dcron/ChangeLog,v 1.10 2003/02/12 12:32:58 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dcron/ChangeLog,v 1.11 2003/02/14 18:49:48 mholzer Exp $
+
+*dcron-2.7-r10 (14 Feb 2003)
+
+ 14 Feb 2003; Martin Holzer <mholzer@gentoo.org> dcron-2.7-r10.ebuild :
+ Added pid in init-script. Closes #15664.
+
+*dcron-2.7-r9 (20 Apr 2002)
12 Feb 2003; Guy Martin <gmsoft@gentoo.org> dcron-2.7-r9.ebuild :
Added hppa to keywords.
@@ -14,9 +21,6 @@
made lintool happy - added LICENSE
-
-*dcron-2.7-r9 (20 Apr 2002)
-
14 Jul 2002; phoen][x <phoenix@gentoo.org> dcron-2.7-r9.ebuild :
Added KEYWORDS, SLOT.
diff --git a/sys-apps/dcron/dcron-2.7-r10.ebuild b/sys-apps/dcron/dcron-2.7-r10.ebuild
new file mode 100644
index 000000000000..c4c5384eb556
--- /dev/null
+++ b/sys-apps/dcron/dcron-2.7-r10.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dcron/dcron-2.7-r10.ebuild,v 1.1 2003/02/14 18:49:48 mholzer Exp $
+
+# to use this, you must be part of the "cron" group
+
+S=${WORKDIR}/dcron
+DESCRIPTION="A cute little cron from Matt Dillon"
+SRC_URI="http://apollo.backplane.com/FreeSrc/dcron27.tgz"
+HOMEPAGE="http://apollo.backplane.com/"
+KEYWORDS="x86 ppc sparc hppa"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="virtual/glibc"
+
+RDEPEND="!virtual/cron
+ sys-apps/cronbase
+ virtual/mta"
+
+PROVIDE="virtual/cron"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ patch -p0 < ${FILESDIR}/${P}-Makefile-gentoo.diff || die
+ # fix 'crontab -e' to look at $EDITOR and not $VISUAL
+ cp ${S}/crontab.c ${S}/crontab.c.orig
+ sed -e 's:VISUAL:EDITOR:g' ${S}/crontab.c.orig > ${S}/crontab.c
+ cp ${S}/crontab.1 ${S}/crontab.1.orig
+ sed -e 's:VISUAL:EDITOR:g' ${S}/crontab.1.orig > ${S}/crontab.1
+ # fix for lines starting with whitespace
+ patch -p0 < ${FILESDIR}/${P}-whitespace.diff || die
+}
+
+src_compile() {
+ make || die
+}
+
+src_install() {
+
+ #this does not work if the directory already exists
+ diropts -m 0750 -o root -g cron
+ dodir /var/spool/cron/crontabs
+
+
+ dodir /usr/{sbin,bin}
+ install -o root -g wheel -m 0700 crond ${D}/usr/sbin
+ install -o root -g cron -m 4750 crontab ${D}/usr/bin
+
+ dodoc CHANGELOG README
+ doman crontab.1 crond.8
+
+ exeinto /etc/init.d ; newexe ${FILESDIR}/dcron.rc6 dcron
+
+ insinto /etc
+ doins ${FILESDIR}/crontab
+
+ dodoc ${FILESDIR}/crontab
+}
+
+
+pkg_postinst() {
+
+ echo
+ einfo "To activate /etc/cron.{hourly|daily|weekly|montly} please run: "
+ einfo "crontab /etc/crontab"
+ echo
+ einfo "!!! That will replace root's current crontab !!!"
+ echo
+
+}
diff --git a/sys-apps/dcron/files/dcron.rc6 b/sys-apps/dcron/files/dcron.rc6
index 809d8b3d446a..6ee262c9078a 100644
--- a/sys-apps/dcron/files/dcron.rc6
+++ b/sys-apps/dcron/files/dcron.rc6
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dcron/files/dcron.rc6,v 1.5 2002/04/20 22:03:25 bangert Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dcron/files/dcron.rc6,v 1.6 2003/02/14 18:49:48 mholzer Exp $
depend() {
need clock hostname logger
@@ -12,11 +12,13 @@ start() {
ebegin "Starting dcron"
start-stop-daemon --start --quiet --exec /usr/sbin/crond \
-- >>/var/log/cron.log 2>&1
+ /usr/bin/pgrep -x -u 0 -P 1 crond > /var/run/cron.pid
eend $?
}
stop() {
ebegin "Stopping dcron"
- start-stop-daemon --stop --quiet --exec /usr/sbin/crond
+ start-stop-daemon --stop --quiet --pidfile /var/run/cron.pid \
+ --exec /usr/sbin/crond
eend $?
}
diff --git a/sys-apps/dcron/files/digest-dcron-2.7-r10 b/sys-apps/dcron/files/digest-dcron-2.7-r10
new file mode 100644
index 000000000000..0bbc16c10bc6
--- /dev/null
+++ b/sys-apps/dcron/files/digest-dcron-2.7-r10
@@ -0,0 +1 @@
+MD5 8984a6bb120cd674d4fb7f1cc52630a2 dcron27.tgz 15868