summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuy Martin <gmsoft@gentoo.org>2005-01-02 09:59:54 +0000
committerGuy Martin <gmsoft@gentoo.org>2005-01-02 09:59:54 +0000
commitaf74dd5e554d03d3d669ac801b134c2c30d8d559 (patch)
tree4686c65987056aab17c6166666b1a6a075286469 /sys-apps
parentDon't install binaries installed by other packages (diff)
downloadgentoo-2-af74dd5e554d03d3d669ac801b134c2c30d8d559.tar.gz
gentoo-2-af74dd5e554d03d3d669ac801b134c2c30d8d559.tar.bz2
gentoo-2-af74dd5e554d03d3d669ac801b134c2c30d8d559.zip
Added dodir before dosym for creating correctly the link /sbin/init when USE=netboot.
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/busybox/ChangeLog6
-rw-r--r--sys-apps/busybox/busybox-1.00-r1.ebuild7
2 files changed, 9 insertions, 4 deletions
diff --git a/sys-apps/busybox/ChangeLog b/sys-apps/busybox/ChangeLog
index b434afebd51d..4e7220ae01b3 100644
--- a/sys-apps/busybox/ChangeLog
+++ b/sys-apps/busybox/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/busybox
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/ChangeLog,v 1.54 2005/01/02 03:54:44 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/ChangeLog,v 1.55 2005/01/02 09:59:54 gmsoft Exp $
+
+ 02 Jan 2005; Guy Martin <gmsoft@gentoo.org> busybox-1.00-r1.ebuild:
+ Added dodir before dosym for creating correctly the link /sbin/init when
+ USE=netboot.
01 Jan 2005; Mike Frysinger <vapier@gentoo.org>
+files/1.00/more-insmod-arches.patch, busybox-1.00-r1.ebuild:
diff --git a/sys-apps/busybox/busybox-1.00-r1.ebuild b/sys-apps/busybox/busybox-1.00-r1.ebuild
index 31a18b00cea9..86d212d439d8 100644
--- a/sys-apps/busybox/busybox-1.00-r1.ebuild
+++ b/sys-apps/busybox/busybox-1.00-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.00-r1.ebuild,v 1.5 2005/01/02 03:54:44 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.00-r1.ebuild,v 1.6 2005/01/02 09:59:54 gmsoft Exp $
inherit eutils
@@ -135,8 +135,9 @@ src_install() {
into /
dobin busybox
if use netboot ; then
- dosym busybox /bin/sh
- dosym busybox /sbin/init
+ dosym /bin/busybox /bin/sh
+ dodir /sbin
+ dosym /bin/busybox /sbin/init
return 0
fi
if use make-busybox-symlinks ; then