summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2015-03-16 06:09:26 +0000
committerJeroen Roovers <jer@gentoo.org>2015-03-16 06:09:26 +0000
commitcf71836f826d516096b12a60b76a474b2b2f5cb2 (patch)
treef6de24c14c7fbd7ce51b0bfc2239966c3bd4c8dc /sys-apps
parentEAPI=5 (diff)
downloadgentoo-2-cf71836f826d516096b12a60b76a474b2b2f5cb2.tar.gz
gentoo-2-cf71836f826d516096b12a60b76a474b2b2f5cb2.tar.bz2
gentoo-2-cf71836f826d516096b12a60b76a474b2b2f5cb2.zip
Version bump.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/pv/ChangeLog9
-rw-r--r--sys-apps/pv/pv-1.6.0.ebuild44
2 files changed, 51 insertions, 2 deletions
diff --git a/sys-apps/pv/ChangeLog b/sys-apps/pv/ChangeLog
index d3db4bb1c59a..707d6743da48 100644
--- a/sys-apps/pv/ChangeLog
+++ b/sys-apps/pv/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/pv
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pv/ChangeLog,v 1.106 2014/11/04 10:01:05 jer Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pv/ChangeLog,v 1.107 2015/03/16 06:09:26 jer Exp $
+
+*pv-1.6.0 (16 Mar 2015)
+
+ 16 Mar 2015; Jeroen Roovers <jer@gentoo.org> +pv-1.6.0.ebuild:
+ Version bump.
04 Nov 2014; Jeroen Roovers <jer@gentoo.org> -pv-1.5.3.ebuild:
Old.
diff --git a/sys-apps/pv/pv-1.6.0.ebuild b/sys-apps/pv/pv-1.6.0.ebuild
new file mode 100644
index 000000000000..3039e52ac85b
--- /dev/null
+++ b/sys-apps/pv/pv-1.6.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pv/pv-1.6.0.ebuild,v 1.1 2015/03/16 06:09:26 jer Exp $
+
+EAPI=5
+inherit toolchain-funcs
+
+DESCRIPTION="Pipe Viewer: a tool for monitoring the progress of data through a pipe"
+HOMEPAGE="http://www.ivarch.com/programs/pv.shtml"
+SRC_URI="http://www.ivarch.com/programs/sources/${P}.tar.bz2"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc64-solaris ~x86-solaris"
+IUSE="debug nls"
+
+PV_LINGUAS=( de fr pl pt )
+IUSE+=" ${PV_LINGUAS[@]/#/linguas_}"
+
+DOCS=( README doc/NEWS doc/TODO )
+
+src_prepare() {
+ sed -i configure -e 's|CFLAGS="-g -Wall"|:|g' || die
+ # These should produce the same end result (working `pv`).
+ sed -i \
+ -e 's:$(LD) $(LDFLAGS) -o:$(AR) rc:' \
+ autoconf/make/modules.mk~ || die
+}
+
+src_configure() {
+ tc-export AR
+ local lingua
+ for lingua in ${PV_LINGUAS[@]}; do
+ if ! use linguas_${lingua}; then
+ sed -i configure -e "/ALL_LINGUAS=/s:${lingua}::g" || die
+ fi
+ done
+ econf $(use_enable debug debugging) $(use_enable nls)
+}
+
+src_test() {
+ sed -i -e 's:usleep 200000 || ::g' tests/019-remote-cksum || die
+ default
+}