summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2003-02-10 03:58:12 +0000
committerBrandon Low <lostlogic@gentoo.org>2003-02-10 03:58:12 +0000
commitd007a41623a97ccc9347e3eb2800fa1c2619df29 (patch)
treee13dde00b194826152262071b341803eee4df80c /sys-apps
parentadd ~alpha (diff)
downloadgentoo-2-d007a41623a97ccc9347e3eb2800fa1c2619df29.tar.gz
gentoo-2-d007a41623a97ccc9347e3eb2800fa1c2619df29.tar.bz2
gentoo-2-d007a41623a97ccc9347e3eb2800fa1c2619df29.zip
fix for only 2.5 systems
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/module-init-tools/ChangeLog5
-rw-r--r--sys-apps/module-init-tools/module-init-tools-0.9.9.ebuild14
-rw-r--r--sys-apps/module-init-tools/module-init-tools-0.9.9_pre1.ebuild13
3 files changed, 19 insertions, 13 deletions
diff --git a/sys-apps/module-init-tools/ChangeLog b/sys-apps/module-init-tools/ChangeLog
index 1dbaa670f253..4a9d4f2eae51 100644
--- a/sys-apps/module-init-tools/ChangeLog
+++ b/sys-apps/module-init-tools/ChangeLog
@@ -1,9 +1,12 @@
# ChangeLog for sys-apps/module-init-tools
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/module-init-tools/ChangeLog,v 1.9 2003/02/01 20:21:15 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/module-init-tools/ChangeLog,v 1.10 2003/02/10 03:58:12 lostlogic Exp $
*module-init-tools-0.9.9 (01 Feb 2003)
+ 09 Feb 2003; Brandon Low <lostlogic@gentoo.org> module-init-tools-0.9.9 :
+ Make not die if the user doesn't have a modules.conf file already...
+
01 Feb 2003; Martin Schlemmer <azarah@gentoo.org> module-init-tools-0.9.9 :
New version.
diff --git a/sys-apps/module-init-tools/module-init-tools-0.9.9.ebuild b/sys-apps/module-init-tools/module-init-tools-0.9.9.ebuild
index f3d2aa8d0a98..4a1659f01681 100644
--- a/sys-apps/module-init-tools/module-init-tools-0.9.9.ebuild
+++ b/sys-apps/module-init-tools/module-init-tools-0.9.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/module-init-tools/module-init-tools-0.9.9.ebuild,v 1.1 2003/02/01 20:21:15 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/module-init-tools/module-init-tools-0.9.9.ebuild,v 1.2 2003/02/10 03:58:12 lostlogic Exp $
# This includes backwards compatability for stable kernels
IUSE=""
@@ -76,11 +76,13 @@ src_install () {
# Create the new modprobe.conf
dodir /etc
- einfo "Generating /etc/modprobe.conf ..."
- PATH="${D}/sbin:${PATH}" \
- ${S}/generate-modprobe.conf ${D}/etc/modprobe.conf \
- || die "Could not create modprobe.conf"
-
+
+ if [ -f /etc/modules.conf ]; then
+ einfo "Generating /etc/modprobe.conf ..."
+ PATH="${D}/sbin:${PATH}" \
+ ${S}/generate-modprobe.conf ${D}/etc/modprobe.conf \
+ || die "Could not create modprobe.conf"
+ fi
dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
}
diff --git a/sys-apps/module-init-tools/module-init-tools-0.9.9_pre1.ebuild b/sys-apps/module-init-tools/module-init-tools-0.9.9_pre1.ebuild
index b031dd1c19bd..c3529efcb7d9 100644
--- a/sys-apps/module-init-tools/module-init-tools-0.9.9_pre1.ebuild
+++ b/sys-apps/module-init-tools/module-init-tools-0.9.9_pre1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/module-init-tools/module-init-tools-0.9.9_pre1.ebuild,v 1.2 2003/01/19 21:21:58 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/module-init-tools/module-init-tools-0.9.9_pre1.ebuild,v 1.3 2003/02/10 03:58:12 lostlogic Exp $
# This includes backwards compatability for stable kernels
IUSE=""
@@ -89,11 +89,12 @@ src_install () {
# Create the new modprobe.conf
dodir /etc
- einfo "Generating /etc/modprobe.conf ..."
- PATH="${D}/sbin:${PATH}" \
- ${S}/generate-modprobe.conf /etc/modules.conf \
- > ${D}/etc/modprobe.conf || die "Could not create modprobe.conf"
-
+ if [ -f /etc/modules.conf ]; then
+ einfo "Generating /etc/modprobe.conf ..."
+ PATH="${D}/sbin:${PATH}" \
+ ${S}/generate-modprobe.conf /etc/modules.conf \
+ > ${D}/etc/modprobe.conf || die "Could not create modprobe.conf"
+ fi
dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
}