summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda XU <heroxbd@gentoo.org>2012-09-29 03:15:54 +0000
committerBenda XU <heroxbd@gentoo.org>2012-09-29 03:15:54 +0000
commitdc2feee4233bb0cdcfd31bd15ab18d0aed98fa04 (patch)
tree579558e48ad98d7d947ccf5d1aef3ee4df024bf1 /sys-apps
parentDrop LIBDIR_* assignments. They're set by features/multilib. (diff)
downloadgentoo-2-dc2feee4233bb0cdcfd31bd15ab18d0aed98fa04.tar.gz
gentoo-2-dc2feee4233bb0cdcfd31bd15ab18d0aed98fa04.tar.bz2
gentoo-2-dc2feee4233bb0cdcfd31bd15ab18d0aed98fa04.zip
make_args should be called only once; ED -> D in src_install to avoid double prefix. close 415899
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/openrc/ChangeLog6
-rw-r--r--sys-apps/openrc/openrc-9999.ebuild8
2 files changed, 9 insertions, 5 deletions
diff --git a/sys-apps/openrc/ChangeLog b/sys-apps/openrc/ChangeLog
index 932fb9a4c557..ecf3307727c9 100644
--- a/sys-apps/openrc/ChangeLog
+++ b/sys-apps/openrc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/openrc
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/openrc/ChangeLog,v 1.229 2012/09/28 22:05:15 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/openrc/ChangeLog,v 1.230 2012/09/29 03:15:54 heroxbd Exp $
+
+ 29 Sep 2012; Benda Xu <heroxbd@gentoo.org> openrc-9999.ebuild:
+ make_args should be called only once; ED -> D in src_install to avoid double
+ prefix. close 415899
28 Sep 2012; William Hubbs <williamh@gentoo.org> openrc-9999.ebuild:
fix typo
diff --git a/sys-apps/openrc/openrc-9999.ebuild b/sys-apps/openrc/openrc-9999.ebuild
index 646c0855a791..10c5b2af152f 100644
--- a/sys-apps/openrc/openrc-9999.ebuild
+++ b/sys-apps/openrc/openrc-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/openrc/openrc-9999.ebuild,v 1.107 2012/09/28 22:05:15 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/openrc/openrc-9999.ebuild,v 1.108 2012/09/29 03:15:54 heroxbd Exp $
EAPI=4
@@ -101,8 +101,8 @@ set_config_yes_no() {
}
src_install() {
- make_args
- emake ${MAKE_ARGS} DESTDIR="${ED}" install
+ [[ -z "${MAKE_ARGS}" ]] && make_args
+ emake ${MAKE_ARGS} DESTDIR="${D}" install
# move the shared libs back to /usr so ldscript can install
# more of a minimal set of files
@@ -212,7 +212,7 @@ pkg_preinst() {
rm -f "${EROOT}"/etc/init.d/clock
fi
if [[ -L ${EROOT}/etc/runlevels/boot/clock ]] ; then
- rm -f "${EROOT}"/etc/runlevels/boot/clock
+ rm -f "${EROOT}"/etc/runlevels/boot/clock
ln -snf /etc/init.d/${clock} "${EROOT}"/etc/runlevels/boot/${clock}
fi
if [[ -L ${EROOT}${LIBDIR}/rc/init.d/started/clock ]] ; then