summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-01-01 08:10:17 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-01-01 08:10:17 +0000
commit642581ff8680b3cf1029e0967fcc06bdde5e41b8 (patch)
treed7210920903f14b484ae073b438932bc361dd65b /sys-auth/keystone/keystone-9999.ebuild
parentxmonad-0.11 release (diff)
downloadgentoo-2-642581ff8680b3cf1029e0967fcc06bdde5e41b8.tar.gz
gentoo-2-642581ff8680b3cf1029e0967fcc06bdde5e41b8.tar.bz2
gentoo-2-642581ff8680b3cf1029e0967fcc06bdde5e41b8.zip
update to eapi5 and distutils-r1
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'sys-auth/keystone/keystone-9999.ebuild')
-rw-r--r--sys-auth/keystone/keystone-9999.ebuild51
1 files changed, 39 insertions, 12 deletions
diff --git a/sys-auth/keystone/keystone-9999.ebuild b/sys-auth/keystone/keystone-9999.ebuild
index 5bb02b2b0389..b8ce770a7748 100644
--- a/sys-auth/keystone/keystone-9999.ebuild
+++ b/sys-auth/keystone/keystone-9999.ebuild
@@ -1,27 +1,27 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/keystone-9999.ebuild,v 1.2 2012/12/31 13:50:34 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/keystone-9999.ebuild,v 1.3 2013/01/01 08:10:17 prometheanfire Exp $
-EAPI=4
+EAPI=5
+#test restricted becaues of bad requirements given (old webob for instance)
+RESTRICT="test"
+PYTHON_COMPAT=( python2_5 python2_6 python2_7 )
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-
-inherit git-2 distutils
+inherit git-2 distutils-r1
DESCRIPTION="Keystone is the Openstack authentication, authorization, and
service catalog written in Python."
HOMEPAGE="https://launchpad.net/keystone"
-EGIT_REPO_URI="https://github.com/openstack/keystone.git"
+SRC_URI="https://github.com/openstack/keystone.git"
LICENSE="Apache-2.0"
SLOT="folsom"
KEYWORDS=""
IUSE="+sqlite mysql postgres ldap"
+#IUSE="+sqlite mysql postgres ldap test"
#todo, seperate out rdepend via use flags
-DEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND="${DEPEND}
dev-python/eventlet
dev-python/greenlet
@@ -47,9 +47,36 @@ RDEPEND="${DEPEND}
sys-auth/keystone[ldap]
) )
"
+# test? ( dev-python/Babel
+# dev-python/decorator
+# dev-python/eventlet
+# dev-python/greenlet
+# dev-python/httplib2
+# dev-python/iso8601
+# dev-python/lxml
+# dev-python/netifaces
+# dev-python/nose
+# dev-python/nosexcover
+# dev-python/passlib
+# dev-python/paste
+# dev-python/pastedeploy
+# dev-python/python-pam
+# dev-python/repoze-lru
+# dev-python/routes
+# dev-python/sphinx
+# >=dev-python/sqlalchemy-migrate-0.7
+# dev-python/tempita
+# >=dev-python/webob-1.0.8
+# dev-python/webtest
+# )
+#PATCHES=( "${FILESDIR}"/keystone_test-requires.patch )
+#
+#python_test() {
+# "${PYTHON}" setup.py nosetests || die
+#}
-src_install() {
- distutils_src_install
+python_install() {
+ distutils-r1_python_install
newconfd "${FILESDIR}/keystone.confd" keystone
newinitd "${FILESDIR}/keystone.initd" keystone