summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2007-09-18 23:25:20 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2007-09-18 23:25:20 +0000
commit190e4f8d3609f30da7e145fc3294a68e6a2f3f2d (patch)
treefd7e257932e25ad39c413886816af1c23a067156 /sys-auth/pam_ldap/pam_ldap-184.ebuild
parentVersion bump per bug #173383. Fixes SIGPIPE issue from bugs #166519, #162355.... (diff)
downloadgentoo-2-190e4f8d3609f30da7e145fc3294a68e6a2f3f2d.tar.gz
gentoo-2-190e4f8d3609f30da7e145fc3294a68e6a2f3f2d.tar.bz2
gentoo-2-190e4f8d3609f30da7e145fc3294a68e6a2f3f2d.zip
Bug #173384, version bump.
(Portage version: 2.1.3.7)
Diffstat (limited to 'sys-auth/pam_ldap/pam_ldap-184.ebuild')
-rw-r--r--sys-auth/pam_ldap/pam_ldap-184.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sys-auth/pam_ldap/pam_ldap-184.ebuild b/sys-auth/pam_ldap/pam_ldap-184.ebuild
new file mode 100644
index 000000000000..34833ec946d9
--- /dev/null
+++ b/sys-auth/pam_ldap/pam_ldap-184.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_ldap/pam_ldap-184.ebuild,v 1.1 2007/09/18 23:25:19 robbat2 Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+
+inherit eutils pam autotools
+
+DESCRIPTION="PAM LDAP Module"
+HOMEPAGE="http://www.padl.com/OSS/pam_ldap.html"
+SRC_URI="http://www.padl.com/download/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 LGPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ssl sasl"
+DEPEND=">=sys-libs/glibc-2.1.3
+ >=sys-libs/pam-0.72
+ >=net-nds/openldap-2.1.30-r5
+ sasl? ( dev-libs/cyrus-sasl )"
+
+src_unpack() {
+ unpack ${A}
+ #EPATCH_OPTS="-p1 -d ${S}" epatch ${FILESDIR}/${PN}-176-fix-referral-tls.patch
+
+ cd "${S}"
+ eautoreconf
+}
+
+src_compile() {
+ econf --with-ldap-lib=openldap `use_enable ssl` || die
+ emake || die
+}
+
+src_install() {
+ dopammod pam_ldap.so
+
+ dodoc pam.conf ldap.conf ldapns.schema chsh chfn certutil
+ dodoc ChangeLog CVSVersionInfo.txt README AUTHORS ns-pwd-policy.schema
+ doman pam_ldap.5
+
+ docinto pam.d
+ dodoc pam.d/*
+}