summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Raghavan <ford_prefect@gentoo.org>2011-09-15 19:47:41 +0000
committerArun Raghavan <ford_prefect@gentoo.org>2011-09-15 19:47:41 +0000
commit69e2b601aaa42b27d814496af2149efa7993a277 (patch)
tree9cd6b5d2f84b1e701753566f83564e58cc139d37 /sys-auth
parentUse libpng.pc instead of versioned pkg-config file to generate Requires.priva... (diff)
downloadgentoo-2-69e2b601aaa42b27d814496af2149efa7993a277.tar.gz
gentoo-2-69e2b601aaa42b27d814496af2149efa7993a277.tar.bz2
gentoo-2-69e2b601aaa42b27d814496af2149efa7993a277.zip
Bump to 0.10, add systemd support, and bump EAPI to 4 while we're at it (thanks to Christoph Brill on bug #372915 for the report and patch).
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/rtkit/ChangeLog8
-rw-r--r--sys-auth/rtkit/rtkit-0.10.ebuild46
2 files changed, 53 insertions, 1 deletions
diff --git a/sys-auth/rtkit/ChangeLog b/sys-auth/rtkit/ChangeLog
index ddab768126ca..ad8a88f8e0a8 100644
--- a/sys-auth/rtkit/ChangeLog
+++ b/sys-auth/rtkit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-auth/rtkit
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/rtkit/ChangeLog,v 1.17 2011/04/16 17:45:01 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/rtkit/ChangeLog,v 1.18 2011/09/15 19:47:41 ford_prefect Exp $
+
+*rtkit-0.10 (15 Sep 2011)
+
+ 15 Sep 2011; Arun Raghavan <ford_prefect@gentoo.org> +rtkit-0.10.ebuild:
+ Bump to 0.10, add systemd support, and bump EAPI to 4 while we're at it
+ (thanks to Christoph Brill on bug #372915 for the report and patch).
16 Apr 2011; Raúl Porcel <armin76@gentoo.org> rtkit-0.9-r1.ebuild:
ia64/sh/x86 stable wrt #360131
diff --git a/sys-auth/rtkit/rtkit-0.10.ebuild b/sys-auth/rtkit/rtkit-0.10.ebuild
new file mode 100644
index 000000000000..290599e19c1e
--- /dev/null
+++ b/sys-auth/rtkit/rtkit-0.10.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/rtkit/rtkit-0.10.ebuild,v 1.1 2011/09/15 19:47:41 ford_prefect Exp $
+
+EAPI="4"
+
+inherit eutils systemd
+
+DESCRIPTION="Realtime Policy and Watchdog Daemon"
+HOMEPAGE="http://0pointer.de/blog/projects/rtkit"
+SRC_URI="http://0pointer.de/public/${P}.tar.gz"
+
+LICENSE="GPL-3 BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND="sys-apps/dbus
+ sys-auth/polkit
+ sys-libs/libcap"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ enewgroup rtkit
+ enewuser rtkit -1 -1 -1 "rtkit"
+}
+
+src_configure() {
+ econf $(systemd_with_unitdir)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ ./rtkit-daemon --introspect > org.freedesktop.RealtimeKit1.xml
+ insinto /usr/share/dbus-1/interfaces
+ doins org.freedesktop.RealtimeKit1.xml
+}
+
+pkg_postinst () {
+ einfo "To start using RealtimeKit, you need to ensure that the 'dbus'"
+ einfo "service is running. If it is already running, you need to reload it"
+ einfo "with the following command:"
+ einfo ""
+ einfo " /etc/init.d/dbus reload"
+}