summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2014-08-19 02:33:41 +0000
committerRick Farina <zerochaos@gentoo.org>2014-08-19 02:33:41 +0000
commitaf9427e33312814f92ae965a688b0b439b8bd244 (patch)
tree2c6d43b4b4ae9bbf12f6613ccc054b18b0c5b64a /sys-auth
parentversion bump, bug 513944 (diff)
downloadgentoo-2-af9427e33312814f92ae965a688b0b439b8bd244.tar.gz
gentoo-2-af9427e33312814f92ae965a688b0b439b8bd244.tar.bz2
gentoo-2-af9427e33312814f92ae965a688b0b439b8bd244.zip
version bump, bug 513944
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key DD11F94A)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/pam_yubico/ChangeLog9
-rw-r--r--sys-auth/pam_yubico/pam_yubico-2.16.ebuild41
2 files changed, 48 insertions, 2 deletions
diff --git a/sys-auth/pam_yubico/ChangeLog b/sys-auth/pam_yubico/ChangeLog
index 62481cdecf08..7fe4d71b44cf 100644
--- a/sys-auth/pam_yubico/ChangeLog
+++ b/sys-auth/pam_yubico/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-auth/pam_yubico
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_yubico/ChangeLog,v 1.3 2013/10/28 13:35:57 zerochaos Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_yubico/ChangeLog,v 1.4 2014/08/19 02:33:41 zerochaos Exp $
+
+*pam_yubico-2.16 (19 Aug 2014)
+
+ 19 Aug 2014; Rick Farina <zerochaos@gentoo.org> +pam_yubico-2.16.ebuild:
+ version bump, bug 513944
*pam_yubico-2.14 (28 Oct 2013)
diff --git a/sys-auth/pam_yubico/pam_yubico-2.16.ebuild b/sys-auth/pam_yubico/pam_yubico-2.16.ebuild
new file mode 100644
index 000000000000..1e5c2c07a71f
--- /dev/null
+++ b/sys-auth/pam_yubico/pam_yubico-2.16.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_yubico/pam_yubico-2.16.ebuild,v 1.1 2014/08/19 02:33:41 zerochaos Exp $
+
+EAPI=5
+inherit multilib
+
+DESCRIPTION="Library for authenticating against PAM with a Yubikey"
+HOMEPAGE="https://github.com/Yubico/yubico-pam"
+SRC_URI="http://opensource.yubico.com/yubico-pam/releases/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ldap"
+
+DEPEND="virtual/pam
+ >=sys-auth/ykclient-2.12
+ >=sys-auth/ykpers-1.6
+ ldap? ( net-nds/openldap )"
+RDEPEND="${DEPEND}"
+
+#src_prepare() {
+# epatch "${FILESDIR}/2.11-drop_privs.patch"
+# eautoreconf
+#}
+
+src_configure() {
+ #challenge response could be optional but that seems horribly dangerous to me
+ econf \
+ --with-cr \
+ $(use_with ldap) \
+ --with-pam-dir=/$(get_libdir)/security
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog NEWS README doc/*
+ #prune_libtool_files #why doesn't this work?
+ find "${D}" -name '*.la' -delete || die
+}