summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2011-11-05 23:03:00 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2011-11-05 23:03:00 +0000
commitf27d287e85fc9efca831674788697f0468bcb7a5 (patch)
tree872dd89969ff8f9580cea400224a37f12e53dd82 /sys-block/open-iscsi/open-iscsi-2.0.871-r1.ebuild
parentStabilize for amd64/x86. (diff)
downloadgentoo-2-f27d287e85fc9efca831674788697f0468bcb7a5.tar.gz
gentoo-2-f27d287e85fc9efca831674788697f0468bcb7a5.tar.bz2
gentoo-2-f27d287e85fc9efca831674788697f0468bcb7a5.zip
Fix linux_chkconfig_module usage to be non-fatal, this package does not build kernel modules. Verified good build with no kernel sources or kernel config available.
(Portage version: 2.2.0_alpha72/cvs/Linux x86_64)
Diffstat (limited to 'sys-block/open-iscsi/open-iscsi-2.0.871-r1.ebuild')
-rw-r--r--sys-block/open-iscsi/open-iscsi-2.0.871-r1.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/sys-block/open-iscsi/open-iscsi-2.0.871-r1.ebuild b/sys-block/open-iscsi/open-iscsi-2.0.871-r1.ebuild
index 5a09c82ca48f..9d06bdc2a9f1 100644
--- a/sys-block/open-iscsi/open-iscsi-2.0.871-r1.ebuild
+++ b/sys-block/open-iscsi/open-iscsi-2.0.871-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/open-iscsi/open-iscsi-2.0.871-r1.ebuild,v 1.7 2011/06/13 01:47:26 sping Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-block/open-iscsi/open-iscsi-2.0.871-r1.ebuild,v 1.8 2011/11/05 23:03:00 robbat2 Exp $
EAPI=2
inherit versionator linux-info eutils flag-o-matic
@@ -34,7 +34,7 @@ pkg_setup() {
CONFIG_CHECK_MODULES="SCSI_ISCSI_ATTRS ISCSI_TCP"
if linux_config_exists; then
for module in ${CONFIG_CHECK_MODULES}; do
- linux_chkconfig_module ${module} || die "${module} needs to be built as module (builtin doesn't work)"
+ linux_chkconfig_module ${module} || ewarn "${module} needs to be built as module (builtin doesn't work)"
done
fi
}