summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-02-25 02:08:22 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-02-25 02:08:22 +0000
commit3f3e22d1b0b2b486bbb6ab06b3a1089d6b0abd1d (patch)
tree378ba3730f09eed24a46d5d071b3b40fa7663c3a /sys-boot/grub
parentVersion bump (diff)
downloadgentoo-2-3f3e22d1b0b2b486bbb6ab06b3a1089d6b0abd1d.tar.gz
gentoo-2-3f3e22d1b0b2b486bbb6ab06b3a1089d6b0abd1d.tar.bz2
gentoo-2-3f3e22d1b0b2b486bbb6ab06b3a1089d6b0abd1d.zip
Fix up all quoting to make repoman happy.
(Portage version: 2.1.4.4)
Diffstat (limited to 'sys-boot/grub')
-rw-r--r--sys-boot/grub/ChangeLog8
-rw-r--r--sys-boot/grub/grub-0.92-r1.ebuild24
-rw-r--r--sys-boot/grub/grub-0.94-r1.ebuild18
-rw-r--r--sys-boot/grub/grub-0.96-r1.ebuild16
-rw-r--r--sys-boot/grub/grub-0.96-r2.ebuild16
-rw-r--r--sys-boot/grub/grub-0.96-r3.ebuild14
-rw-r--r--sys-boot/grub/grub-0.97-r2.ebuild16
-rw-r--r--sys-boot/grub/grub-0.97-r3.ebuild24
-rw-r--r--sys-boot/grub/grub-0.97-r4.ebuild24
-rw-r--r--sys-boot/grub/grub-0.97.ebuild10
10 files changed, 88 insertions, 82 deletions
diff --git a/sys-boot/grub/ChangeLog b/sys-boot/grub/ChangeLog
index 9a1306aa5839..bc1d753a2202 100644
--- a/sys-boot/grub/ChangeLog
+++ b/sys-boot/grub/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-boot/grub
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.75 2008/02/16 22:05:39 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.76 2008/02/25 02:08:22 robbat2 Exp $
+
+ 25 Feb 2008; Robin H. Johnson <robbat2@gentoo.org> grub-0.92-r1.ebuild,
+ grub-0.94-r1.ebuild, grub-0.96-r1.ebuild, grub-0.96-r2.ebuild,
+ grub-0.96-r3.ebuild, grub-0.97.ebuild, grub-0.97-r2.ebuild,
+ grub-0.97-r3.ebuild, grub-0.97-r4.ebuild:
+ Fix up all quoting to make repoman happy.
*grub-1.96 (16 Feb 2008)
diff --git a/sys-boot/grub/grub-0.92-r1.ebuild b/sys-boot/grub/grub-0.92-r1.ebuild
index fbfd1d6968c1..f5d5efad28a2 100644
--- a/sys-boot/grub/grub-0.92-r1.ebuild
+++ b/sys-boot/grub/grub-0.92-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.92-r1.ebuild,v 1.13 2005/07/28 17:53:38 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.92-r1.ebuild,v 1.14 2008/02/25 02:08:22 robbat2 Exp $
inherit mount-boot eutils flag-o-matic toolchain-funcs
@@ -21,18 +21,18 @@ IUSE=""
DEPEND=">=sys-libs/ncurses-5.2-r5"
PROVIDE="virtual/bootloader"
-PATCHDIR=${WORKDIR}/gentoo
+PATCHDIR="${WORKDIR}/gentoo"
src_unpack() {
- unpack ${A} ; cd ${S}
+ unpack ${A} ; cd "${S}"
EPATCH_SUFFIX="patch"
- epatch ${PATCHDIR}
+ epatch "${PATCHDIR}"
if [ "`gcc-version`" = "3.3" ]
then
- epatch ${PATCHDIR}/gcc-3.3
+ epatch "${PATCHDIR}"/gcc-3.3
fi
}
@@ -61,15 +61,15 @@ src_compile() {
src_install() {
make \
- prefix=${D}/usr \
- sbindir=${D}/sbin \
- mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info \
+ prefix="${D}"/usr \
+ sbindir="${D}"/sbin \
+ mandir="${D}"/usr/share/man \
+ infodir="${D}"/usr/share/info \
install || die "Installation failed."
insinto /boot/grub
- doins ${DISTDIR}/splash.xpm.gz
- dodoc AUTHORS BUGS COPYING ChangeLog NEWS README THANKS TODO
+ doins "${DISTDIR}"/splash.xpm.gz
+ dodoc AUTHORS BUGS ChangeLog NEWS README THANKS TODO
}
pkg_postinst() {
diff --git a/sys-boot/grub/grub-0.94-r1.ebuild b/sys-boot/grub/grub-0.94-r1.ebuild
index 01e71b23bcad..4e8821b37d5f 100644
--- a/sys-boot/grub/grub-0.94-r1.ebuild
+++ b/sys-boot/grub/grub-0.94-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.94-r1.ebuild,v 1.24 2005/08/21 02:24:04 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.94-r1.ebuild,v 1.25 2008/02/25 02:08:22 robbat2 Exp $
inherit mount-boot eutils flag-o-matic toolchain-funcs
@@ -36,11 +36,11 @@ pkg_setup() {
}
src_unpack() {
- unpack ${A}; cd ${S}
+ unpack ${A}; cd "${S}"
EPATCH_SUFFIX="patch"
- epatch ${PATCHDIR}
+ epatch "${PATCHDIR}"
}
src_compile() {
@@ -75,7 +75,7 @@ src_compile() {
emake w89c840_o_CFLAGS="-O" || die "making netboot stuff"
- mv stage2/{nbgrub,pxegrub} ${S}
+ mv stage2/{nbgrub,pxegrub} "${S}"
mv stage2/stage2 stage2/stage2.netboot
make clean || die
@@ -91,19 +91,19 @@ src_compile() {
}
src_install() {
- make DESTDIR=${D} install || die
+ make DESTDIR="${D}" install || die
exeinto /usr/lib/grub/${CHOST}
doexe nbgrub pxegrub stage2/stage2 stage2/stage2.netboot
insinto /boot/grub
- doins ${DISTDIR}/splash.xpm.gz
+ doins "${DISTDIR}"/splash.xpm.gz
newins docs/menu.lst grub.conf.sample
- dodoc AUTHORS BUGS COPYING ChangeLog NEWS README THANKS TODO
+ dodoc AUTHORS BUGS ChangeLog NEWS README THANKS TODO
newdoc docs/menu.lst grub.conf.sample
docinto gentoo
- dodoc ${PATCHDIR}/README*
+ dodoc "${PATCHDIR}"/README*
}
pkg_postinst() {
diff --git a/sys-boot/grub/grub-0.96-r1.ebuild b/sys-boot/grub/grub-0.96-r1.ebuild
index 2d483090d9e3..583f0e6ca42c 100644
--- a/sys-boot/grub/grub-0.96-r1.ebuild
+++ b/sys-boot/grub/grub-0.96-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.96-r1.ebuild,v 1.15 2005/08/21 02:24:04 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.96-r1.ebuild,v 1.16 2008/02/25 02:08:22 robbat2 Exp $
inherit mount-boot eutils flag-o-matic toolchain-funcs
@@ -46,7 +46,7 @@ src_unpack() {
unpack ${A} ; cd "${S}"
EPATCH_SUFFIX="patch"
- epatch ${PATCHDIR}
+ epatch "${PATCHDIR}"
# a bunch of patches apply to raw autotool files
autoconf || die "autoconf failed"
@@ -117,18 +117,18 @@ src_install() {
use netboot && doexe nbgrub pxegrub stage2/stage2.netboot
insinto /boot/grub
- doins ${DISTDIR}/splash.xpm.gz
+ doins "${DISTDIR}"/splash.xpm.gz
newins docs/menu.lst grub.conf.sample
- dodoc AUTHORS BUGS COPYING ChangeLog NEWS README THANKS TODO
+ dodoc AUTHORS BUGS ChangeLog NEWS README THANKS TODO
newdoc docs/menu.lst grub.conf.sample
docinto gentoo
- dodoc ${PATCHDIR}/README.Gentoo.patches
+ dodoc "${PATCHDIR}"/README.Gentoo.patches
}
pkg_postinst() {
- [[ ${ROOT} != "/" ]] && return 0
+ [[ "${ROOT}" != "/" ]] && return 0
# change menu.lst to grub.conf
if [[ ! -e /boot/grub/grub.conf && -e /boot/grub/menu.lst ]] ; then
@@ -144,7 +144,7 @@ pkg_postinst() {
einfo "Copying files from /lib/grub and /usr/lib/grub to /boot"
for x in /lib/grub/*/* /usr/lib/grub/*/* ; do
- [[ -f ${x} ]] && cp -p ${x} /boot/grub
+ [[ -f "${x}" ]] && cp -p "${x}" /boot/grub
done
# hardened voodoo
diff --git a/sys-boot/grub/grub-0.96-r2.ebuild b/sys-boot/grub/grub-0.96-r2.ebuild
index f5856e36e4ab..ef7a58c82b75 100644
--- a/sys-boot/grub/grub-0.96-r2.ebuild
+++ b/sys-boot/grub/grub-0.96-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.96-r2.ebuild,v 1.10 2006/02/05 14:44:52 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.96-r2.ebuild,v 1.11 2008/02/25 02:08:22 robbat2 Exp $
inherit mount-boot eutils flag-o-matic toolchain-funcs
@@ -38,7 +38,7 @@ src_unpack() {
unpack ${A} ; cd "${S}"
EPATCH_SUFFIX="patch"
- epatch ${PATCHDIR}
+ epatch "${PATCHDIR}"
# a bunch of patches apply to raw autotool files
autoconf || die "autoconf failed"
@@ -109,18 +109,18 @@ src_install() {
use netboot && doexe nbgrub pxegrub stage2/stage2.netboot
insinto /boot/grub
- doins ${DISTDIR}/splash.xpm.gz
+ doins "${DISTDIR}"/splash.xpm.gz
newins docs/menu.lst grub.conf.sample
- dodoc AUTHORS BUGS COPYING ChangeLog NEWS README THANKS TODO
+ dodoc AUTHORS BUGS ChangeLog NEWS README THANKS TODO
newdoc docs/menu.lst grub.conf.sample
docinto gentoo
- dodoc ${PATCHDIR}/README*
+ dodoc "${PATCHDIR}"/README*
}
pkg_postinst() {
- [[ ${ROOT} != "/" ]] && return 0
+ [[ "${ROOT}" != "/" ]] && return 0
# change menu.lst to grub.conf
if [[ ! -e /boot/grub/grub.conf && -e /boot/grub/menu.lst ]] ; then
@@ -136,7 +136,7 @@ pkg_postinst() {
einfo "Copying files from /lib/grub and /usr/lib/grub to /boot"
for x in /lib/grub/*/* /usr/lib/grub/*/* ; do
- [[ -f ${x} ]] && cp -p ${x} /boot/grub
+ [[ -f "${x}" ]] && cp -p "${x}" /boot/grub
done
[[ -e /boot/grub/grub.conf ]] \
diff --git a/sys-boot/grub/grub-0.96-r3.ebuild b/sys-boot/grub/grub-0.96-r3.ebuild
index 28145f4d89da..219535b7710c 100644
--- a/sys-boot/grub/grub-0.96-r3.ebuild
+++ b/sys-boot/grub/grub-0.96-r3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.96-r3.ebuild,v 1.3 2005/08/21 02:24:04 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.96-r3.ebuild,v 1.4 2008/02/25 02:08:22 robbat2 Exp $
inherit mount-boot eutils flag-o-matic toolchain-funcs
@@ -116,18 +116,18 @@ src_install() {
use netboot && doexe nbgrub pxegrub stage2/stage2.netboot
insinto /boot/grub
- doins ${DISTDIR}/splash.xpm.gz
+ doins "${DISTDIR}"/splash.xpm.gz
newins docs/menu.lst grub.conf.sample
- dodoc AUTHORS BUGS COPYING ChangeLog NEWS README THANKS TODO
+ dodoc AUTHORS BUGS ChangeLog NEWS README THANKS TODO
newdoc docs/menu.lst grub.conf.sample
docinto gentoo
- dodoc ${PATCHDIR}/README*
+ dodoc "${PATCHDIR}"/README*
}
pkg_postinst() {
- [[ ${ROOT} != "/" ]] && return 0
+ [[ "${ROOT}" != "/" ]] && return 0
# change menu.lst to grub.conf
if [[ ! -e /boot/grub/grub.conf && -e /boot/grub/menu.lst ]] ; then
@@ -143,7 +143,7 @@ pkg_postinst() {
einfo "Copying files from /lib/grub and /usr/lib/grub to /boot"
for x in /lib/grub/*/* /usr/lib/grub/*/* ; do
- [[ -f ${x} ]] && cp -p ${x} /boot/grub
+ [[ -f "${x}" ]] && cp -p "${x}" /boot/grub
done
[[ -e /boot/grub/grub.conf ]] \
diff --git a/sys-boot/grub/grub-0.97-r2.ebuild b/sys-boot/grub/grub-0.97-r2.ebuild
index 5dd50bbd89e1..5350f7b8a7cb 100644
--- a/sys-boot/grub/grub-0.97-r2.ebuild
+++ b/sys-boot/grub/grub-0.97-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.97-r2.ebuild,v 1.10 2006/11/27 00:35:21 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.97-r2.ebuild,v 1.11 2008/02/25 02:08:22 robbat2 Exp $
inherit mount-boot eutils flag-o-matic toolchain-funcs
@@ -123,11 +123,11 @@ src_install() {
setup_boot_dir() {
local dir="${1}"
- [[ ! -e ${dir} ]] && die "${dir} does not exist!"
- [[ ! -e ${dir}/grub ]] && mkdir "${dir}/grub"
+ [[ ! -e "${dir}" ]] && die "${dir} does not exist!"
+ [[ ! -e "${dir}"/grub ]] && mkdir "${dir}/grub"
# change menu.lst to grub.conf
- if [[ ! -e ${dir}/grub/grub.conf ]] && [[ -e ${dir}/grub/menu.lst ]] ; then
+ if [[ ! -e "${dir}"/grub/grub.conf ]] && [[ -e "${dir}"/grub/menu.lst ]] ; then
mv -f "${dir}"/grub/menu.lst "${dir}"/grub/grub.conf
ewarn
ewarn "*** IMPORTANT NOTE: menu.lst has been renamed to grub.conf"
@@ -143,7 +143,7 @@ setup_boot_dir() {
einfo "Copying files from /lib/grub and /usr/lib/grub to "${dir}""
for x in /lib*/grub/*/* /usr/lib*/grub/*/* ; do
- [[ -f ${x} ]] && cp -p ${x} "${dir}"/grub/
+ [[ -f "${x}" ]] && cp -p "${x}" "${dir}"/grub/
done
if [[ -e "${dir}"/grub/grub.conf ]] ; then
@@ -155,7 +155,7 @@ setup_boot_dir() {
}
pkg_postinst() {
- [[ ${ROOT} != "/" ]] && return 0
+ [[ "${ROOT}" != "/" ]] && return 0
setup_boot_dir /boot
einfo "To install grub files to another device (like a usb stick), just run:"
einfo " emerge --config =${PF}"
@@ -165,5 +165,5 @@ pkg_config() {
local dir
einfo "Enter the directory where you want to setup grub:"
read dir
- setup_boot_dir ${dir}
+ setup_boot_dir "${dir}"
}
diff --git a/sys-boot/grub/grub-0.97-r3.ebuild b/sys-boot/grub/grub-0.97-r3.ebuild
index 328dafd280e0..c9871889c857 100644
--- a/sys-boot/grub/grub-0.97-r3.ebuild
+++ b/sys-boot/grub/grub-0.97-r3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.97-r3.ebuild,v 1.10 2007/05/25 05:05:11 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.97-r3.ebuild,v 1.11 2008/02/25 02:08:22 robbat2 Exp $
inherit mount-boot eutils flag-o-matic toolchain-funcs autotools
@@ -113,30 +113,30 @@ src_install() {
setup_boot_dir() {
local dir="${1}"
- [[ ! -e ${dir} ]] && die "${dir} does not exist!"
- [[ ! -e ${dir}/grub ]] && mkdir "${dir}/grub"
+ [[ ! -e "${dir}" ]] && die "${dir} does not exist!"
+ [[ ! -e "${dir}"/grub ]] && mkdir "${dir}/grub"
# change menu.lst to grub.conf
- if [[ ! -e ${dir}/grub/grub.conf ]] && [[ -e ${dir}/grub/menu.lst ]] ; then
+ if [[ ! -e "${dir}"/grub/grub.conf ]] && [[ -e "${dir}"/grub/menu.lst ]] ; then
mv -f "${dir}"/grub/menu.lst "${dir}"/grub/grub.conf
ewarn
ewarn "*** IMPORTANT NOTE: menu.lst has been renamed to grub.conf"
ewarn
fi
- if [[ ! -e ${dir}/grub/menu.lst ]]; then
+ if [[ ! -e "${dir}"/grub/menu.lst ]]; then
einfo "Linking from new grub.conf name to menu.lst"
ln -snf grub.conf "${dir}"/grub/menu.lst
fi
- [[ -e ${dir}/grub/stage2 ]] && mv "${dir}"/grub/stage2{,.old}
+ [[ -e "${dir}"/grub/stage2 ]] && mv "${dir}"/grub/stage2{,.old}
- einfo "Copying files from /lib/grub and /usr/lib/grub to "${dir}""
+ einfo "Copying files from /lib/grub and /usr/lib/grub to ${dir}"
for x in /lib*/grub/*/* /usr/lib*/grub/*/* ; do
- [[ -f ${x} ]] && cp -p ${x} "${dir}"/grub/
+ [[ -f "${x}" ]] && cp -p "${x}" "${dir}"/grub/
done
- if [[ -e ${dir}/grub/grub.conf ]] ; then
+ if [[ -e "${dir}"/grub/grub.conf ]] ; then
egrep \
-v '^[[:space:]]*(#|$|default|fallback|initrd|password|splashimage|timeout|title)' \
"${dir}"/grub/grub.conf | \
@@ -147,7 +147,7 @@ setup_boot_dir() {
}
pkg_postinst() {
- [[ ${ROOT} != "/" ]] && return 0
+ [[ "${ROOT}" != "/" ]] && return 0
[[ -n ${DONT_MOUNT_BOOT} ]] && return 0
setup_boot_dir /boot
einfo "To install grub files to another device (like a usb stick), just run:"
@@ -158,5 +158,5 @@ pkg_config() {
local dir
einfo "Enter the directory where you want to setup grub:"
read dir
- setup_boot_dir ${dir}
+ setup_boot_dir "${dir}"
}
diff --git a/sys-boot/grub/grub-0.97-r4.ebuild b/sys-boot/grub/grub-0.97-r4.ebuild
index bdde1c97af30..948ab84554c9 100644
--- a/sys-boot/grub/grub-0.97-r4.ebuild
+++ b/sys-boot/grub/grub-0.97-r4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.97-r4.ebuild,v 1.1 2008/02/25 01:44:37 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.97-r4.ebuild,v 1.2 2008/02/25 02:08:22 robbat2 Exp $
inherit mount-boot eutils flag-o-matic toolchain-funcs autotools
@@ -115,30 +115,30 @@ src_install() {
setup_boot_dir() {
local dir="${1}"
- [[ ! -e ${dir} ]] && die "${dir} does not exist!"
- [[ ! -e ${dir}/grub ]] && mkdir "${dir}/grub"
+ [[ ! -e "${dir}" ]] && die "${dir} does not exist!"
+ [[ ! -e "${dir}"/grub ]] && mkdir "${dir}/grub"
# change menu.lst to grub.conf
- if [[ ! -e ${dir}/grub/grub.conf ]] && [[ -e ${dir}/grub/menu.lst ]] ; then
+ if [[ ! -e "${dir}"/grub/grub.conf ]] && [[ -e "${dir}"/grub/menu.lst ]] ; then
mv -f "${dir}"/grub/menu.lst "${dir}"/grub/grub.conf
ewarn
ewarn "*** IMPORTANT NOTE: menu.lst has been renamed to grub.conf"
ewarn
fi
- if [[ ! -e ${dir}/grub/menu.lst ]]; then
+ if [[ ! -e "${dir}"/grub/menu.lst ]]; then
einfo "Linking from new grub.conf name to menu.lst"
ln -snf grub.conf "${dir}"/grub/menu.lst
fi
- [[ -e ${dir}/grub/stage2 ]] && mv "${dir}"/grub/stage2{,.old}
+ [[ -e "${dir}"/grub/stage2 ]] && mv "${dir}"/grub/stage2{,.old}
- einfo "Copying files from /lib/grub and /usr/lib/grub to "${dir}""
+ einfo "Copying files from /lib/grub and /usr/lib/grub to ${dir}"
for x in /lib*/grub/*/* /usr/lib*/grub/*/* ; do
- [[ -f ${x} ]] && cp -p ${x} "${dir}"/grub/
+ [[ -f "${x}" ]] && cp -p "${x}" "${dir}"/grub/
done
- if [[ -e ${dir}/grub/grub.conf ]] ; then
+ if [[ -e "${dir}"/grub/grub.conf ]] ; then
egrep \
-v '^[[:space:]]*(#|$|default|fallback|initrd|password|splashimage|timeout|title)' \
"${dir}"/grub/grub.conf | \
@@ -149,7 +149,7 @@ setup_boot_dir() {
}
pkg_postinst() {
- [[ ${ROOT} != "/" ]] && return 0
+ [[ "${ROOT}" != "/" ]] && return 0
[[ -n ${DONT_MOUNT_BOOT} ]] && return 0
setup_boot_dir /boot
einfo "To install grub files to another device (like a usb stick), just run:"
@@ -160,5 +160,5 @@ pkg_config() {
local dir
einfo "Enter the directory where you want to setup grub:"
read dir
- setup_boot_dir ${dir}
+ setup_boot_dir "${dir}"
}
diff --git a/sys-boot/grub/grub-0.97.ebuild b/sys-boot/grub/grub-0.97.ebuild
index 2ca8af3edd43..14ecf1f5830c 100644
--- a/sys-boot/grub/grub-0.97.ebuild
+++ b/sys-boot/grub/grub-0.97.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.97.ebuild,v 1.2 2005/08/21 02:24:04 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.97.ebuild,v 1.3 2008/02/25 02:08:22 robbat2 Exp $
inherit mount-boot eutils flag-o-matic toolchain-funcs
@@ -125,11 +125,11 @@ src_install() {
newdoc docs/menu.lst grub.conf.sample
docinto gentoo
- dodoc ${PATCHDIR}/README*
+ dodoc "${PATCHDIR}"/README*
}
pkg_postinst() {
- [[ ${ROOT} != "/" ]] && return 0
+ [[ "${ROOT}" != "/" ]] && return 0
# change menu.lst to grub.conf
if [[ ! -e /boot/grub/grub.conf && -e /boot/grub/menu.lst ]] ; then
@@ -145,7 +145,7 @@ pkg_postinst() {
einfo "Copying files from /lib/grub and /usr/lib/grub to /boot"
for x in /lib/grub/*/* /usr/lib/grub/*/* ; do
- [[ -f ${x} ]] && cp -p ${x} /boot/grub
+ [[ -f "${x}" ]] && cp -p "${x}" /boot/grub
done
[[ -e /boot/grub/grub.conf ]] \