summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-09-08 06:13:23 +0000
committerMike Frysinger <vapier@gentoo.org>2006-09-08 06:13:23 +0000
commit5a9a4e3135207440b4f36301eb6a4a3af85d5dc0 (patch)
tree43fb21ef822d6afc14a354db6aa5a7087a6a837e /sys-boot/grub
parentuse new multilib style (diff)
downloadgentoo-2-5a9a4e3135207440b4f36301eb6a4a3af85d5dc0.tar.gz
gentoo-2-5a9a4e3135207440b4f36301eb6a4a3af85d5dc0.tar.bz2
gentoo-2-5a9a4e3135207440b4f36301eb6a4a3af85d5dc0.zip
Grab a bunch of patches from Debian.
(Portage version: 2.1.1_rc1-r6)
Diffstat (limited to 'sys-boot/grub')
-rw-r--r--sys-boot/grub/ChangeLog7
-rw-r--r--sys-boot/grub/files/digest-grub-0.97-r39
-rw-r--r--sys-boot/grub/grub-0.97-r3.ebuild165
3 files changed, 180 insertions, 1 deletions
diff --git a/sys-boot/grub/ChangeLog b/sys-boot/grub/ChangeLog
index 856d072facc1..8191208736f6 100644
--- a/sys-boot/grub/ChangeLog
+++ b/sys-boot/grub/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/grub
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.66 2006/08/30 05:14:08 tsunam Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.67 2006/09/08 06:13:23 vapier Exp $
+
+*grub-0.97-r3 (08 Sep 2006)
+
+ 08 Sep 2006; Mike Frysinger <vapier@gentoo.org> +grub-0.97-r3.ebuild:
+ Grab a bunch of patches from Debian.
30 Aug 2006; Joshua Jackson <tsunam@gentoo.org> grub-0.97-r2.ebuild:
Stable x86; bug #144998
diff --git a/sys-boot/grub/files/digest-grub-0.97-r3 b/sys-boot/grub/files/digest-grub-0.97-r3
new file mode 100644
index 000000000000..1a217f08f67d
--- /dev/null
+++ b/sys-boot/grub/files/digest-grub-0.97-r3
@@ -0,0 +1,9 @@
+MD5 a5b91d09a7a941b347e60c0796913a35 grub-0.97-patches-1.3.tar.bz2 24317
+RMD160 9cbea5ed4a5bfdd7a6c785d02adfc64f5a76dc4d grub-0.97-patches-1.3.tar.bz2 24317
+SHA256 2a9cf0b5507c9b7dc7ccb787e3883e5e8baa324a63a79322eb81f2f594fda411 grub-0.97-patches-1.3.tar.bz2 24317
+MD5 cd3f3eb54446be6003156158d51f4884 grub-0.97.tar.gz 971783
+RMD160 7fb5674edf0c950bd38e94f85ff1e2909aa741f0 grub-0.97.tar.gz 971783
+SHA256 4e1d15d12dbd3e9208111d6b806ad5a9857ca8850c47877d36575b904559260b grub-0.97.tar.gz 971783
+MD5 cdd6c89d48982ecd544c0b4774755afd splash.xpm.gz 33856
+RMD160 2fead61f91c368429e80936248bb02af2bdf15ff splash.xpm.gz 33856
+SHA256 b95600f777331b0dd31d51c68f60f0e846e4c8b628857a41165f4e6b30e6acaf splash.xpm.gz 33856
diff --git a/sys-boot/grub/grub-0.97-r3.ebuild b/sys-boot/grub/grub-0.97-r3.ebuild
new file mode 100644
index 000000000000..d3791d21ea20
--- /dev/null
+++ b/sys-boot/grub/grub-0.97-r3.ebuild
@@ -0,0 +1,165 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.97-r3.ebuild,v 1.1 2006/09/08 06:13:23 vapier Exp $
+
+inherit mount-boot eutils flag-o-matic toolchain-funcs
+
+PATCHVER="1.3"
+DESCRIPTION="GNU GRUB Legacy boot loader"
+HOMEPAGE="http://www.gnu.org/software/grub/"
+SRC_URI="mirror://gentoo/${P}.tar.gz
+ ftp://alpha.gnu.org/gnu/${PN}/${P}.tar.gz
+ mirror://gentoo/splash.xpm.gz
+ mirror://gentoo/${P}-patches-${PATCHVER}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static netboot custom-cflags"
+
+RDEPEND=">=sys-libs/ncurses-5.2-r5"
+DEPEND="${RDEPEND}
+ >=sys-devel/automake-1.7
+ >=sys-devel/autoconf-2.5"
+PROVIDE="virtual/bootloader"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # patch breaks booting for some people #111885
+ rm "${WORKDIR}"/patch/400_*
+
+ if [[ -n ${PATCHVER} ]] ; then
+ EPATCH_SUFFIX="patch"
+ epatch "${WORKDIR}"/patch
+
+ # a bunch of patches apply to raw autotool files
+ autoconf || die "autoconf failed"
+ aclocal || die "aclocal failed"
+ automake || die "automake failed"
+ fi
+}
+
+src_compile() {
+ use amd64 && multilib_toolchain_setup x86
+
+ unset BLOCK_SIZE #73499
+
+ ### i686-specific code in the boot loader is a bad idea; disabling to ensure
+ ### at least some compatibility if the hard drive is moved to an older or
+ ### incompatible system.
+
+ # grub-0.95 added -fno-stack-protector detection, to disable ssp for stage2,
+ # but the objcopy's (faulty) test fails if -fstack-protector is default.
+ # create a cache telling configure that objcopy is ok, and add -C to econf
+ # to make use of the cache.
+ #
+ # CFLAGS has to be undefined running econf, else -fno-stack-protector detection fails.
+ # STAGE2_CFLAGS is not allowed to be used on emake command-line, it overwrites
+ # -fno-stack-protector detected by configure, removed from netboot's emake.
+ use custom-cflags || unset CFLAGS
+
+ export grub_cv_prog_objcopy_absolute=yes #79734
+ use static && append-ldflags -static
+
+ # build the net-bootable grub first, but only if "netboot" is set
+ if use netboot ; then
+ econf \
+ --libdir=/lib \
+ --datadir=/usr/lib/grub \
+ --exec-prefix=/ \
+ --disable-auto-linux-mem-opt \
+ --enable-diskless \
+ --enable-{3c{5{03,07,09,29,95},90x},cs89x0,davicom,depca,eepro{,100}} \
+ --enable-{epic100,exos205,ni5210,lance,ne2100,ni{50,65}10,natsemi} \
+ --enable-{ne,ns8390,wd,otulip,rtl8139,sis900,sk-g16,smc9000,tiara} \
+ --enable-{tulip,via-rhine,w89c840} || die "netboot econf failed"
+
+ emake w89c840_o_CFLAGS="-O" || die "making netboot stuff"
+
+ mv -f stage2/{nbgrub,pxegrub} "${S}"/
+ mv -f stage2/stage2 stage2/stage2.netboot
+
+ make clean || die "make clean failed"
+ fi
+
+ # Now build the regular grub
+ # Note that FFS and UFS2 support are broken for now - stage1_5 files too big
+ econf \
+ --libdir=/lib \
+ --datadir=/usr/lib/grub \
+ --exec-prefix=/ \
+ --disable-auto-linux-mem-opt || die "econf failed"
+ emake || die "making regular stuff"
+}
+
+src_test() {
+ # non-default block size also give false pass/fails.
+ unset BLOCK_SIZE
+ make check || die "make check failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ if use netboot ; then
+ exeinto /usr/lib/grub/${CHOST}
+ doexe nbgrub pxegrub stage2/stage2.netboot || die "netboot install"
+ fi
+
+ insinto /boot/grub
+ doins "${DISTDIR}"/splash.xpm.gz
+ newins docs/menu.lst grub.conf.sample
+
+ dodoc AUTHORS BUGS ChangeLog NEWS README THANKS TODO
+ newdoc docs/menu.lst grub.conf.sample
+}
+
+setup_boot_dir() {
+ local dir="${1}"
+
+ [[ ! -e "${dir}" ]] && die "${dir} does not exist!"
+
+ [[ ! -e "${dir}/grub" ]] && mkdir "${dir}/grub"
+
+ # change menu.lst to grub.conf
+ if [[ ! -e "${dir}/grub/grub.conf" && -e "${dir}/grub/menu.lst" ]] ; then
+ mv -f "${dir}/grub/menu.lst ${dir}/grub/grub.conf"
+ ewarn
+ ewarn "*** IMPORTANT NOTE: menu.lst has been renamed to grub.conf"
+ ewarn
+ fi
+
+ if [[ ! -e "${dir}"/grub/menu.lst ]]; then
+ einfo "Linking from new grub.conf name to menu.lst"
+ ln -snf grub.conf "${dir}/grub/menu.lst"
+ fi
+
+ [[ -e "${dir}"/grub/stage2 ]] && mv "${dir}"/grub/stage2{,.old}
+
+ einfo "Copying files from /lib/grub and /usr/lib/grub to "${dir}""
+ for x in /lib*/grub/*/* /usr/lib*/grub/*/* ; do
+ [[ -f ${x} ]] && cp -p ${x} "${dir}"/grub/
+ done
+
+ if [[ -e "${dir}"/grub/grub.conf ]] ; then
+ egrep -v '^[[:space:]]*(#|$|default|fallback|splashimage|timeout|title)' "${dir}"/grub/grub.conf | \
+ /sbin/grub --batch \
+ --device-map="${dir}"/grub/device.map \
+ > /dev/null
+ fi
+}
+
+pkg_postinst() {
+ [[ ${ROOT} != "/" ]] && return 0
+ setup_boot_dir /boot
+ einfo "To install grub files to another device (like a usb stick), just run:"
+ einfo " emerge --config =${PF}"
+}
+
+pkg_config() {
+ local dir
+ einfo "Enter the directory where you want to setup grub:"
+ read dir
+ setup_boot_dir ${dir}
+}