summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-07-22 18:29:50 +0000
committerMike Gilbert <floppym@gentoo.org>2012-07-22 18:29:50 +0000
commit7206d805af160bdf8f4cef35b41257e8e2d018ae (patch)
treeb0978bb7944b4351aa18d0e0563f3e3c70e9b433 /sys-boot/grub
parentAdd division by zero error fix from upstream. (diff)
downloadgentoo-2-7206d805af160bdf8f4cef35b41257e8e2d018ae.tar.gz
gentoo-2-7206d805af160bdf8f4cef35b41257e8e2d018ae.tar.bz2
gentoo-2-7206d805af160bdf8f4cef35b41257e8e2d018ae.zip
Replace previous patch with better version from upstream.
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'sys-boot/grub')
-rw-r--r--sys-boot/grub/ChangeLog7
-rw-r--r--sys-boot/grub/files/grub-2.00-config-quoting.patch113
-rw-r--r--sys-boot/grub/files/grub-2.00-gettext_printf.patch14
-rw-r--r--sys-boot/grub/grub-2.00.ebuild4
-rw-r--r--sys-boot/grub/grub-9999.ebuild4
5 files changed, 123 insertions, 19 deletions
diff --git a/sys-boot/grub/ChangeLog b/sys-boot/grub/ChangeLog
index daa172ac1276..421ccc0a5512 100644
--- a/sys-boot/grub/ChangeLog
+++ b/sys-boot/grub/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/grub
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.230 2012/07/22 16:43:04 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.231 2012/07/22 18:29:50 floppym Exp $
+
+ 22 Jul 2012; Mike Gilbert <floppym@gentoo.org>
+ +files/grub-2.00-config-quoting.patch, -files/grub-2.00-gettext_printf.patch,
+ grub-2.00.ebuild, grub-9999.ebuild:
+ Replace previous patch with better version from upstream.
22 Jul 2012; Mike Gilbert <floppym@gentoo.org>
+files/grub-2.00-gettext_printf.patch, grub-2.00.ebuild, grub-9999.ebuild:
diff --git a/sys-boot/grub/files/grub-2.00-config-quoting.patch b/sys-boot/grub/files/grub-2.00-config-quoting.patch
new file mode 100644
index 000000000000..3b031c626456
--- /dev/null
+++ b/sys-boot/grub/files/grub-2.00-config-quoting.patch
@@ -0,0 +1,113 @@
+https://bugs.gentoo.org/show_bug.cgi?id=426364
+https://savannah.gnu.org/bugs/index.php?36839
+--- util/grub-mkconfig_lib.in
++++ util/grub-mkconfig_lib.in
+@@ -255,19 +255,19 @@
+ echo "$version_find_latest_a"
+ }
+
+-# One layer of quotation is eaten by "", the second by sed, and the third by
+-# printf; so this turns ' into \'. Note that you must use the output of
++# One layer of quotation is eaten by "" and the second by
++# sed; so this turns ' into \'. Note that you must use the output of
+ # this function in a printf format string.
+
+ grub_quote () {
+- sed "s/'/'\\\\\\\\''/g"
++ sed "s/'/'\\\\''/g"
+ }
+
+ gettext_quoted () {
+- gettext "$@" | sed "s/'/'\\\\\\\\''/g"
++ gettext "$@" | grub_quote
+ }
+
+-# Run the first argument through gettext_quoted, and then pass that and all
++# Run the first argument through gettext, and then pass that and all
+ # remaining arguments to printf. This is a useful abbreviation and tends to
+ # be easier to type.
+ gettext_printf () {
+
+=== modified file 'util/grub.d/10_hurd.in'
+--- util/grub.d/10_hurd.in
++++ util/grub.d/10_hurd.in
+@@ -117,7 +117,7 @@
+ opts=
+ fi
+ sed "s/^/$submenu_indentation/" << EOF
+- echo '$message'
++ echo '$(echo "$message" | grub_quote)'
+ multiboot ${kernel} root=device:${GRUB_DEVICE#/dev/} $opts ${GRUB_CMDLINE_GNUMACH}
+ EOF
+
+@@ -133,7 +133,7 @@
+ fi
+
+ sed "s/^/$submenu_indentation/" << EOF
+- echo '$message'
++ echo '$(echo "$message" | grub_quote)'
+ module /hurd/${hurd_fs}.static ${hurd_fs} $opts \\
+ --multiboot-command-line='\${kernel-command-line}' \\
+ --host-priv-port='\${host-port}' \\
+--- util/grub.d/10_illumos.in
++++ util/grub.d/10_illumos.in
+@@ -46,6 +46,7 @@
+ ISADIR=
+ fi
+ zfs-bootfs $($grub_mkrelpath /) ZFS_BOOTFS
++ echo '$(echo "$message" | grub_quote)'
+ multiboot $($grub_mkrelpath /platform/i86pc/kernel)/\$ISADIR/unix /platform/i86pc/kernel/\$ISADIR/unix -B \$ZFS_BOOTFS,console=text
+ module $($grub_mkrelpath /platform/i86pc)/\$ISADIR/boot_archive /platform/i86pc/\$ISADIR/boot_archive
+ }
+--- util/grub.d/10_kfreebsd.in
++++ util/grub.d/10_kfreebsd.in
+@@ -100,7 +100,7 @@
+ printf '%s\n' "${prepare_boot_cache}" | sed "s/^/$submenu_indentation/"
+ message="$(gettext_printf "Loading kernel of FreeBSD %s ..." ${version})"
+ sed "s/^/$submenu_indentation/" << EOF
+- echo '$message'
++ echo '$(echo "$message" | grub_quote)'
+ kfreebsd ${rel_dirname}/${basename} ${args}
+ EOF
+
+--- util/grub.d/10_linux.in
++++ util/grub.d/10_linux.in
+@@ -134,14 +134,14 @@
+ fi
+ message="$(gettext_printf "Loading Linux %s ..." ${version})"
+ sed "s/^/$submenu_indentation/" << EOF
+- echo '$message'
++ echo '$(echo "$message" | grub_quote)'
+ linux ${rel_dirname}/${basename} root=${linux_root_device_thisversion} ro ${args}
+ EOF
+ if test -n "${initrd}" ; then
+ # TRANSLATORS: ramdisk isn't identifier. Should be translated.
+ message="$(gettext_printf "Loading initial ramdisk ...")"
+ sed "s/^/$submenu_indentation/" << EOF
+- echo '$message'
++ echo '$(echo "$message" | grub_quote)'
+ initrd ${rel_dirname}/${initrd}
+ EOF
+ fi
+--- util/grub.d/20_linux_xen.in
++++ util/grub.d/20_linux_xen.in
+@@ -120,16 +120,16 @@
+ xmessage="$(gettext_printf "Loading Xen %s ..." ${xen_version})"
+ lmessage="$(gettext_printf "Loading Linux %s ..." ${version})"
+ sed "s/^/$submenu_indentation/" << EOF
+- echo '$xmessage'
++ echo '$(echo "$xmessage" | grub_quote)'
+ multiboot ${rel_xen_dirname}/${xen_basename} placeholder ${xen_args}
+- echo '$lmessage'
++ echo '$(echo "$lmessage" | grub_quote)'
+ module ${rel_dirname}/${basename} placeholder root=${linux_root_device_thisversion} ro ${args}
+ EOF
+ if test -n "${initrd}" ; then
+ # TRANSLATORS: ramdisk isn't identifier. Should be translated.
+ message="$(gettext_printf "Loading initial ramdisk ...")"
+ sed "s/^/$submenu_indentation/" << EOF
+- echo '$message'
++ echo '$(echo "$message" | grub_quote)'
+ module ${rel_dirname}/${initrd}
+ EOF
+ fi
diff --git a/sys-boot/grub/files/grub-2.00-gettext_printf.patch b/sys-boot/grub/files/grub-2.00-gettext_printf.patch
deleted file mode 100644
index 41068c42216e..000000000000
--- a/sys-boot/grub/files/grub-2.00-gettext_printf.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-https://bugs.gentoo.org/show_bug.cgi?id=426364
-https://savannah.gnu.org/bugs/index.php?36839
---- util/grub-mkconfig_lib.in
-+++ util/grub-mkconfig_lib.in
-@@ -273,7 +273,7 @@
- gettext_printf () {
- gettext_printf_format="$1"
- shift
-- printf "$(gettext "$gettext_printf_format")" "$@"
-+ printf "$(gettext_quoted "$gettext_printf_format")" "$@"
- }
-
- uses_abstraction () {
-
diff --git a/sys-boot/grub/grub-2.00.ebuild b/sys-boot/grub/grub-2.00.ebuild
index 0140ab3acc89..fa6a85b708a3 100644
--- a/sys-boot/grub/grub-2.00.ebuild
+++ b/sys-boot/grub/grub-2.00.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-2.00.ebuild,v 1.15 2012/07/22 16:43:04 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-2.00.ebuild,v 1.16 2012/07/22 18:29:50 floppym Exp $
EAPI=4
@@ -219,7 +219,7 @@ src_prepare() {
if [[ ${PV} != 9999 ]]; then
epatch "${FILESDIR}/${P}-parallel-make.patch" #424231
epatch "${FILESDIR}/${P}-no-gets.patch" #424703
- epatch "${FILESDIR}/${P}-gettext_printf.patch" #426364
+ epatch "${FILESDIR}/${P}-config-quoting.patch" #426364
fi
# fix texinfo file name, bug 416035
diff --git a/sys-boot/grub/grub-9999.ebuild b/sys-boot/grub/grub-9999.ebuild
index 9e9aab40d9e6..56daa8c45b3c 100644
--- a/sys-boot/grub/grub-9999.ebuild
+++ b/sys-boot/grub/grub-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-9999.ebuild,v 1.80 2012/07/22 16:43:04 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-9999.ebuild,v 1.81 2012/07/22 18:29:50 floppym Exp $
EAPI=4
@@ -219,7 +219,7 @@ src_prepare() {
if [[ ${PV} != 9999 ]]; then
epatch "${FILESDIR}/${P}-parallel-make.patch" #424231
epatch "${FILESDIR}/${P}-no-gets.patch" #424703
- epatch "${FILESDIR}/${P}-gettext_printf.patch" #426364
+ epatch "${FILESDIR}/${P}-config-quoting.patch" #426364
fi
# fix texinfo file name, bug 416035