summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2009-11-01 15:37:22 +0000
committerJeroen Roovers <jer@gentoo.org>2009-11-01 15:37:22 +0000
commit160cf4fffaa3006f3547d7a738e7e91bd16b38b9 (patch)
treef204a80374ec5fbfdb068a63e44b016246acc5b5 /sys-boot
parentExternal sqlite needs to be 3.6.16 (diff)
downloadgentoo-2-160cf4fffaa3006f3547d7a738e7e91bd16b38b9.tar.gz
gentoo-2-160cf4fffaa3006f3547d7a738e7e91bd16b38b9.tar.bz2
gentoo-2-160cf4fffaa3006f3547d7a738e7e91bd16b38b9.zip
Version bump.
(Portage version: 2.2_rc48/cvs/Linux i686)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/syslinux/ChangeLog7
-rw-r--r--sys-boot/syslinux/syslinux-3.83.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/sys-boot/syslinux/ChangeLog b/sys-boot/syslinux/ChangeLog
index 202def5fd251..ff048f9b4195 100644
--- a/sys-boot/syslinux/ChangeLog
+++ b/sys-boot/syslinux/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/syslinux
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/ChangeLog,v 1.47 2009/09/14 10:49:54 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/ChangeLog,v 1.48 2009/11/01 15:37:22 jer Exp $
+
+*syslinux-3.83 (01 Nov 2009)
+
+ 01 Nov 2009; Jeroen Roovers <jer@gentoo.org> +syslinux-3.83.ebuild:
+ Version bump.
*syslinux-3.82-r1 (14 Sep 2009)
diff --git a/sys-boot/syslinux/syslinux-3.83.ebuild b/sys-boot/syslinux/syslinux-3.83.ebuild
new file mode 100644
index 000000000000..772997ed85eb
--- /dev/null
+++ b/sys-boot/syslinux/syslinux-3.83.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/syslinux-3.83.ebuild,v 1.1 2009/11/01 15:37:22 jer Exp $
+
+inherit eutils
+
+DESCRIPTION="SysLinux, IsoLinux and PXELinux bootloader"
+HOMEPAGE="http://syslinux.zytor.com/"
+SRC_URI="mirror://kernel/linux/utils/boot/syslinux/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+RDEPEND="sys-fs/mtools
+ dev-perl/Crypt-PasswdMD5
+ dev-perl/Digest-SHA1"
+DEPEND="${RDEPEND}
+ dev-lang/nasm"
+
+# This ebuild is a departure from the old way of rebuilding everything in syslinux
+# This departure is necessary since hpa doesn't support the rebuilding of anything other
+# than the installers.
+
+# removed all the unpack/patching stuff since we aren't rebuilding the core stuff anymore
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-3.72-nopie.patch
+ # Don't prestrip, makes portage angry
+ epatch "${FILESDIR}"/${PN}-3.72-nostrip.patch
+
+ rm -f gethostip #bug 137081
+}
+
+src_compile() {
+ emake installer || die
+}
+
+src_install() {
+ emake INSTALLSUBDIRS=utils INSTALLROOT="${D}" MANDIR=/usr/share/man install || die
+ dodoc README NEWS TODO doc/*
+}