summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-08-20 22:44:26 +0000
committerJeroen Roovers <jer@gentoo.org>2014-08-20 22:44:26 +0000
commit7061ec32fdfbd6139732a5084ad288e5329ec7ed (patch)
treefac85172fc167e602bad0d78ad06eca7e52e469e /sys-boot
parentbumped EAPI to 5; committed directly to stable as no other changes present an... (diff)
downloadgentoo-2-7061ec32fdfbd6139732a5084ad288e5329ec7ed.tar.gz
gentoo-2-7061ec32fdfbd6139732a5084ad288e5329ec7ed.tar.bz2
gentoo-2-7061ec32fdfbd6139732a5084ad288e5329ec7ed.zip
Old.
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/unetbootin/ChangeLog6
-rw-r--r--sys-boot/unetbootin/unetbootin-585.ebuild88
-rw-r--r--sys-boot/unetbootin/unetbootin-603.ebuild90
-rw-r--r--sys-boot/unetbootin/unetbootin-608.ebuild5
4 files changed, 7 insertions, 182 deletions
diff --git a/sys-boot/unetbootin/ChangeLog b/sys-boot/unetbootin/ChangeLog
index cc7ac3bea116..8fd6683fae45 100644
--- a/sys-boot/unetbootin/ChangeLog
+++ b/sys-boot/unetbootin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-boot/unetbootin
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/unetbootin/ChangeLog,v 1.107 2014/08/20 19:00:42 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/unetbootin/ChangeLog,v 1.108 2014/08/20 22:44:26 jer Exp $
+
+ 20 Aug 2014; Jeroen Roovers <jer@gentoo.org> -unetbootin-585.ebuild,
+ -unetbootin-603.ebuild:
+ Old.
20 Aug 2014; Johannes Huber <johu@gentoo.org> unetbootin-608.ebuild:
amd64 stable, bug #511158
diff --git a/sys-boot/unetbootin/unetbootin-585.ebuild b/sys-boot/unetbootin/unetbootin-585.ebuild
deleted file mode 100644
index 1bc6d813fbe9..000000000000
--- a/sys-boot/unetbootin/unetbootin-585.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/unetbootin/unetbootin-585.ebuild,v 1.4 2013/09/30 17:14:28 ago Exp $
-
-EAPI=5
-
-inherit eutils qt4-r2
-
-DESCRIPTION="Universal Netboot Installer creates Live USB systems for various OS
-distributions."
-HOMEPAGE="http://unetbootin.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${PN}-source-${PV}.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-UNBI_LINGUAS="
- am ar ast be bg bn ca cs da de el eo es et eu fa fi fo fr gl he hr hu id it
- ja lt lv ml ms nan nb nl nn pl pt_BR pt ro ru si sk sl sr sv sw tr uk ur vi
- zh_CN zh_TW
-"
-
-for lingua in ${UNBI_LINGUAS}; do
- IUSE="${IUSE} linguas_${lingua}"
-done
-
-S="${WORKDIR}"
-
-DEPEND="dev-qt/qtgui:4"
-RDEPEND="${DEPEND}
- sys-fs/mtools
- <sys-boot/syslinux-5
- app-arch/p7zip"
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-581-desktop.patch"
-
- # QA check in case linguas are added or removed
- enum() {
- echo ${#}
- }
- [[ $(enum ${UNBI_LINGUAS}) -eq $(( $(enum $(echo ${PN}_*.ts) ) -1 )) ]] \
- || die "Numbers of recorded and actual linguas do not match"
- unset enum
-
- # Make room between the last line of TRANSLATIONS and the next definition
- sed -i \
- -e '/^DEFINES/s|.*|\n&|g' \
- ${PN}.pro || die
-
- # Remove localisations
- local lingua
- for lingua in ${UNBI_LINGUAS}; do
- if ! use linguas_${lingua}; then
- sed -i ${PN}.pro -e "/\.*${PN}_${lingua}\.ts.*/d" || die
- rm ${PN}_${lingua}.ts || die
- fi
- done
-}
-
-src_configure() {
- lupdate ${PN}.pro || die
- lrelease ${PN}.pro || die
- eqmake4 ${PN}.pro || die
-}
-
-src_install() {
- dobin ${PN}
-
- domenu ${PN}.desktop
-
- for file in ${PN}*.png; do
- size="${file/${PN}_}"
- size="${size/.png}x${size/.png}"
- insinto /usr/share/icons/hicolor/${size}/apps
- newins ${file} ${PN}.png
- done
-
- local lingua
- for lingua in ${UNBI_LINGUAS}; do
- if use linguas_${lingua}; then
- insinto /usr/share/${PN}
- doins ${PN}_${lingua}.qm
- fi
- done
-}
diff --git a/sys-boot/unetbootin/unetbootin-603.ebuild b/sys-boot/unetbootin/unetbootin-603.ebuild
deleted file mode 100644
index 0c5f1e925c41..000000000000
--- a/sys-boot/unetbootin/unetbootin-603.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/unetbootin/unetbootin-603.ebuild,v 1.1 2014/04/22 15:14:56 jer Exp $
-
-EAPI=5
-
-inherit eutils qt4-r2
-
-DESCRIPTION="Universal Netboot Installer creates Live USB systems for various OS
-distributions."
-HOMEPAGE="http://unetbootin.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${PN}-source-${PV}.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-UNBI_LINGUAS="
- am ar ast be bg bn ca cs da de el eo es et eu fa fi fo fr gl he hr hu id it
- ja lt lv ml ms nan nb nl nn pl pt_BR pt ro ru si sk sl sr sv sw tr uk ur vi
- zh_CN zh_TW
-"
-
-for lingua in ${UNBI_LINGUAS}; do
- IUSE="${IUSE} linguas_${lingua}"
-done
-
-S="${WORKDIR}"
-
-DEPEND="dev-qt/qtgui:4"
-RDEPEND="
- ${DEPEND}
- sys-fs/mtools
- <sys-boot/syslinux-5
- app-arch/p7zip
-"
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-581-desktop.patch"
-
- # QA check in case linguas are added or removed
- enum() {
- echo ${#}
- }
- [[ $(enum ${UNBI_LINGUAS}) -eq $(( $(enum $(echo ${PN}_*.ts) ) -1 )) ]] \
- || die "Numbers of recorded and actual linguas do not match"
- unset enum
-
- # Make room between the last line of TRANSLATIONS and the next definition
- sed -i \
- -e '/^DEFINES/s|.*|\n&|g' \
- ${PN}.pro || die
-
- # Remove localisations
- local lingua
- for lingua in ${UNBI_LINGUAS}; do
- if ! use linguas_${lingua}; then
- sed -i ${PN}.pro -e "/\.*${PN}_${lingua}\.ts.*/d" || die
- rm ${PN}_${lingua}.ts || die
- fi
- done
-}
-
-src_configure() {
- lupdate ${PN}.pro || die
- lrelease ${PN}.pro || die
- eqmake4 ${PN}.pro || die
-}
-
-src_install() {
- dobin ${PN}
-
- domenu ${PN}.desktop
-
- for file in ${PN}*.png; do
- size="${file/${PN}_}"
- size="${size/.png}x${size/.png}"
- insinto /usr/share/icons/hicolor/${size}/apps
- newins ${file} ${PN}.png
- done
-
- local lingua
- for lingua in ${UNBI_LINGUAS}; do
- if use linguas_${lingua}; then
- insinto /usr/share/${PN}
- doins ${PN}_${lingua}.qm
- fi
- done
-}
diff --git a/sys-boot/unetbootin/unetbootin-608.ebuild b/sys-boot/unetbootin/unetbootin-608.ebuild
index d65a2667f52a..3befd1ae0336 100644
--- a/sys-boot/unetbootin/unetbootin-608.ebuild
+++ b/sys-boot/unetbootin/unetbootin-608.ebuild
@@ -1,13 +1,12 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/unetbootin/unetbootin-608.ebuild,v 1.3 2014/08/20 19:00:42 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/unetbootin/unetbootin-608.ebuild,v 1.4 2014/08/20 22:44:26 jer Exp $
EAPI=5
inherit eutils qt4-r2
-DESCRIPTION="Universal Netboot Installer creates Live USB systems for various OS
-distributions."
+DESCRIPTION="Universal Netboot Installer creates Live USB systems for various OS distributions"
HOMEPAGE="http://unetbootin.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${PN}-source-${PV}.tar.gz"