summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@gentoo.org>2013-07-01 23:28:25 +0000
committerJustin Bronder <jsbronder@gentoo.org>2013-07-01 23:28:25 +0000
commitba1a69a27b5e550e0c36ff5312fd67117ce02fcd (patch)
tree497907118fd97e29f8fd9baa4e6df3933f794c75 /sys-cluster/hpl
parentVersion bump for security bug #472280. (diff)
downloadgentoo-2-ba1a69a27b5e550e0c36ff5312fd67117ce02fcd.tar.gz
gentoo-2-ba1a69a27b5e550e0c36ff5312fd67117ce02fcd.tar.bz2
gentoo-2-ba1a69a27b5e550e0c36ff5312fd67117ce02fcd.zip
Respect CFLAGS (#452984). Remove old.
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 4D7043C9)
Diffstat (limited to 'sys-cluster/hpl')
-rw-r--r--sys-cluster/hpl/ChangeLog8
-rw-r--r--sys-cluster/hpl/hpl-2.0-r2.ebuild65
-rw-r--r--sys-cluster/hpl/hpl-2.0-r3.ebuild (renamed from sys-cluster/hpl/hpl-2.0-r1.ebuild)3
3 files changed, 9 insertions, 67 deletions
diff --git a/sys-cluster/hpl/ChangeLog b/sys-cluster/hpl/ChangeLog
index 7d9384b52932..afa39cac2fdf 100644
--- a/sys-cluster/hpl/ChangeLog
+++ b/sys-cluster/hpl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-cluster/hpl
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/hpl/ChangeLog,v 1.19 2013/02/27 15:57:37 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/hpl/ChangeLog,v 1.20 2013/07/01 23:28:25 jsbronder Exp $
+
+*hpl-2.0-r3 (01 Jul 2013)
+
+ 01 Jul 2013; Justin Bronder <jsbronder@gentoo.org> -hpl-2.0-r1.ebuild,
+ -hpl-2.0-r2.ebuild, +hpl-2.0-r3.ebuild:
+ Respect CFLAGS (#452984). Remove old.
*hpl-2.0-r2 (27 Feb 2013)
diff --git a/sys-cluster/hpl/hpl-2.0-r2.ebuild b/sys-cluster/hpl/hpl-2.0-r2.ebuild
deleted file mode 100644
index 7aec0ca0be7c..000000000000
--- a/sys-cluster/hpl/hpl-2.0-r2.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/hpl/hpl-2.0-r2.ebuild,v 1.1 2013/02/27 15:57:37 jlec Exp $
-
-EAPI=4
-
-inherit eutils multilib
-
-DESCRIPTION="A Portable Implementation of the High-Performance Linpack Benchmark for Distributed-Memory Computers"
-HOMEPAGE="http://www.netlib.org/benchmark/hpl/"
-SRC_URI="http://www.netlib.org/benchmark/hpl/hpl-${PV}.tar.gz"
-
-SLOT="0"
-LICENSE="HPL"
-KEYWORDS="~x86 ~amd64"
-IUSE="doc"
-
-RDEPEND="
- virtual/blas
- virtual/lapack
- virtual/mpi"
-DEPEND="${DEPEND}
- virtual/pkgconfig"
-
-src_prepare() {
- local a=""
- local locallib="${EPREFIX}/usr/$(get_libdir)/lib"
- local localblas="$(for i in $($(tc-getPKG_CONFIG) --libs-only-l blas lapack);do a="${a} ${i/-l/${locallib}}.so "; done; echo ${a})"
-
- cp setup/Make.Linux_PII_FBLAS Make.gentoo_hpl_fblas_x86 || die
- sed -i \
- -e "/^TOPdir/s,= .*,= ${S}," \
- -e '/^HPL_OPTS\>/s,=,= -DHPL_DETAILED_TIMING -DHPL_COPY_L,' \
- -e '/^ARCH\>/s,= .*,= gentoo_hpl_fblas_x86,' \
- -e '/^MPdir\>/s,= .*,=,' \
- -e '/^MPlib\>/s,= .*,=,' \
- -e "/^LAlib\>/s,= .*,= ${localblas}," \
- -e '/^LINKER\>/s,= .*,= mpicc,' \
- -e '/^CC\>/s,= .*,= mpicc,' \
- -e "/^LINKFLAGS\>/s|= .*|= ${LDFLAGS}|" \
- Make.gentoo_hpl_fblas_x86 || die
-}
-
-src_compile() {
- # parallel make failure bug #321539
- HOME=${WORKDIR} emake -j1 arch=gentoo_hpl_fblas_x86
-}
-
-src_install() {
- dobin bin/gentoo_hpl_fblas_x86/xhpl
- dolib lib/gentoo_hpl_fblas_x86/libhpl.a
- dodoc INSTALL BUGS COPYRIGHT HISTORY README TUNING \
- bin/gentoo_hpl_fblas_x86/HPL.dat
- doman man/man3/*.3
- if use doc; then
- dohtml -r www/*
- fi
-}
-
-pkg_postinst() {
- einfo "Remember to copy /usr/share/hpl/HPL.dat to your working directory"
- einfo "before running xhpl. Typically one may run hpl by executing:"
- einfo "\"mpiexec -np 4 /usr/bin/xhpl\""
- einfo "where -np specifies the number of processes."
-}
diff --git a/sys-cluster/hpl/hpl-2.0-r1.ebuild b/sys-cluster/hpl/hpl-2.0-r3.ebuild
index f50d003120be..1130b617491e 100644
--- a/sys-cluster/hpl/hpl-2.0-r1.ebuild
+++ b/sys-cluster/hpl/hpl-2.0-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/hpl/hpl-2.0-r1.ebuild,v 1.3 2013/02/27 15:57:37 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/hpl/hpl-2.0-r3.ebuild,v 1.1 2013/07/01 23:28:25 jsbronder Exp $
EAPI=4
@@ -37,6 +37,7 @@ src_prepare() {
-e "/^LAlib\>/s,= .*,= ${localblas}," \
-e '/^LINKER\>/s,= .*,= mpicc,' \
-e '/^CC\>/s,= .*,= mpicc,' \
+ -e '/^CCFLAGS\>/s|= .*|= $(HPL_DEFS) ${CFLAGS}|' \
-e "/^LINKFLAGS\>/s|= .*|= ${LDFLAGS}|" \
Make.gentoo_hpl_fblas_x86 || die
}