summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@gentoo.org>2012-11-02 04:37:25 +0000
committerJustin Bronder <jsbronder@gentoo.org>2012-11-02 04:37:25 +0000
commitfd4c8a63ffdb9474b1856876e49b26f0837eea3e (patch)
treed56619c001fbeb158acccc0ff12b749f210ed86c /sys-cluster/mpich2
parentFix build with glibc-2.16 (bug #426922). (diff)
downloadgentoo-2-fd4c8a63ffdb9474b1856876e49b26f0837eea3e.tar.gz
gentoo-2-fd4c8a63ffdb9474b1856876e49b26f0837eea3e.tar.bz2
gentoo-2-fd4c8a63ffdb9474b1856876e49b26f0837eea3e.zip
bump, fixes #437802
(Portage version: 2.1.11.30/cvs/Linux x86_64, signed Manifest commit with key 4D7043C9)
Diffstat (limited to 'sys-cluster/mpich2')
-rw-r--r--sys-cluster/mpich2/ChangeLog7
-rw-r--r--sys-cluster/mpich2/mpich2-1.5.ebuild111
2 files changed, 117 insertions, 1 deletions
diff --git a/sys-cluster/mpich2/ChangeLog b/sys-cluster/mpich2/ChangeLog
index efa9369e651d..f8ba44ead2b0 100644
--- a/sys-cluster/mpich2/ChangeLog
+++ b/sys-cluster/mpich2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-cluster/mpich2
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/ChangeLog,v 1.80 2012/10/16 18:43:14 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/ChangeLog,v 1.81 2012/11/02 04:37:25 jsbronder Exp $
+
+*mpich2-1.5 (02 Nov 2012)
+
+ 02 Nov 2012; Justin Bronder <jsbronder@gentoo.org> +mpich2-1.5.ebuild:
+ bump
16 Oct 2012; Justin Lecher <jlec@gentoo.org> mpich2-1.2.1_p1-r1.ebuild,
mpich2-1.4_rc2-r1.ebuild, mpich2-1.4.1_p1.ebuild, metadata.xml:
diff --git a/sys-cluster/mpich2/mpich2-1.5.ebuild b/sys-cluster/mpich2/mpich2-1.5.ebuild
new file mode 100644
index 000000000000..d8ac56a1c7e9
--- /dev/null
+++ b/sys-cluster/mpich2/mpich2-1.5.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/mpich2-1.5.ebuild,v 1.1 2012/11/02 04:37:25 jsbronder Exp $
+
+EAPI=5
+
+FORTRAN_NEEDED=fortran
+
+inherit fortran-2
+
+MY_PV=${PV/_/}
+DESCRIPTION="A high performance and portable MPI implementation"
+HOMEPAGE="http://www.mcs.anl.gov/research/projects/mpich2/index.php"
+SRC_URI="http://www.mcs.anl.gov/research/projects/mpich2/downloads/tarballs/${MY_PV}/${PN}-${MY_PV}.tar.gz"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE="+cxx doc fortran mpi-threads romio threads"
+
+COMMON_DEPEND="
+ dev-libs/libaio
+ sys-apps/hwloc
+ romio? ( net-fs/nfs-utils )"
+
+DEPEND="${COMMON_DEPEND}
+ dev-lang/perl
+ sys-devel/libtool"
+
+RDEPEND="${COMMON_DEPEND}
+ !sys-cluster/openmpi"
+
+S="${WORKDIR}"/${PN}-${MY_PV}
+
+pkg_setup() {
+ FORTRAN_STANDARD="77 90"
+ fortran-2_pkg_setup
+
+ if use mpi-threads && ! use threads; then
+ ewarn "mpi-threads requires threads, assuming that's what you want"
+ fi
+}
+
+src_prepare() {
+ # Using MPICH2LIB_LDFLAGS doesn't seem to full work.
+ sed -i 's| *@WRAPPER_LDFLAGS@ *||' \
+ src/packaging/pkgconfig/mpich2.pc.in \
+ src/env/*.in \
+ || die
+}
+
+src_configure() {
+ local c="--enable-shared"
+
+ # The configure statements can be somewhat confusing, as they
+ # don't all show up in the top level configure, however, they
+ # are picked up in the children directories.
+
+ if use mpi-threads; then
+ # MPI-THREAD requries threading.
+ c="${c} --with-thread-package=pthreads"
+ c="${c} --enable-threads=runtime"
+ else
+ if use threads ; then
+ c="${c} --with-thread-package=pthreads"
+ else
+ c="${c} --with-thread-package=none"
+ fi
+ c="${c} --enable-threads=single"
+ fi
+
+ export MPICH2LIB_CFLAGS=${CFLAGS}
+ export MPICH2LIB_CPPFLAGS=${CPPFLAGS}
+ export MPICH2LIB_CXXFLAGS=${CXXFLAGS}
+ export MPICH2LIB_FFLAGS=${FFLAGS}
+ export MPICH2LIB_FCFLAGS=${FCFLAGS}
+ export MPICH2LIB_LDFLAGS=${LDFLAGS}
+ unset CFLAGS CPPFLAGS CXXFLAGS FFLAGS FCFLAGS LDFLAGS
+
+ c="${c} --sysconfdir=${EPREFIX}/etc/${PN}"
+ c="${c} --docdir=${EPREFIX}/usr/share/doc/${PF}"
+ econf ${c} \
+ --with-pm=hydra \
+ --disable-mpe \
+ --disable-fast \
+ --enable-smpcoll \
+ --enable-versioning \
+ $(use_enable romio) \
+ $(use_enable cxx) \
+ $(use_enable fortran f77) \
+ $(use_enable fortran fc)
+}
+
+src_test() {
+ emake -j1 check
+}
+
+src_install() {
+ default
+
+ dodir /usr/share/doc/${PF}
+ dodoc COPYRIGHT README{,.envvar} CHANGES RELEASE_NOTES
+ newdoc src/pm/hydra/README README.hydra
+ if use romio; then
+ newdoc src/mpi/romio/README README.romio
+ fi
+
+ if ! use doc; then
+ rm -rf "${D}"usr/share/doc/${PF}/www*
+ fi
+}