summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2015-03-24 04:13:56 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2015-03-24 04:13:56 +0000
commit57ba487b4ab2555f19c0b0e0fd53cc2cc4ea5a64 (patch)
treee55b9f8c74f09dd775b117d5012e6bc4fdb86d63 /sys-cluster/neutron
parentRecord net-irc/{supybot-plugins,supybot} masked for removal (diff)
downloadgentoo-2-57ba487b4ab2555f19c0b0e0fd53cc2cc4ea5a64.tar.gz
gentoo-2-57ba487b4ab2555f19c0b0e0fd53cc2cc4ea5a64.tar.bz2
gentoo-2-57ba487b4ab2555f19c0b0e0fd53cc2cc4ea5a64.zip
newer module naming bug 532848
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x33ED3FD25AFC78BA)
Diffstat (limited to 'sys-cluster/neutron')
-rw-r--r--sys-cluster/neutron/ChangeLog6
-rw-r--r--sys-cluster/neutron/neutron-2014.2.2-r1.ebuild8
-rw-r--r--sys-cluster/neutron/neutron-2014.2.9999.ebuild8
3 files changed, 13 insertions, 9 deletions
diff --git a/sys-cluster/neutron/ChangeLog b/sys-cluster/neutron/ChangeLog
index 39d06f1225bf..bf944de9c432 100644
--- a/sys-cluster/neutron/ChangeLog
+++ b/sys-cluster/neutron/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-cluster/neutron
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/neutron/ChangeLog,v 1.54 2015/02/13 00:58:41 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/neutron/ChangeLog,v 1.55 2015/03/24 04:13:56 prometheanfire Exp $
+
+ 24 Mar 2015; Matthew Thode <prometheanfire@gentoo.org>
+ neutron-2014.2.2-r1.ebuild, neutron-2014.2.9999.ebuild:
+ newer module naming bug 532848
*neutron-2014.2.2-r1 (13 Feb 2015)
diff --git a/sys-cluster/neutron/neutron-2014.2.2-r1.ebuild b/sys-cluster/neutron/neutron-2014.2.2-r1.ebuild
index bb8d5ce9562d..3c9d514be49a 100644
--- a/sys-cluster/neutron/neutron-2014.2.2-r1.ebuild
+++ b/sys-cluster/neutron/neutron-2014.2.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/neutron/neutron-2014.2.2-r1.ebuild,v 1.1 2015/02/13 00:58:41 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/neutron/neutron-2014.2.2-r1.ebuild,v 1.2 2015/03/24 04:13:56 prometheanfire Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -106,9 +106,9 @@ PATCHES=(
pkg_setup() {
linux-info_pkg_setup
- CONFIG_CHECK_MODULES="8021Q IP6TABLE_FILTER IP6_TABLES IPT_REJECT \
- IPTABLE_MANGLE IPT_MASQUERADE IPTABLE_NAT NF_CONNTRACK_IPV4 NF_DEFRAG_IPV4 \
- NF_NAT_IPV4 NF_NAT NF_CONNTRACK IPTABLE_FILTER IP_TABLES X_TABLES"
+ CONFIG_CHECK_MODULES="VLAN_8021Q IP6_NF_FILTER IP6_NF_IPTABLES IP_NF_TARGET_REJECT \
+ IP_NF_MANGLE IP_NF_TARGET_MASQUERADE NF_NAT_IPV4 NF_CONNTRACK_IPV4 NF_DEFRAG_IPV4 \
+ NF_NAT_IPV4 NF_NAT NF_CONNTRACK IP_NF_FILTER IP_NF_IPTABLES NETFILTER_XTABLES"
if linux_config_exists; then
for module in ${CONFIG_CHECK_MODULES}; do
linux_chkconfig_present ${module} || ewarn "${module} needs to be enabled in kernel"
diff --git a/sys-cluster/neutron/neutron-2014.2.9999.ebuild b/sys-cluster/neutron/neutron-2014.2.9999.ebuild
index 5b7d25e7782a..a33563e4fd20 100644
--- a/sys-cluster/neutron/neutron-2014.2.9999.ebuild
+++ b/sys-cluster/neutron/neutron-2014.2.9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/neutron/neutron-2014.2.9999.ebuild,v 1.10 2015/02/13 00:58:41 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/neutron/neutron-2014.2.9999.ebuild,v 1.11 2015/03/24 04:13:56 prometheanfire Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -107,9 +107,9 @@ PATCHES=(
pkg_setup() {
linux-info_pkg_setup
- CONFIG_CHECK_MODULES="8021Q IP6TABLE_FILTER IP6_TABLES IPT_REJECT \
- IPTABLE_MANGLE IPT_MASQUERADE IPTABLE_NAT NF_CONNTRACK_IPV4 NF_DEFRAG_IPV4 \
- NF_NAT_IPV4 NF_NAT NF_CONNTRACK IPTABLE_FILTER IP_TABLES X_TABLES"
+ CONFIG_CHECK_MODULES="VLAN_8021Q IP6_NF_FILTER IP6_NF_IPTABLES IP_NF_TARGET_REJECT \
+ IP_NF_MANGLE IP_NF_TARGET_MASQUERADE NF_NAT_IPV4 NF_CONNTRACK_IPV4 NF_DEFRAG_IPV4 \
+ NF_NAT_IPV4 NF_NAT NF_CONNTRACK IP_NF_FILTER IP_NF_IPTABLES NETFILTER_XTABLES"
if linux_config_exists; then
for module in ${CONFIG_CHECK_MODULES}; do
linux_chkconfig_present ${module} || ewarn "${module} needs to be enabled in kernel"