summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@gentoo.org>2012-02-03 20:16:12 +0000
committerJustin Bronder <jsbronder@gentoo.org>2012-02-03 20:16:12 +0000
commitaff023d4ad265c38ac64f6901bff743db67f4bfc (patch)
tree55c28779b60906c817d32ec241b0c00dba1b62fa /sys-cluster/openmpi
parentImport from ::perl-experimental for rt-4 (#235914) (diff)
downloadgentoo-2-aff023d4ad265c38ac64f6901bff743db67f4bfc.tar.gz
gentoo-2-aff023d4ad265c38ac64f6901bff743db67f4bfc.tar.bz2
gentoo-2-aff023d4ad265c38ac64f6901bff743db67f4bfc.zip
cleanup old
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster/openmpi')
-rw-r--r--sys-cluster/openmpi/ChangeLog7
-rw-r--r--sys-cluster/openmpi/openmpi-1.5.3-r1.ebuild111
-rw-r--r--sys-cluster/openmpi/openmpi-1.5.3-r2.ebuild119
-rw-r--r--sys-cluster/openmpi/openmpi-1.5.3.ebuild107
-rw-r--r--sys-cluster/openmpi/openmpi-1.5.4-r1.ebuild123
-rw-r--r--sys-cluster/openmpi/openmpi-1.5.4.ebuild121
6 files changed, 6 insertions, 582 deletions
diff --git a/sys-cluster/openmpi/ChangeLog b/sys-cluster/openmpi/ChangeLog
index ccceec8e3a3b..b47e5f4c09ab 100644
--- a/sys-cluster/openmpi/ChangeLog
+++ b/sys-cluster/openmpi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-cluster/openmpi
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/ChangeLog,v 1.95 2012/01/20 13:15:19 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/ChangeLog,v 1.96 2012/02/03 20:16:12 jsbronder Exp $
+
+ 03 Feb 2012; Justin Bronder <jsbronder@gentoo.org> -openmpi-1.5.3.ebuild,
+ -openmpi-1.5.3-r1.ebuild, -openmpi-1.5.3-r2.ebuild, -openmpi-1.5.4.ebuild,
+ -openmpi-1.5.4-r1.ebuild:
+ cleanup old
*openmpi-1.5.4-r2 (20 Jan 2012)
diff --git a/sys-cluster/openmpi/openmpi-1.5.3-r1.ebuild b/sys-cluster/openmpi/openmpi-1.5.3-r1.ebuild
deleted file mode 100644
index a75ca96c746a..000000000000
--- a/sys-cluster/openmpi/openmpi-1.5.3-r1.ebuild
+++ /dev/null
@@ -1,111 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.5.3-r1.ebuild,v 1.3 2011/07/02 16:37:24 alexxy Exp $
-
-EAPI=3
-inherit eutils fortran-2 multilib flag-o-matic toolchain-funcs
-
-MY_P=${P/-mpi}
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="A high-performance message passing library (MPI)"
-HOMEPAGE="http://www.open-mpi.org"
-SRC_URI="http://www.open-mpi.org/software/ompi/v1.5/downloads/${MY_P}.tar.bz2"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux"
-IUSE="+cxx elibc_FreeBSD fortran heterogeneous infiniband ipv6 mpi-threads pbs romio sctp threads vt"
-RDEPEND="
- fortran? ( virtual/fortran )
- pbs? ( sys-cluster/torque )
- infiniband? ( sys-infiniband/openib )
- sctp? ( net-misc/lksctp-tools )
- vt? (
- !dev-libs/libotf
- !app-text/lcdf-typetools
- )
- elibc_FreeBSD? ( dev-libs/libexecinfo )
- >=sys-apps/hwloc-1.1.1
- !sys-cluster/mpich
- !sys-cluster/lam-mpi
- !sys-cluster/mpich2
- !sys-cluster/mpiexec"
-DEPEND="${RDEPEND}"
-
-pkg_setup() {
- use fortran && fortran-2_pkg_setup
- if use mpi-threads; then
- echo
- ewarn "WARNING: use of MPI_THREAD_MULTIPLE is still disabled by"
- ewarn "default and officially unsupported by upstream."
- ewarn "You may stop now and set USE=-mpi-threads"
- echo
- fi
-
- echo
- elog "OpenMPI has an overwhelming count of configuration options."
- elog "Don't forget the EXTRA_ECONF environment variable can let you"
- elog "specify configure options if you find them necessary."
- echo
-}
-
-src_prepare() {
- # Necessary for scalibility, see
- # http://www.open-mpi.org/community/lists/users/2008/09/6514.php
- if use threads; then
- echo 'oob_tcp_listen_mode = listen_thread' \
- >> opal/etc/openmpi-mca-params.conf
- fi
-
- epatch "${FILESDIR}"/openmpi-r24328.patch
-}
-
-src_configure() {
- local myconf=(
- --sysconfdir="${EPREFIX}/etc/${PN}"
- --enable-pretty-print-stacktrace
- --enable-orterun-prefix-by-default
- --without-slurm
- --with-hwloc="${EPREFIX}/usr"
- )
-
- if use mpi-threads; then
- myconf+=(--enable-mpi-threads
- --enable-progress-threads)
- fi
-
- if use fortran; then
- if [[ $(tc-getFC) =~ g77 ]]; then
- myconf+=(--disable-mpi-f90)
- elif [[ $(tc-getFC) =~ if ]]; then
- # Enabled here as gfortran compile times are huge with this enabled.
- myconf+=(--with-mpi-f90-size=medium)
- fi
- else
- myconf+=(--disable-mpi-f90 --disable-mpi-f77)
- fi
-
- ! use vt && myconf+=(--enable-contrib-no-build=vt)
-
- econf "${myconf[@]}" \
- $(use_enable cxx mpi-cxx) \
- $(use_enable romio io-romio) \
- $(use_enable heterogeneous) \
- $(use_with pbs tm) \
- $(use_enable ipv6) \
- $(use_with infiniband openib) \
- $(use_with sctp sctp)
-}
-
-src_install () {
- emake DESTDIR="${D}" install || die "make install failed"
- # From USE=vt see #359917
- rm "${D}"/usr/share/libtool &> /dev/null
- dodoc README AUTHORS NEWS VERSION || die
-}
-
-src_test() {
- # Doesn't work with the default src_test as the dry run (-n) fails.
- cd "${S}"
- emake -j1 check || die "emake check failed"
-}
diff --git a/sys-cluster/openmpi/openmpi-1.5.3-r2.ebuild b/sys-cluster/openmpi/openmpi-1.5.3-r2.ebuild
deleted file mode 100644
index 66b040e0fe73..000000000000
--- a/sys-cluster/openmpi/openmpi-1.5.3-r2.ebuild
+++ /dev/null
@@ -1,119 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.5.3-r2.ebuild,v 1.2 2011/07/10 17:03:37 aballier Exp $
-
-EAPI=4
-inherit eutils fortran-2 multilib flag-o-matic toolchain-funcs
-
-MY_P=${P/-mpi}
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="A high-performance message passing library (MPI)"
-HOMEPAGE="http://www.open-mpi.org"
-SRC_URI="http://www.open-mpi.org/software/ompi/v1.5/downloads/${MY_P}.tar.bz2"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux"
-IUSE="+cxx elibc_FreeBSD fortran heterogeneous infiniband ipv6 mpi-threads pbs
- romio sctp slurm threads vt"
-
-REQUIRED_USE="^^ (
- ( !slurm !pbs )
- ( slurm !pbs )
- ( !slurm pbs )
- )"
-
-RDEPEND="
- fortran? ( virtual/fortran )
- pbs? ( sys-cluster/torque )
- infiniband? ( sys-infiniband/openib )
- sctp? ( net-misc/lksctp-tools )
- vt? (
- !dev-libs/libotf
- !app-text/lcdf-typetools
- )
- elibc_FreeBSD? ( dev-libs/libexecinfo )
- >=sys-apps/hwloc-1.1.1
- !sys-cluster/mpich
- !sys-cluster/lam-mpi
- !sys-cluster/mpich2
- !sys-cluster/mpiexec"
-DEPEND="${RDEPEND}"
-
-pkg_setup() {
- use fortran && fortran-2_pkg_setup
- if use mpi-threads; then
- echo
- ewarn "WARNING: use of MPI_THREAD_MULTIPLE is still disabled by"
- ewarn "default and officially unsupported by upstream."
- ewarn "You may stop now and set USE=-mpi-threads"
- echo
- fi
-
- echo
- elog "OpenMPI has an overwhelming count of configuration options."
- elog "Don't forget the EXTRA_ECONF environment variable can let you"
- elog "specify configure options if you find them necessary."
- echo
-}
-
-src_prepare() {
- # Necessary for scalibility, see
- # http://www.open-mpi.org/community/lists/users/2008/09/6514.php
- if use threads; then
- echo 'oob_tcp_listen_mode = listen_thread' \
- >> opal/etc/openmpi-mca-params.conf
- fi
-
- epatch "${FILESDIR}"/openmpi-r24328.patch
-}
-
-src_configure() {
- local myconf=(
- --sysconfdir="${EPREFIX}/etc/${PN}"
- --enable-pretty-print-stacktrace
- --enable-orterun-prefix-by-default
- --with-hwloc="${EPREFIX}/usr"
- )
-
- if use mpi-threads; then
- myconf+=(--enable-mpi-threads
- --enable-progress-threads)
- fi
-
- if use fortran; then
- if [[ $(tc-getFC) =~ g77 ]]; then
- myconf+=(--disable-mpi-f90)
- elif [[ $(tc-getFC) =~ if ]]; then
- # Enabled here as gfortran compile times are huge with this enabled.
- myconf+=(--with-mpi-f90-size=medium)
- fi
- else
- myconf+=(--disable-mpi-f90 --disable-mpi-f77)
- fi
-
- ! use vt && myconf+=(--enable-contrib-no-build=vt)
-
- econf "${myconf[@]}" \
- $(use_enable cxx mpi-cxx) \
- $(use_enable romio io-romio) \
- $(use_enable heterogeneous) \
- $(use_with pbs tm) \
- $(use_with slurm) \
- $(use_enable ipv6) \
- $(use_with infiniband openib) \
- $(use_with sctp sctp)
-}
-
-src_install () {
- emake DESTDIR="${D}" install || die "make install failed"
- # From USE=vt see #359917
- rm "${D}"/usr/share/libtool &> /dev/null
- dodoc README AUTHORS NEWS VERSION || die
-}
-
-src_test() {
- # Doesn't work with the default src_test as the dry run (-n) fails.
- cd "${S}"
- emake -j1 check || die "emake check failed"
-}
diff --git a/sys-cluster/openmpi/openmpi-1.5.3.ebuild b/sys-cluster/openmpi/openmpi-1.5.3.ebuild
deleted file mode 100644
index f399271f9b6c..000000000000
--- a/sys-cluster/openmpi/openmpi-1.5.3.ebuild
+++ /dev/null
@@ -1,107 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.5.3.ebuild,v 1.7 2011/06/24 19:45:54 xarthisius Exp $
-
-EAPI=3
-inherit eutils fortran-2 multilib flag-o-matic toolchain-funcs
-
-MY_P=${P/-mpi}
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="A high-performance message passing library (MPI)"
-HOMEPAGE="http://www.open-mpi.org"
-SRC_URI="http://www.open-mpi.org/software/ompi/v1.5/downloads/${MY_P}.tar.bz2"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="+cxx elibc_FreeBSD fortran heterogeneous ipv6 mpi-threads pbs romio threads vt"
-RDEPEND="
- fortran? ( virtual/fortran )
- pbs? ( sys-cluster/torque )
- vt? (
- !dev-libs/libotf
- !app-text/lcdf-typetools
- )
- elibc_FreeBSD? ( dev-libs/libexecinfo )
- >=sys-apps/hwloc-1.1.1
- !sys-cluster/mpich
- !sys-cluster/lam-mpi
- !sys-cluster/mpich2
- !sys-cluster/mpiexec"
-DEPEND="${RDEPEND}"
-
-pkg_setup() {
- use fortran && fortran-2_pkg_setup
- if use mpi-threads; then
- echo
- ewarn "WARNING: use of MPI_THREAD_MULTIPLE is still disabled by"
- ewarn "default and officially unsupported by upstream."
- ewarn "You may stop now and set USE=-mpi-threads"
- echo
- fi
-
- echo
- elog "OpenMPI has an overwhelming count of configuration options."
- elog "Don't forget the EXTRA_ECONF environment variable can let you"
- elog "specify configure options if you find them necessary."
- echo
-}
-
-src_prepare() {
- # Necessary for scalibility, see
- # http://www.open-mpi.org/community/lists/users/2008/09/6514.php
- if use threads; then
- echo 'oob_tcp_listen_mode = listen_thread' \
- >> opal/etc/openmpi-mca-params.conf
- fi
-
- epatch "${FILESDIR}"/openmpi-r24328.patch
-}
-
-src_configure() {
- local myconf=(
- --sysconfdir="${EPREFIX}/etc/${PN}"
- --enable-pretty-print-stacktrace
- --enable-orterun-prefix-by-default
- --without-slurm
- --with-hwloc=/usr
- )
-
- if use mpi-threads; then
- myconf+=(--enable-mpi-threads
- --enable-progress-threads)
- fi
-
- if use fortran; then
- if [[ $(tc-getFC) =~ g77 ]]; then
- myconf+=(--disable-mpi-f90)
- elif [[ $(tc-getFC) =~ if ]]; then
- # Enabled here as gfortran compile times are huge with this enabled.
- myconf+=(--with-mpi-f90-size=medium)
- fi
- else
- myconf+=(--disable-mpi-f90 --disable-mpi-f77)
- fi
-
- ! use vt && myconf+=(--enable-contrib-no-build=vt)
-
- econf "${myconf[@]}" \
- $(use_enable cxx mpi-cxx) \
- $(use_enable romio io-romio) \
- $(use_enable heterogeneous) \
- $(use_with pbs tm) \
- $(use_enable ipv6)
-}
-
-src_install () {
- emake DESTDIR="${D}" install || die "make install failed"
- # From USE=vt see #359917
- rm "${D}"/usr/share/libtool &> /dev/null
- dodoc README AUTHORS NEWS VERSION || die
-}
-
-src_test() {
- # Doesn't work with the default src_test as the dry run (-n) fails.
- cd "${S}"
- emake -j1 check || die "emake check failed"
-}
diff --git a/sys-cluster/openmpi/openmpi-1.5.4-r1.ebuild b/sys-cluster/openmpi/openmpi-1.5.4-r1.ebuild
deleted file mode 100644
index c75bbdb296ce..000000000000
--- a/sys-cluster/openmpi/openmpi-1.5.4-r1.ebuild
+++ /dev/null
@@ -1,123 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.5.4-r1.ebuild,v 1.2 2011/12/17 13:01:31 grobian Exp $
-
-EAPI=4
-inherit eutils fortran-2 multilib flag-o-matic toolchain-funcs
-
-MY_P=${P/-mpi}
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="A high-performance message passing library (MPI)"
-HOMEPAGE="http://www.open-mpi.org"
-SRC_URI="http://www.open-mpi.org/software/ompi/v1.5/downloads/${MY_P}.tar.bz2"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux"
-IUSE="+cxx elibc_FreeBSD fortran heterogeneous infiniband ipv6 mpi-threads +numa pbs
- romio sctp slurm threads vt"
-
-REQUIRED_USE="^^ (
- ( !slurm !pbs )
- ( slurm !pbs )
- ( !slurm pbs )
- )"
-
-RDEPEND="
- fortran? ( virtual/fortran )
- pbs? ( sys-cluster/torque )
- infiniband? ( sys-infiniband/openib )
- sctp? ( net-misc/lksctp-tools )
- vt? (
- !dev-libs/libotf
- !app-text/lcdf-typetools
- )
- elibc_FreeBSD? ( dev-libs/libexecinfo )
- numa? ( sys-process/numactl )
- >=sys-apps/hwloc-1.3
- !sys-cluster/mpich
- !sys-cluster/lam-mpi
- !sys-cluster/mpich2
- !sys-cluster/mpiexec"
-DEPEND="${RDEPEND}"
-
-pkg_setup() {
- use fortran && fortran-2_pkg_setup
- if use mpi-threads; then
- echo
- ewarn "WARNING: use of MPI_THREAD_MULTIPLE is still disabled by"
- ewarn "default and officially unsupported by upstream."
- ewarn "You may stop now and set USE=-mpi-threads"
- echo
- fi
-
- echo
- elog "OpenMPI has an overwhelming count of configuration options."
- elog "Don't forget the EXTRA_ECONF environment variable can let you"
- elog "specify configure options if you find them necessary."
- echo
-}
-
-src_prepare() {
- # Necessary for scalibility, see
- # http://www.open-mpi.org/community/lists/users/2008/09/6514.php
- if use threads; then
- echo 'oob_tcp_listen_mode = listen_thread' \
- >> opal/etc/openmpi-mca-params.conf
- fi
-
- epatch "${FILESDIR}"/openmpi-r24328.patch
-}
-
-src_configure() {
- local myconf=(
- --sysconfdir="${EPREFIX}/etc/${PN}"
- --enable-pretty-print-stacktrace
- --enable-orterun-prefix-by-default
- --with-hwloc="${EPREFIX}/usr"
- )
-
- if use mpi-threads; then
- myconf+=(
- --enable-mpi-thread-multiple
- --enable-opal-multi-threads
- )
- fi
-
- if use fortran; then
- if [[ $(tc-getFC) =~ g77 ]]; then
- myconf+=(--disable-mpi-f90)
- elif [[ $(tc-getFC) =~ if ]]; then
- # Enabled here as gfortran compile times are huge with this enabled.
- myconf+=( --with-mpi-f90-size=medium )
- fi
- else
- myconf+=( --disable-mpi-f90 --disable-mpi-f77 )
- fi
-
- ! use vt && myconf+=(--enable-contrib-no-build=vt)
-
- use infiniband && myconf+=( --with-openib="${EPREFIX}/usr" )
- use numa && myconf+=( --with-libnuma="${EPREFIX}/usr" )
-
- econf "${myconf[@]}" \
- $(use_enable cxx mpi-cxx) \
- $(use_enable romio io-romio) \
- $(use_enable heterogeneous) \
- $(use_with pbs tm) \
- $(use_with slurm) \
- $(use_enable ipv6) \
- $(use_with sctp sctp)
-}
-
-src_install () {
- emake DESTDIR="${D}" install || die "make install failed"
- # From USE=vt see #359917
- rm "${ED}"/usr/share/libtool &> /dev/null
- dodoc README AUTHORS NEWS VERSION || die
-}
-
-src_test() {
- # Doesn't work with the default src_test as the dry run (-n) fails.
- emake -j1 check || die "emake check failed"
-}
diff --git a/sys-cluster/openmpi/openmpi-1.5.4.ebuild b/sys-cluster/openmpi/openmpi-1.5.4.ebuild
deleted file mode 100644
index 6233adb7e5ed..000000000000
--- a/sys-cluster/openmpi/openmpi-1.5.4.ebuild
+++ /dev/null
@@ -1,121 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.5.4.ebuild,v 1.1 2011/08/31 17:26:17 alexxy Exp $
-
-EAPI=4
-inherit eutils fortran-2 multilib flag-o-matic toolchain-funcs
-
-MY_P=${P/-mpi}
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="A high-performance message passing library (MPI)"
-HOMEPAGE="http://www.open-mpi.org"
-SRC_URI="http://www.open-mpi.org/software/ompi/v1.5/downloads/${MY_P}.tar.bz2"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux"
-IUSE="+cxx elibc_FreeBSD fortran heterogeneous infiniband ipv6 mpi-threads pbs
- romio sctp slurm threads vt"
-
-REQUIRED_USE="^^ (
- ( !slurm !pbs )
- ( slurm !pbs )
- ( !slurm pbs )
- )"
-
-RDEPEND="
- fortran? ( virtual/fortran )
- pbs? ( sys-cluster/torque )
- infiniband? ( sys-infiniband/openib )
- sctp? ( net-misc/lksctp-tools )
- vt? (
- !dev-libs/libotf
- !app-text/lcdf-typetools
- )
- elibc_FreeBSD? ( dev-libs/libexecinfo )
- >=sys-apps/hwloc-1.1.1
- !sys-cluster/mpich
- !sys-cluster/lam-mpi
- !sys-cluster/mpich2
- !sys-cluster/mpiexec"
-DEPEND="${RDEPEND}"
-
-pkg_setup() {
- use fortran && fortran-2_pkg_setup
- if use mpi-threads; then
- echo
- ewarn "WARNING: use of MPI_THREAD_MULTIPLE is still disabled by"
- ewarn "default and officially unsupported by upstream."
- ewarn "You may stop now and set USE=-mpi-threads"
- echo
- fi
-
- echo
- elog "OpenMPI has an overwhelming count of configuration options."
- elog "Don't forget the EXTRA_ECONF environment variable can let you"
- elog "specify configure options if you find them necessary."
- echo
-}
-
-src_prepare() {
- # Necessary for scalibility, see
- # http://www.open-mpi.org/community/lists/users/2008/09/6514.php
- if use threads; then
- echo 'oob_tcp_listen_mode = listen_thread' \
- >> opal/etc/openmpi-mca-params.conf
- fi
-
- epatch "${FILESDIR}"/openmpi-r24328.patch
-}
-
-src_configure() {
- local myconf=(
- --sysconfdir="${EPREFIX}/etc/${PN}"
- --enable-pretty-print-stacktrace
- --enable-orterun-prefix-by-default
- --with-hwloc="${EPREFIX}/usr"
- )
-
- if use mpi-threads; then
- myconf+=(
- --enable-mpi-thread-multiple
- --enable-opal-multi-threads
- )
- fi
-
- if use fortran; then
- if [[ $(tc-getFC) =~ g77 ]]; then
- myconf+=(--disable-mpi-f90)
- elif [[ $(tc-getFC) =~ if ]]; then
- # Enabled here as gfortran compile times are huge with this enabled.
- myconf+=(--with-mpi-f90-size=medium)
- fi
- else
- myconf+=(--disable-mpi-f90 --disable-mpi-f77)
- fi
-
- ! use vt && myconf+=(--enable-contrib-no-build=vt)
-
- econf "${myconf[@]}" \
- $(use_enable cxx mpi-cxx) \
- $(use_enable romio io-romio) \
- $(use_enable heterogeneous) \
- $(use_with pbs tm) \
- $(use_with slurm) \
- $(use_enable ipv6) \
- $(use_with infiniband openib) \
- $(use_with sctp sctp)
-}
-
-src_install () {
- emake DESTDIR="${D}" install || die "make install failed"
- # From USE=vt see #359917
- rm "${D}"/usr/share/libtool &> /dev/null
- dodoc README AUTHORS NEWS VERSION || die
-}
-
-src_test() {
- # Doesn't work with the default src_test as the dry run (-n) fails.
- cd "${S}"
- emake -j1 check || die "emake check failed"
-}