summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2010-06-18 20:19:06 +0000
committerMatti Bickel <mabi@gentoo.org>2010-06-18 20:19:06 +0000
commit4d1a698599f0a70bddb1bcccfd472f6a999b3c08 (patch)
tree51b87bf6b1662c871ff82287b794f7b853ad3a7b /sys-cluster
parentBump to 1.6.1. Just a bunch of bug fixes. (diff)
downloadgentoo-2-4d1a698599f0a70bddb1bcccfd472f6a999b3c08.tar.gz
gentoo-2-4d1a698599f0a70bddb1bcccfd472f6a999b3c08.tar.bz2
gentoo-2-4d1a698599f0a70bddb1bcccfd472f6a999b3c08.zip
fix Unsafe.pl error with recent openmpi
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/mpi-dotnet/ChangeLog5
-rw-r--r--sys-cluster/mpi-dotnet/files/Unsafe.pl.patch10
2 files changed, 11 insertions, 4 deletions
diff --git a/sys-cluster/mpi-dotnet/ChangeLog b/sys-cluster/mpi-dotnet/ChangeLog
index 933af8b655c6..a09bf12133d1 100644
--- a/sys-cluster/mpi-dotnet/ChangeLog
+++ b/sys-cluster/mpi-dotnet/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-cluster/mpi-dotnet
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpi-dotnet/ChangeLog,v 1.5 2010/04/18 12:08:59 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpi-dotnet/ChangeLog,v 1.6 2010/06/18 20:19:06 mabi Exp $
+
+ 18 Jun 2010; <mabi@gentoo.org> files/Unsafe.pl.patch:
+ make it work with recent openmpi
18 Apr 2010; <nixnut@gentoo.org> mpi-dotnet-1.0.0.ebuild:
ppc stable #281207
diff --git a/sys-cluster/mpi-dotnet/files/Unsafe.pl.patch b/sys-cluster/mpi-dotnet/files/Unsafe.pl.patch
index b24cf6db6fa9..1649f3d3ac4e 100644
--- a/sys-cluster/mpi-dotnet/files/Unsafe.pl.patch
+++ b/sys-cluster/mpi-dotnet/files/Unsafe.pl.patch
@@ -1,5 +1,5 @@
---- a/MPI/Unsafe.pl 2008-10-06 15:52:17.000000000 +0200
-+++ b/MPI/Unsafe.pl 2010-02-25 21:25:07.000000000 +0100
+--- mpi.net-1.0.0.orig/MPI/Unsafe.pl 2008-10-06 15:52:17.000000000 +0200
++++ mpi.net-1.0.0/MPI/Unsafe.pl 2010-06-18 21:37:23.000000000 +0200
@@ -96,7 +96,7 @@
}
@@ -27,7 +27,7 @@
} elsif ($line =~ /struct $mpi_status_name[^;]*$/) {
$in_mpi_status=1;
}
-@@ -183,7 +183,11 @@
+@@ -183,7 +183,15 @@
# This is a constant we need to replace.
my $value = $constants{$constant};
@@ -36,6 +36,10 @@
+ # this is for you LAM :-)
+ print UNSAFE_OUTPUT ("$whitespace","public static readonly $type $constant = mpinet_$constant();\n");
+ push (@cbridge_constants, "$type:$constant");
++ } elsif ($value =~ /OMPI_PREDEFINED_GLOBAL\((.+), (.+)\)/) {
++ # OpenMPI choose to use external variables for these values
++ print UNSAFE_OUTPUT ("$whitespace","public static readonly $type $constant = mpinet_$constant();\n");
++ push (@cbridge_constants, "$type:$constant");
+ } elsif ($value =~ /&/ or $constant =~ /_FN$/) {
# If we're taking the address of something, or if this
# is a _FN constant, it needs to be done in the C