summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexys Jacob <ultrabug@gentoo.org>2015-08-04 08:01:23 +0000
committerAlexys Jacob <ultrabug@gentoo.org>2015-08-04 08:01:23 +0000
commit63cdfe79b1b937c38de2ce9c22db18ad5fb5b123 (patch)
treedfefe0ba53500c19f31d598ba47651d407e82d9b /sys-cluster
parentVersion bump. Removed old (diff)
downloadgentoo-2-63cdfe79b1b937c38de2ce9c22db18ad5fb5b123.tar.gz
gentoo-2-63cdfe79b1b937c38de2ce9c22db18ad5fb5b123.tar.bz2
gentoo-2-63cdfe79b1b937c38de2ce9c22db18ad5fb5b123.zip
version bump
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key B658FA13)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/keepalived/ChangeLog7
-rw-r--r--sys-cluster/keepalived/keepalived-1.2.19.ebuild64
2 files changed, 70 insertions, 1 deletions
diff --git a/sys-cluster/keepalived/ChangeLog b/sys-cluster/keepalived/ChangeLog
index 85438591685d..f7be4398169a 100644
--- a/sys-cluster/keepalived/ChangeLog
+++ b/sys-cluster/keepalived/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-cluster/keepalived
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/keepalived/ChangeLog,v 1.131 2015/07/08 10:02:10 ultrabug Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/keepalived/ChangeLog,v 1.132 2015/08/04 08:01:23 ultrabug Exp $
+
+*keepalived-1.2.19 (04 Aug 2015)
+
+ 04 Aug 2015; Ultrabug <ultrabug@gentoo.org> +keepalived-1.2.19.ebuild:
+ version bump fix #556636 thx to Tomas Mozes
*keepalived-1.2.18 (08 Jul 2015)
diff --git a/sys-cluster/keepalived/keepalived-1.2.19.ebuild b/sys-cluster/keepalived/keepalived-1.2.19.ebuild
new file mode 100644
index 000000000000..dc4d163924c5
--- /dev/null
+++ b/sys-cluster/keepalived/keepalived-1.2.19.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/keepalived/keepalived-1.2.19.ebuild,v 1.1 2015/08/04 08:01:23 ultrabug Exp $
+
+EAPI=4
+
+inherit autotools base
+
+DESCRIPTION="A strong & robust keepalive facility to the Linux Virtual Server project"
+HOMEPAGE="http://www.keepalived.org/"
+SRC_URI="http://www.keepalived.org/software/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="debug ipv6 snmp"
+
+RDEPEND="dev-libs/popt
+ sys-apps/iproute2
+ dev-libs/libnl
+ dev-libs/openssl
+ snmp? ( net-analyzer/net-snmp )"
+DEPEND="${RDEPEND}
+ >=sys-kernel/linux-headers-2.6.30"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.2.2-libipvs-fix-backup-daemon.patch
+)
+
+DOCS=( README CONTRIBUTORS INSTALL VERSION ChangeLog AUTHOR TODO
+ doc/keepalived.conf.SYNOPSIS doc/NOTE_vrrp_vmac.txt )
+
+src_prepare() {
+ base_src_prepare
+ eautoreconf
+}
+
+src_configure() {
+ STRIP=/bin/true \
+ econf \
+ --with-kernel-dir=/usr \
+ --enable-vrrp \
+ $(use_enable debug) \
+ $(use_enable snmp)
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/keepalived.init keepalived
+ newconfd "${FILESDIR}"/keepalived.confd keepalived
+
+ use snmp && dodoc doc/KEEPALIVED-MIB
+
+ docinto genhash
+ dodoc genhash/README genhash/AUTHOR genhash/ChangeLog genhash/VERSION || die
+ # This was badly named by upstream, it's more HOWTO than anything else.
+ newdoc INSTALL INSTALL+HOWTO
+
+ # Security risk to bundle SSL certs
+ rm -f "${ED}"/etc/keepalived/samples/*.pem
+ # Clean up sysvinit files
+ rm -rf "${ED}"/etc/sysconfig "${ED}"/etc/rc.d/
+}