summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-09-05 21:46:49 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-09-05 21:46:49 +0000
commitf9683d6739ffbb2eedebe92b6018eb871f0c59b2 (patch)
tree1752fc9473478a05607aa010f6f5ee4add1d5426 /sys-cluster
parentupdatign deps, some havana stuff, some init stuff, fixing bugs 483384 482698 (diff)
downloadgentoo-2-f9683d6739ffbb2eedebe92b6018eb871f0c59b2.tar.gz
gentoo-2-f9683d6739ffbb2eedebe92b6018eb871f0c59b2.tar.bz2
gentoo-2-f9683d6739ffbb2eedebe92b6018eb871f0c59b2.zip
updating a few neutron things, deps and initscripts mostly
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/neutron/ChangeLog12
-rw-r--r--sys-cluster/neutron/files/neutron-confd2
-rw-r--r--sys-cluster/neutron/files/neutron-initd60
-rw-r--r--sys-cluster/neutron/files/neutron-sudoers4
-rw-r--r--sys-cluster/neutron/metadata.xml7
-rw-r--r--sys-cluster/neutron/neutron-2012.2.4-r2.ebuild (renamed from sys-cluster/neutron/neutron-2012.2.4-r1.ebuild)53
-rw-r--r--sys-cluster/neutron/neutron-2013.1.3-r1.ebuild (renamed from sys-cluster/neutron/neutron-2013.1.3.ebuild)45
-rw-r--r--sys-cluster/neutron/neutron-2013.1.9999.ebuild45
-rw-r--r--sys-cluster/neutron/neutron-9999.ebuild48
9 files changed, 233 insertions, 43 deletions
diff --git a/sys-cluster/neutron/ChangeLog b/sys-cluster/neutron/ChangeLog
index 4f9a69fad24b..2b3bc21f7b68 100644
--- a/sys-cluster/neutron/ChangeLog
+++ b/sys-cluster/neutron/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for sys-cluster/neutron
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/neutron/ChangeLog,v 1.5 2013/08/22 16:10:35 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/neutron/ChangeLog,v 1.6 2013/09/05 21:46:49 prometheanfire Exp $
+
+*neutron-2013.1.3-r1 (05 Sep 2013)
+*neutron-2012.2.4-r2 (05 Sep 2013)
+
+ 05 Sep 2013; Matthew Thode <prometheanfire@gentoo.org> +files/neutron-confd,
+ +files/neutron-initd, +files/neutron-sudoers, +neutron-2012.2.4-r2.ebuild,
+ +neutron-2013.1.3-r1.ebuild, -neutron-2012.2.4-r1.ebuild,
+ -neutron-2013.1.3.ebuild, metadata.xml, neutron-2013.1.9999.ebuild,
+ neutron-9999.ebuild:
+ updating a few neutron things, deps and initscripts mostly
22 Aug 2013; Matthew Thode <prometheanfire@gentoo.org>
neutron-2012.2.4-r1.ebuild, neutron-2013.1.3.ebuild,
diff --git a/sys-cluster/neutron/files/neutron-confd b/sys-cluster/neutron/files/neutron-confd
new file mode 100644
index 000000000000..dae379e557c7
--- /dev/null
+++ b/sys-cluster/neutron/files/neutron-confd
@@ -0,0 +1,2 @@
+#Don't touch this unless you know what you are doing
+PID_PATH=/run/quantum
diff --git a/sys-cluster/neutron/files/neutron-initd b/sys-cluster/neutron/files/neutron-initd
new file mode 100644
index 000000000000..6ecae4046b01
--- /dev/null
+++ b/sys-cluster/neutron/files/neutron-initd
@@ -0,0 +1,60 @@
+#!/sbin/runscript
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ need net
+}
+
+BASENAME=$(echo $SVCNAME | cut -d '-' -f 1)
+SERVERNAME=$(echo $SVCNAME | cut -d '-' -f 2)
+
+checkconfig() {
+ if [ ! -r /etc/conf.d/$BASENAME ]; then
+ eerror "No quantum conf.d file found: /etc/conf.d/$BASENAME)"
+ return 1
+ fi
+ return 0
+}
+
+start() {
+ checkconfig || return $?
+ . /etc/conf.d/$BASENAME
+
+ ebegin "Starting ${SVCNAME}"
+
+ if [ ! -d ${PID_PATH} ]; then
+ mkdir ${PID_PATH}
+ fi
+
+ start-stop-daemon --start \
+ --user quantum:quantum \
+ --quiet \
+ --pidfile "${PID_PATH}/${SVCNAME}.pid" \
+ --make-pidfile \
+ --background \
+ --exec /usr/bin/${SVCNAME} -- \
+ --config-file /etc/quantum/quantum.conf \
+ --config-file /etc/quantum/plugins/openvswitch/ovs_quantum_plugin.ini \
+ --log-file /var/log/quantum/server.log
+
+ eend $? "Failed to start ${SVCNAME}"
+}
+
+stop() {
+ checkconfig || return $?
+ . /etc/conf.d/$BASENAME
+
+ ebegin "Stopping ${SVCNAME}"
+
+ start-stop-daemon --stop --user quantum --quiet --pidfile "${PID_PATH}/${SVCNAME}.pid" \
+ --exec /usr/bin/${SVCNAME} -- \
+ --config-file /etc/quantum/quantum.conf \
+ --config-file /etc/quantum/plugins/openvswitch/ovs_quantum_plugin.ini \
+ --log-file /var/log/quantum/server.log
+ eend $? "Failed to stop ${SVCNAME}"
+}
+
+#restart() {
+#
+#}
diff --git a/sys-cluster/neutron/files/neutron-sudoers b/sys-cluster/neutron/files/neutron-sudoers
new file mode 100644
index 000000000000..7d1d5a2be487
--- /dev/null
+++ b/sys-cluster/neutron/files/neutron-sudoers
@@ -0,0 +1,4 @@
+Defaults:neutron !requiretty
+
+neutron ALL = (root) NOPASSWD: /usr/bin/quantum-rootwrap
+
diff --git a/sys-cluster/neutron/metadata.xml b/sys-cluster/neutron/metadata.xml
index bf50b796793b..0637de22a8f9 100644
--- a/sys-cluster/neutron/metadata.xml
+++ b/sys-cluster/neutron/metadata.xml
@@ -14,5 +14,12 @@
supports extensions to provide advanced network capabilities
(e.g., QoS, ACLs, network monitoring, etc)
</longdescription>
+ <use>
+ <flag name="dhcp">Installs the initscripts for the neutron dhcp service</flag>
+ <flag name="l3">Installs the initscripts for the neutron l3 service</flag>
+ <flag name="metadata">Installs the initscripts for the neutron metadata service</flag>
+ <flag name="openvswitch">Installs the initscripts for the neutron openvswitch service</flag>
+ <flag name="server">Installs the initscripts for the neutron server service</flag>
+ </use>
</pkgmetadata>
diff --git a/sys-cluster/neutron/neutron-2012.2.4-r1.ebuild b/sys-cluster/neutron/neutron-2012.2.4-r2.ebuild
index 6ea383ab7891..b9645ca250a5 100644
--- a/sys-cluster/neutron/neutron-2012.2.4-r1.ebuild
+++ b/sys-cluster/neutron/neutron-2012.2.4-r2.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/neutron/neutron-2012.2.4-r1.ebuild,v 1.5 2013/08/22 16:10:35 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/neutron/neutron-2012.2.4-r2.ebuild,v 1.1 2013/09/05 21:46:49 prometheanfire Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
-inherit distutils-r1
+inherit distutils-r1 eutils
#restricted due to packages missing and bad depends in the test ==webob-1.0.8
RESTRICT="test"
@@ -17,43 +17,61 @@ S="${WORKDIR}/quantum-${PV}"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="test"
+IUSE="+dhcp +l3 +metadata +openvswitch +server test"
#the cliff dep is as below because it depends on pyparsing, which only has 2.7 OR 3.2, not both
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ app-admin/sudo
test? ( dev-python/cliff[python_targets_python2_7]
dev-python/configobj[${PYTHON_USEDEP}] )
dev-python/coverage[${PYTHON_USEDEP}]
>=dev-python/mock-1.0[${PYTHON_USEDEP}]
- =dev-python/mox-0.5.3-r1[${PYTHON_USEDEP}]
+ ~dev-python/mox-0.5.3[${PYTHON_USEDEP}]
dev-python/nose[${PYTHON_USEDEP}]
dev-python/nosehtmloutput[${PYTHON_USEDEP}]
dev-python/nosexcover
dev-python/openstack-nose-plugin[${PYTHON_USEDEP}]
- =dev-python/pep8-1.3.3
+ ~dev-python/pep8-1.3.3
>=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
- =dev-python/webtest-1.3.3
+ ~dev-python/webtest-1.3.3
virtual/python-unittest2[${PYTHON_USEDEP}]"
RDEPEND="=dev-python/pastedeploy-1.5.0-r1[${PYTHON_USEDEP}]
>=dev-python/routes-1.12.3[${PYTHON_USEDEP}]
- =dev-python/amqplib-0.6.1
- =dev-python/anyjson-0.2.4[${PYTHON_USEDEP}]
+ ~dev-python/amqplib-0.6.1[${PYTHON_USEDEP}]
+ ~dev-python/anyjson-0.2.4[${PYTHON_USEDEP}]
>=dev-python/eventlet-0.9.17[${PYTHON_USEDEP}]
>=dev-python/greenlet-0.3.1[${PYTHON_USEDEP}]
dev-python/httplib2[${PYTHON_USEDEP}]
>=dev-python/iso8601-0.1.4[${PYTHON_USEDEP}]
- =dev-python/kombu-1.0.4-r1[${PYTHON_USEDEP}]
+ ~dev-python/kombu-1.0.4[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]
- dev-python/netaddr
+ dev-python/netaddr[${PYTHON_USEDEP}]
>=dev-python/python-quantumclient-2.0[${PYTHON_USEDEP}]
- dev-python/pyudev
+ dev-python/pyudev[${PYTHON_USEDEP}]
>dev-python/sqlalchemy-0.6.4
<=dev-python/sqlalchemy-0.7.9
- =dev-python/webob-1.0.8-r1[${PYTHON_USEDEP}]
- net-misc/openvswitch"
+ ~dev-python/webob-1.0.8[${PYTHON_USEDEP}]
+ net-misc/openvswitch
+ dhcp? ( net-dns/dnsmasq )"
+
+pkg_setup() {
+ enewgroup neutron
+ enewuser neutron -1 -1 /var/lib/neutron neutron
+}
python_install() {
distutils-r1_python_install
+ newconfd "${FILESDIR}/neutron-confd" "quantum"
+ newinitd "${FILESDIR}/neutron-initd" "quantum"
+
+ use server && dosym /etc/init.d/quantum /etc/init.d/quantum-server
+ use dhcp && dosym /etc/init.d/quantum /etc/init.d/quantum-dhcp-agent
+ use l3 && dosym /etc/init.d/quantum /etc/init.d/quantum-l3-agent
+ use metadata && dosym /etc/init.d/quantum /etc/init.d/quantum-metadata-agent
+ use openvswitch && dosym /etc/init.d/quantum /etc/init.d/quantum-openvswitch-agent
+
+ dodir /var/log/neutron
+ fowners neutron:neutron /var/log/neutron
keepdir /etc/quantum
insinto /etc/quantum
@@ -68,4 +86,13 @@ python_install() {
#remove the etc stuff from usr...
rm -R "${D}/usr/etc/"
+
+ #add sudoers definitions for user neutron
+ insinto /etc/sudoers.d/
+ doins "${FILESDIR}/neutron-sudoers"
+}
+
+pkg_config() {
+ fperms 0700 /var/log/neutron
+ fowners neutron:neutron /var/log neutron
}
diff --git a/sys-cluster/neutron/neutron-2013.1.3.ebuild b/sys-cluster/neutron/neutron-2013.1.3-r1.ebuild
index 54009438c57d..61b06fcf043c 100644
--- a/sys-cluster/neutron/neutron-2013.1.3.ebuild
+++ b/sys-cluster/neutron/neutron-2013.1.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/neutron/neutron-2013.1.3.ebuild,v 1.5 2013/08/22 16:10:35 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/neutron/neutron-2013.1.3-r1.ebuild,v 1.1 2013/09/05 21:46:49 prometheanfire Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -17,22 +17,23 @@ S="${WORKDIR}/quantum-${PV}"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="test"
+IUSE="+dhcp +l3 +metadata +openvswitch +server test"
#the cliff dep is as below because it depends on pyparsing, which only has 2.7 OR 3.2, not both
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ app-admin/sudo
test? ( dev-python/cliff[python_targets_python2_7]
dev-python/configobj[${PYTHON_USEDEP}] )
dev-python/coverage[${PYTHON_USEDEP}]
>=dev-python/mock-1.0[${PYTHON_USEDEP}]
- =dev-python/mox-0.5.3-r1[${PYTHON_USEDEP}]
+ ~dev-python/mox-0.5.3[${PYTHON_USEDEP}]
dev-python/nose[${PYTHON_USEDEP}]
dev-python/nosehtmloutput[${PYTHON_USEDEP}]
dev-python/nosexcover
dev-python/openstack-nose-plugin[${PYTHON_USEDEP}]
- =dev-python/pep8-1.3.3
+ ~dev-python/pep8-1.3.3
>=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
- =dev-python/webtest-1.3.3
+ ~dev-python/webtest-1.3.3
virtual/python-unittest2[${PYTHON_USEDEP}]"
RDEPEND=">=dev-python/pastedeploy-1.5.0-r1[${PYTHON_USEDEP}]
>=dev-python/alembic-0.4.1[${PYTHON_USEDEP}]
@@ -45,22 +46,39 @@ RDEPEND=">=dev-python/pastedeploy-1.5.0-r1[${PYTHON_USEDEP}]
dev-python/httplib2[${PYTHON_USEDEP}]
>=dev-python/iso8601-0.1.4[${PYTHON_USEDEP}]
>=dev-python/kombu-1.0.4-r1[${PYTHON_USEDEP}]
- dev-python/netaddr
- =dev-python/pyparsing-1.5.7[${PYTHON_USEDEP}]
+ dev-python/netaddr[${PYTHON_USEDEP}]
+ ~dev-python/pyparsing-1.5.7[${PYTHON_USEDEP}]
>=dev-python/python-keystoneclient-0.2.0[${PYTHON_USEDEP}]
dev-python/python-novaclient[${PYTHON_USEDEP}]
>=dev-python/python-quantumclient-2.2.0[${PYTHON_USEDEP}]
<=dev-python/python-quantumclient-3.0.0[${PYTHON_USEDEP}]
- dev-python/pyudev
+ dev-python/pyudev[${PYTHON_USEDEP}]
>dev-python/sqlalchemy-0.7.8
<=dev-python/sqlalchemy-0.7.99
>=dev-python/webob-1.2[${PYTHON_USEDEP}]
>=dev-python/oslo-config-1.1.0[${PYTHON_USEDEP}]
virtual/python-argparse[${PYTHON_USEDEP}]
- net-misc/openvswitch"
+ net-misc/openvswitch
+ dhcp? ( net-dns/dnsmasq )"
+
+pkg_setup() {
+ enewgroup neutron
+ enewuser neutron -1 -1 /var/lib/neutron neutron
+}
python_install() {
distutils-r1_python_install
+ newconfd "${FILESDIR}/neutron-confd" "quantum"
+ newinitd "${FILESDIR}/neutron-initd" "quantum"
+
+ use server && dosym /etc/init.d/quantum /etc/init.d/quantum-server
+ use dhcp && dosym /etc/init.d/quantum /etc/init.d/quantum-dhcp-agent
+ use l3 && dosym /etc/init.d/quantum /etc/init.d/quantum-l3-agent
+ use metadata && dosym /etc/init.d/quantum /etc/init.d/quantum-metadata-agent
+ use openvswitch && dosym /etc/init.d/quantum /etc/init.d/quantum-openvswitch-agent
+
+ dodir /var/log/neutron
+ fowners neutron:neutron /var/log/neutron
keepdir /etc/quantum
insinto /etc/quantum
@@ -78,4 +96,13 @@ python_install() {
insinto "/usr/lib64/python2.7/site-packages/quantum/db/migration/alembic_migrations/"
doins -r "quantum/db/migration/alembic_migrations/versions"
+
+ #add sudoers definitions for user neutron
+ insinto /etc/sudoers.d/
+ doins "${FILESDIR}/neutron-sudoers"
+}
+
+pkg_config() {
+ fperms 0700 /var/log/neutron
+ fowners neutron:neutron /var/log neutron
}
diff --git a/sys-cluster/neutron/neutron-2013.1.9999.ebuild b/sys-cluster/neutron/neutron-2013.1.9999.ebuild
index deb2a4420de3..1ece438a080b 100644
--- a/sys-cluster/neutron/neutron-2013.1.9999.ebuild
+++ b/sys-cluster/neutron/neutron-2013.1.9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/neutron/neutron-2013.1.9999.ebuild,v 1.4 2013/08/22 16:10:35 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/neutron/neutron-2013.1.9999.ebuild,v 1.5 2013/09/05 21:46:49 prometheanfire Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -17,22 +17,23 @@ EGIT_BRANCH="stable/grizzly"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS=""
-IUSE="test"
+IUSE="+dhcp +l3 +metadata +openvswitch +server test"
#the cliff dep is as below because it depends on pyparsing, which only has 2.7 OR 3.2, not both
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ app-admin/sudo
test? ( dev-python/cliff[python_targets_python2_7]
dev-python/configobj[${PYTHON_USEDEP}] )
dev-python/coverage[${PYTHON_USEDEP}]
>=dev-python/mock-1.0[${PYTHON_USEDEP}]
- =dev-python/mox-0.5.3-r1[${PYTHON_USEDEP}]
+ ~dev-python/mox-0.5.3[${PYTHON_USEDEP}]
dev-python/nose[${PYTHON_USEDEP}]
dev-python/nosehtmloutput[${PYTHON_USEDEP}]
dev-python/nosexcover
dev-python/openstack-nose-plugin[${PYTHON_USEDEP}]
- =dev-python/pep8-1.3.3
+ ~dev-python/pep8-1.3.3
>=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
- =dev-python/webtest-1.3.3
+ ~dev-python/webtest-1.3.3
virtual/python-unittest2[${PYTHON_USEDEP}]"
RDEPEND=">=dev-python/pastedeploy-1.5.0-r1[${PYTHON_USEDEP}]
>=dev-python/alembic-0.4.1[${PYTHON_USEDEP}]
@@ -45,22 +46,39 @@ RDEPEND=">=dev-python/pastedeploy-1.5.0-r1[${PYTHON_USEDEP}]
dev-python/httplib2[${PYTHON_USEDEP}]
>=dev-python/iso8601-0.1.4[${PYTHON_USEDEP}]
>=dev-python/kombu-1.0.4-r1[${PYTHON_USEDEP}]
- dev-python/netaddr
- =dev-python/pyparsing-1.5.7[${PYTHON_USEDEP}]
+ dev-python/netaddr[${PYTHON_USEDEP}]
+ ~dev-python/pyparsing-1.5.7[${PYTHON_USEDEP}]
>=dev-python/python-keystoneclient-0.2.0[${PYTHON_USEDEP}]
dev-python/python-novaclient[${PYTHON_USEDEP}]
>=dev-python/python-quantumclient-2.2.0[${PYTHON_USEDEP}]
<=dev-python/python-quantumclient-3.0.0[${PYTHON_USEDEP}]
- dev-python/pyudev
+ dev-python/pyudev[${PYTHON_USEDEP}]
>dev-python/sqlalchemy-0.7.8
<=dev-python/sqlalchemy-0.7.99
>=dev-python/webob-1.2[${PYTHON_USEDEP}]
>=dev-python/oslo-config-1.1.0[${PYTHON_USEDEP}]
virtual/python-argparse[${PYTHON_USEDEP}]
- net-misc/openvswitch"
+ net-misc/openvswitch
+ dhcp? ( net-dns/dnsmasq )"
+
+pkg_setup() {
+ enewgroup neutron
+ enewuser neutron -1 -1 /var/lib/neutron neutron
+}
python_install() {
distutils-r1_python_install
+ newconfd "${FILESDIR}/neutron-confd" "quantum"
+ newinitd "${FILESDIR}/neutron-initd" "quantum"
+
+ use server && dosym /etc/init.d/quantum /etc/init.d/quantum-server
+ use dhcp && dosym /etc/init.d/quantum /etc/init.d/quantum-dhcp-agent
+ use l3 && dosym /etc/init.d/quantum /etc/init.d/quantum-l3-agent
+ use metadata && dosym /etc/init.d/quantum /etc/init.d/quantum-metadata-agent
+ use openvswitch && dosym /etc/init.d/quantum /etc/init.d/quantum-openvswitch-agent
+
+ dodir /var/log/neutron
+ fowners neutron:neutron /var/log/neutron
keepdir /etc/quantum
insinto /etc/quantum
@@ -78,4 +96,13 @@ python_install() {
insinto "/usr/lib64/python2.7/site-packages/quantum/db/migration/alembic_migrations/"
doins -r "quantum/db/migration/alembic_migrations/versions"
+
+ #add sudoers definitions for user neutron
+ insinto /etc/sudoers.d/
+ doins "${FILESDIR}/neutron-sudoers"
+}
+
+pkg_config() {
+ fperms 0700 /var/log/neutron
+ fowners neutron:neutron /var/log neutron
}
diff --git a/sys-cluster/neutron/neutron-9999.ebuild b/sys-cluster/neutron/neutron-9999.ebuild
index c165fedb2338..07015ead0967 100644
--- a/sys-cluster/neutron/neutron-9999.ebuild
+++ b/sys-cluster/neutron/neutron-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/neutron/neutron-9999.ebuild,v 1.2 2013/08/22 16:10:35 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/neutron/neutron-9999.ebuild,v 1.3 2013/09/05 21:46:49 prometheanfire Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -12,27 +12,27 @@ RESTRICT="test"
DESCRIPTION="Quantum is a virtual network service for Openstack."
HOMEPAGE="https://launchpad.net/neutron"
EGIT_REPO_URI="https://github.com/openstack/neutron.git"
-EGIT_BRANCH="master"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS=""
-IUSE="test"
+IUSE="+dhcp +l3 +metadata +openvswitch +server test"
#the cliff dep is as below because it depends on pyparsing, which only has 2.7 OR 3.2, not both
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ app-admin/sudo
test? ( dev-python/cliff[python_targets_python2_7]
dev-python/configobj[${PYTHON_USEDEP}] )
dev-python/coverage[${PYTHON_USEDEP}]
>=dev-python/mock-1.0[${PYTHON_USEDEP}]
- =dev-python/mox-0.5.3-r1[${PYTHON_USEDEP}]
+ ~dev-python/mox-0.5.3[${PYTHON_USEDEP}]
dev-python/nose[${PYTHON_USEDEP}]
dev-python/nosehtmloutput[${PYTHON_USEDEP}]
dev-python/nosexcover
dev-python/openstack-nose-plugin[${PYTHON_USEDEP}]
- =dev-python/pep8-1.3.3
+ ~dev-python/pep8-1.3.3
>=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
- =dev-python/webtest-1.3.3
+ ~dev-python/webtest-1.3.3
virtual/python-unittest2[${PYTHON_USEDEP}]"
RDEPEND=">=dev-python/pastedeploy-1.5.0-r1[${PYTHON_USEDEP}]
>=dev-python/alembic-0.4.1[${PYTHON_USEDEP}]
@@ -45,22 +45,39 @@ RDEPEND=">=dev-python/pastedeploy-1.5.0-r1[${PYTHON_USEDEP}]
dev-python/httplib2[${PYTHON_USEDEP}]
>=dev-python/iso8601-0.1.4[${PYTHON_USEDEP}]
>=dev-python/kombu-1.0.4-r1[${PYTHON_USEDEP}]
- dev-python/netaddr
- =dev-python/pyparsing-1.5.7[${PYTHON_USEDEP}]
+ dev-python/netaddr[${PYTHON_USEDEP}]
+ ~dev-python/pyparsing-1.5.7[${PYTHON_USEDEP}]
>=dev-python/python-keystoneclient-0.2.0[${PYTHON_USEDEP}]
dev-python/python-novaclient[${PYTHON_USEDEP}]
- >=dev-python/python-neutronclient-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/python-neutronclient-2.3.0[${PYTHON_USEDEP}]
<=dev-python/python-neutronclient-3.0.0[${PYTHON_USEDEP}]
- dev-python/pyudev
+ dev-python/pyudev[${PYTHON_USEDEP}]
>dev-python/sqlalchemy-0.7.8
<=dev-python/sqlalchemy-0.7.99
>=dev-python/webob-1.2[${PYTHON_USEDEP}]
>=dev-python/oslo-config-1.1.0[${PYTHON_USEDEP}]
virtual/python-argparse[${PYTHON_USEDEP}]
- net-misc/openvswitch"
+ net-misc/openvswitch
+ dhcp? ( net-dns/dnsmasq )"
+
+pkg_setup() {
+ enewgroup neutron
+ enewuser neutron -1 -1 /var/lib/neutron neutron
+}
python_install() {
distutils-r1_python_install
+ newconfd "${FILESDIR}/neutron-confd" "neutron"
+ newinitd "${FILESDIR}/neutron-initd" "neutron"
+
+ use server && dosym /etc/init.d/neutron /etc/init.d/neutron-server
+ use dhcp && dosym /etc/init.d/neutron /etc/init.d/neutron-dhcp-agent
+ use l3 && dosym /etc/init.d/neutron /etc/init.d/neutron-l3-agent
+ use metadata && dosym /etc/init.d/neutron /etc/init.d/neutron-metadata-agent
+ use openvswitch && dosym /etc/init.d/neutron /etc/init.d/neutron-openvswitch-agent
+
+ dodir /var/log/neutron
+ fowners neutron:neutron /var/log/neutron
keepdir /etc/neutron
insinto /etc/neutron
@@ -78,4 +95,13 @@ python_install() {
insinto "/usr/lib64/python2.7/site-packages/neutron/db/migration/alembic_migrations/"
doins -r "neutron/db/migration/alembic_migrations/versions"
+
+ #add sudoers definitions for user neutron
+ insinto /etc/sudoers.d/
+ doins "${FILESDIR}/neutron-sudoers"
+}
+
+pkg_config() {
+ fperms 0700 /var/log/neutron
+ fowners neutron:neutron /var/log neutron
}