summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-10-24 21:20:38 +0000
committerMike Frysinger <vapier@gentoo.org>2014-10-24 21:20:38 +0000
commitda7dcab74070d51ce053fc5d33283b0e605b4559 (patch)
tree48579decd6c79e0f864b95421d6c559764a3e2a6 /sys-devel/autoconf
parentUpgrade old ebuilds to EAPI=4 and enable SLOTing all the time. (diff)
downloadgentoo-2-da7dcab74070d51ce053fc5d33283b0e605b4559.tar.gz
gentoo-2-da7dcab74070d51ce053fc5d33283b0e605b4559.tar.bz2
gentoo-2-da7dcab74070d51ce053fc5d33283b0e605b4559.zip
Upgrade old ebuilds to EAPI=4 and enable SLOTing all the time.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'sys-devel/autoconf')
-rw-r--r--sys-devel/autoconf/ChangeLog4
-rw-r--r--sys-devel/autoconf/autoconf-2.69.ebuild14
-rw-r--r--sys-devel/autoconf/autoconf-9999.ebuild19
3 files changed, 17 insertions, 20 deletions
diff --git a/sys-devel/autoconf/ChangeLog b/sys-devel/autoconf/ChangeLog
index 676e79627272..d5689831920b 100644
--- a/sys-devel/autoconf/ChangeLog
+++ b/sys-devel/autoconf/ChangeLog
@@ -1,11 +1,11 @@
# ChangeLog for sys-devel/autoconf
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/ChangeLog,v 1.192 2014/10/24 21:14:20 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/ChangeLog,v 1.193 2014/10/24 21:20:38 vapier Exp $
24 Oct 2014; Mike Frysinger <vapier@gentoo.org> autoconf-2.59-r7.ebuild,
autoconf-2.61-r2.ebuild, autoconf-2.62-r1.ebuild, autoconf-2.63-r1.ebuild,
autoconf-2.64.ebuild, autoconf-2.65-r1.ebuild, autoconf-2.67.ebuild,
- autoconf-2.68.ebuild, autoconf-2.69.ebuild:
+ autoconf-2.68.ebuild, autoconf-2.69.ebuild, autoconf-9999.ebuild:
Upgrade old ebuilds to EAPI=4 and enable SLOTing all the time.
24 Oct 2014; Mike Frysinger <vapier@gentoo.org> autoconf-2.67.ebuild,
diff --git a/sys-devel/autoconf/autoconf-2.69.ebuild b/sys-devel/autoconf/autoconf-2.69.ebuild
index 26f4235cee73..59acd6fff072 100644
--- a/sys-devel/autoconf/autoconf-2.69.ebuild
+++ b/sys-devel/autoconf/autoconf-2.69.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/autoconf-2.69.ebuild,v 1.20 2014/10/24 21:14:20 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/autoconf-2.69.ebuild,v 1.21 2014/10/24 21:20:38 vapier Exp $
EAPI="3"
@@ -34,7 +34,7 @@ src_prepare() {
if [[ ${PV} == "9999" ]] ; then
autoreconf -f -i || die
fi
- use multislot && find -name Makefile.in -exec sed -i '/^pkgdatadir/s:$:-@VERSION@:' {} +
+ find -name Makefile.in -exec sed -i '/^pkgdatadir/s:$:-@VERSION@:' {} +
}
src_configure() {
@@ -51,10 +51,8 @@ src_install() {
dodoc AUTHORS BUGS NEWS README TODO THANKS \
ChangeLog ChangeLog.0 ChangeLog.1 ChangeLog.2
- if use multislot ; then
- local f
- for f in "${D}"/usr/share/info/*.info* ; do
- mv "${f}" "${f/.info/-${SLOT}.info}" || die
- done
- fi
+ local f
+ for f in "${D}"/usr/share/info/*.info* ; do
+ mv "${f}" "${f/.info/-${SLOT}.info}" || die
+ done
}
diff --git a/sys-devel/autoconf/autoconf-9999.ebuild b/sys-devel/autoconf/autoconf-9999.ebuild
index 0ecb61eab0a5..cee5431c96c8 100644
--- a/sys-devel/autoconf/autoconf-9999.ebuild
+++ b/sys-devel/autoconf/autoconf-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/autoconf-9999.ebuild,v 1.14 2014/10/24 19:23:59 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/autoconf-9999.ebuild,v 1.15 2014/10/24 21:20:38 vapier Exp $
EAPI="4"
@@ -22,12 +22,13 @@ DESCRIPTION="Used to create autoconfiguration files"
HOMEPAGE="http://www.gnu.org/software/autoconf/autoconf.html"
LICENSE="GPL-3"
-SLOT=$(usex multislot "${PV}" "2.5")
-IUSE="emacs multislot"
+SLOT="${PV}"
+IUSE="emacs"
DEPEND=">=sys-devel/m4-1.4.16
>=dev-lang/perl-5.6"
RDEPEND="${DEPEND}
+ !~sys-devel/${P}:0
>=sys-devel/autoconf-wrapper-13"
[[ ${PV} == "9999" ]] && DEPEND+=" >=sys-apps/texinfo-4.3"
PDEPEND="emacs? ( app-emacs/autoconf-mode )"
@@ -36,7 +37,7 @@ src_prepare() {
if [[ ${PV} == "9999" ]] ; then
autoreconf -f -i || die
fi
- use multislot && find -name Makefile.in -exec sed -i '/^pkgdatadir/s:$:-@VERSION@:' {} +
+ find -name Makefile.in -exec sed -i '/^pkgdatadir/s:$:-@VERSION@:' {} +
}
src_configure() {
@@ -51,10 +52,8 @@ src_configure() {
src_install() {
default
- if use multislot ; then
- local f
- for f in "${D}"/usr/share/info/*.info* ; do
- mv "${f}" "${f/.info/-${SLOT}.info}" || die
- done
- fi
+ local f
+ for f in "${D}"/usr/share/info/*.info* ; do
+ mv "${f}" "${f/.info/-${SLOT}.info}" || die
+ done
}