summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <msterret@gentoo.org>2003-09-06 08:10:54 +0000
committerMichael Sterrett <msterret@gentoo.org>2003-09-06 08:10:54 +0000
commitb998104c0ece932692fb196cad924268bf33f523 (patch)
treeb8d6ae14accaea8fc616a0105b5b1d4ca3d8049d /sys-devel/binutils/binutils-2.13.90.0.16-r1.ebuild
parentwhitespace cleanup (diff)
downloadgentoo-2-b998104c0ece932692fb196cad924268bf33f523.tar.gz
gentoo-2-b998104c0ece932692fb196cad924268bf33f523.tar.bz2
gentoo-2-b998104c0ece932692fb196cad924268bf33f523.zip
whitespace cleanup
Diffstat (limited to 'sys-devel/binutils/binutils-2.13.90.0.16-r1.ebuild')
-rw-r--r--sys-devel/binutils/binutils-2.13.90.0.16-r1.ebuild36
1 files changed, 18 insertions, 18 deletions
diff --git a/sys-devel/binutils/binutils-2.13.90.0.16-r1.ebuild b/sys-devel/binutils/binutils-2.13.90.0.16-r1.ebuild
index 87b8d5a20423..68272fcbc9e2 100644
--- a/sys-devel/binutils/binutils-2.13.90.0.16-r1.ebuild
+++ b/sys-devel/binutils/binutils-2.13.90.0.16-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.13.90.0.16-r1.ebuild,v 1.10 2003/05/25 15:34:03 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.13.90.0.16-r1.ebuild,v 1.11 2003/09/06 08:09:19 msterret Exp $
IUSE="nls bootstrap static build"
@@ -25,7 +25,7 @@ KEYWORDS="x86 ppc alpha sparc mips hppa"
DEPEND="virtual/glibc
>=sys-apps/portage-2.0.21
nls? ( sys-devel/gettext )
- || ( dev-lang/perl
+ || ( dev-lang/perl
( !build? ( dev-lang/perl ) )
( !bootstrap? ( dev-lang/perl ) )
)"
@@ -33,7 +33,7 @@ DEPEND="virtual/glibc
# if "build" or "bootstrap" not in USE.
src_unpack() {
-
+
unpack ${A}
cd ${S}
@@ -52,14 +52,14 @@ src_unpack() {
src_compile() {
- # Add patches for mips
- if [ "${ARCH}" = "mips" ]
- then
- cd ${S}
- chmod +x mips/README
- ./mips/README
- fi
-
+ # Add patches for mips
+ if [ "${ARCH}" = "mips" ]
+ then
+ cd ${S}
+ chmod +x mips/README
+ ./mips/README
+ fi
+
local myconf=""
use nls && \
myconf="${myconf} --without-included-gettext" || \
@@ -75,7 +75,7 @@ src_compile() {
--infodir=/usr/share/info \
--host=${CHOST} \
${myconf} || die
-
+
if [ "`use static`" ]
then
make headers -C bfd CFLAGS=-O || die
@@ -106,18 +106,18 @@ src_install() {
insinto /usr/include
doins include/libiberty.h
-
+
# c++filt is included with gcc -- what are these GNU people thinking?
# but not the manpage, so leave that!
# We install it now, as gcc-3.3 do not have it any longer ...
# rm -f ${D}/usr/bin/c++filt #${D}/usr/share/man/man1/c++filt*
-
+
# By default strip has a symlink going from /usr/${CHOST}/bin/strip to
# /usr/bin/strip we should reverse it:
rm ${D}/usr/${CHOST}/bin/strip; mv ${D}/usr/bin/strip ${D}/usr/${CHOST}/bin/strip
# The strip symlink gets created in the loop below
-
+
# By default ar, as, ld, nm, ranlib and strip are in two places; create
# symlinks. This will reduce the size of the tbz2 significantly. We also
# move all the stuff in /usr/bin to /usr/${CHOST}/bin and create the
@@ -129,12 +129,12 @@ src_install() {
if [ ! -e ../${CHOST}/bin/${x} ]
then
mv ${x} ../${CHOST}/bin/${x}
- else
+ else
rm -f ${x}
fi
ln -s ../${CHOST}/bin/${x} ${x}
done
-
+
cd ${S}
if [ -z "`use build`" ]
then
@@ -142,7 +142,7 @@ src_install() {
mandir=${D}/usr/share/man \
infodir=${D}/usr/share/info \
install-info || die
-
+
dodoc COPYING* README
docinto bfd
dodoc bfd/ChangeLog* bfd/COPYING bfd/README bfd/PORTING bfd/TODO