summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-02-06 15:58:08 +0000
committerAron Griffis <agriffis@gentoo.org>2004-02-06 15:58:08 +0000
commit82f917a6cee2d98370812a0c4b548d5249b85aec (patch)
tree027240c3bd48454fcba4f15a981f1ac6c9e1eb77 /sys-devel/bison
parentAdding amd64 keyword from #36030. (diff)
downloadgentoo-2-82f917a6cee2d98370812a0c4b548d5249b85aec.tar.gz
gentoo-2-82f917a6cee2d98370812a0c4b548d5249b85aec.tar.bz2
gentoo-2-82f917a6cee2d98370812a0c4b548d5249b85aec.zip
k6 replacement in the ebuild was resulting in -march=i586-3, fix and make more stringent
Diffstat (limited to 'sys-devel/bison')
-rw-r--r--sys-devel/bison/ChangeLog6
-rw-r--r--sys-devel/bison/bison-1.875.ebuild11
2 files changed, 11 insertions, 6 deletions
diff --git a/sys-devel/bison/ChangeLog b/sys-devel/bison/ChangeLog
index f4b066a841d1..eb8f64a64dd1 100644
--- a/sys-devel/bison/ChangeLog
+++ b/sys-devel/bison/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/bison
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/ChangeLog,v 1.24 2004/02/05 02:52:07 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/ChangeLog,v 1.25 2004/02/06 15:58:08 agriffis Exp $
+
+ 06 Feb 2004; Aron Griffis <agriffis@gentoo.org> bison-1.875.ebuild:
+ k6 replacement in the ebuild was resulting in -march=i586-3, fix and make more
+ stringent
04 Feb 2004; Aron Griffis <agriffis@gentoo.org> bison-1.875.ebuild:
Fix bug 29017 by replacing -march=k6 and -march=k6-2 with -march=i586. Fix bug
diff --git a/sys-devel/bison/bison-1.875.ebuild b/sys-devel/bison/bison-1.875.ebuild
index fe07262f04f4..ff9aba137f6e 100644
--- a/sys-devel/bison/bison-1.875.ebuild
+++ b/sys-devel/bison/bison-1.875.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/bison-1.875.ebuild,v 1.10 2004/02/05 02:52:07 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/bison-1.875.ebuild,v 1.11 2004/02/06 15:58:08 agriffis Exp $
inherit gcc
@@ -31,11 +31,12 @@ src_compile() {
[[ $ARCH == amd64 ]] && append-flags -O0
# Bug 29017 says that bison has compile-time issues with
- # -march=k6 and -march=k6-2 prior to 3.4CVS. Use -march=i586
- # instead (04 Feb 2004 agriffis)
+ # -march=k6* prior to 3.4CVS. Use -march=i586 instead
+ # (04 Feb 2004 agriffis)
if [[ $(gcc-major-version) == 3 && $(gcc-minor-version) < 4 ]]; then
- CFLAGS=${CFLAGS//-march=k6-2/-march=i586}
- CFLAGS=${CFLAGS//-march=k6/-march=i586}
+ CFLAGS=" ${CFLAGS} "
+ CFLAGS=${CFLAGS// -march=k6-? / -march=i586 }
+ CFLAGS=${CFLAGS// -march=k6 / -march=i586 }
fi
econf $(use_enable nls) || die