summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-05-03 05:20:39 +0000
committerMike Frysinger <vapier@gentoo.org>2007-05-03 05:20:39 +0000
commit27577c63dbe1491da696c34e9d4e8c376af168a2 (patch)
tree654fd6e6a52c7d57f6e2ecd7f5b6b1a909275099 /sys-devel/gcc-config/gcc-config-1.4.0.ebuild
parentdosemu bump (diff)
downloadgentoo-2-27577c63dbe1491da696c34e9d4e8c376af168a2.tar.gz
gentoo-2-27577c63dbe1491da696c34e9d4e8c376af168a2.tar.bz2
gentoo-2-27577c63dbe1491da696c34e9d4e8c376af168a2.zip
Move to GCC_PATH #174422 and make sure LDPATH is not re-ordered on us all the time #168884.
(Portage version: 2.1.2.5)
Diffstat (limited to 'sys-devel/gcc-config/gcc-config-1.4.0.ebuild')
-rw-r--r--sys-devel/gcc-config/gcc-config-1.4.0.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/sys-devel/gcc-config/gcc-config-1.4.0.ebuild b/sys-devel/gcc-config/gcc-config-1.4.0.ebuild
new file mode 100644
index 000000000000..0c66547c807a
--- /dev/null
+++ b/sys-devel/gcc-config/gcc-config-1.4.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/gcc-config-1.4.0.ebuild,v 1.5 2007/05/03 05:20:39 vapier Exp $
+
+inherit flag-o-matic toolchain-funcs multilib
+
+# Version of .c wrapper to use
+W_VER="1.5.0"
+
+DESCRIPTION="Utility to change the gcc compiler being used"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-*" #~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="!app-admin/eselect-compiler"
+
+S=${WORKDIR}
+
+src_compile() {
+ strip-flags
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} -Wall -o wrapper \
+ "${FILESDIR}"/wrapper-${W_VER}.c || die "compile wrapper"
+}
+
+src_install() {
+ newbin "${FILESDIR}"/${PN}-${PV} ${PN} || die "install gcc-config"
+ sed -i \
+ -e "s:PORTAGE-VERSION:${PVR}:g" \
+ -e "s:GENTOO_LIBDIR:$(get_libdir):g" \
+ "${D}"/usr/bin/${PN}
+
+ exeinto /usr/$(get_libdir)/misc
+ newexe wrapper gcc-config || die "install wrapper"
+}
+
+pkg_postinst() {
+ # Do we have a valid multi ver setup ?
+ if gcc-config --get-current-profile &>/dev/null ; then
+ # We not longer use the /usr/include/g++-v3 hacks, as
+ # it is not needed ...
+ [[ -L ${ROOT}/usr/include/g++ ]] && rm -f "${ROOT}"/usr/include/g++
+ [[ -L ${ROOT}/usr/include/g++-v3 ]] && rm -f "${ROOT}"/usr/include/g++-v3
+ gcc-config $(/usr/bin/gcc-config --get-current-profile)
+ fi
+
+ # Make sure old versions dont exist #79062
+ rm -f "${ROOT}"/usr/sbin/gcc-config
+}