summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-07-19 22:51:23 +0000
committerTravis Tilley <lv@gentoo.org>2004-07-19 22:51:23 +0000
commitc3f67a3599449202717e40beb8ab55653ecc5a8b (patch)
tree03de4bf07f5b782ad37c3f8e27bfd5d4c88f1438 /sys-devel/gcc/gcc-3.4.1.ebuild
parent~amd64 ~sparc (Manifest recommit) (diff)
downloadgentoo-2-c3f67a3599449202717e40beb8ab55653ecc5a8b.tar.gz
gentoo-2-c3f67a3599449202717e40beb8ab55653ecc5a8b.tar.bz2
gentoo-2-c3f67a3599449202717e40beb8ab55653ecc5a8b.zip
changed use of gtk2 USE flag to gtk
Diffstat (limited to 'sys-devel/gcc/gcc-3.4.1.ebuild')
-rw-r--r--sys-devel/gcc/gcc-3.4.1.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/sys-devel/gcc/gcc-3.4.1.ebuild b/sys-devel/gcc/gcc-3.4.1.ebuild
index 60c7d52bbb02..8e026a592125 100644
--- a/sys-devel/gcc/gcc-3.4.1.ebuild
+++ b/sys-devel/gcc/gcc-3.4.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.1.ebuild,v 1.8 2004/07/14 23:28:59 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.1.ebuild,v 1.9 2004/07/19 22:51:23 lv Exp $
-IUSE="static nls bootstrap build multilib gcj gtk2 f77 objc hardened uclibc n32 n64"
+IUSE="static nls bootstrap build multilib gcj gtk f77 objc hardened uclibc n32 n64"
inherit eutils flag-o-matic libtool gnuconfig
@@ -173,7 +173,7 @@ DEPEND="virtual/libc
>=sys-devel/bison-1.875
>=sys-devel/gcc-config-1.3.1
amd64? ( multilib? ( >=app-emulation/emul-linux-x86-baselibs-1.0 ) )
- !build? ( gcj? ( gtk2? ( >=x11-libs/gtk+-2.2 ) ) )
+ !build? ( gcj? ( gtk? ( >=x11-libs/gtk+-2.2 ) ) )
!build? ( >=sys-libs/ncurses-5.2-r2
nls? ( sys-devel/gettext ) )"
@@ -531,7 +531,7 @@ src_compile() {
# GTK+ is preferred over xlib in 3.4.x (xlib is unmaintained
# right now). Much thanks to <csm@gnu.org> for the heads up.
# Travis Tilley <lv@gentoo.org> (11 Jul 2004)
- if ! use build && use gcj && use gtk2
+ if ! use build && use gcj && use gtk
then
myconf="${myconf} --enable-java-awt=gtk"
fi