summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2011-09-03 14:54:16 +0000
committerFabian Groffen <grobian@gentoo.org>2011-09-03 14:54:16 +0000
commita1cc1e9da59c726eef4d4d6da53ad4aa9e3abcfe (patch)
tree11c20c5be173c03e18bec4ac92e7b95c09b93d29 /sys-devel/gdb
parentBump to 1.1.1, add plugin to 9999 (diff)
downloadgentoo-2-a1cc1e9da59c726eef4d4d6da53ad4aa9e3abcfe.tar.gz
gentoo-2-a1cc1e9da59c726eef4d4d6da53ad4aa9e3abcfe.tar.bz2
gentoo-2-a1cc1e9da59c726eef4d4d6da53ad4aa9e3abcfe.zip
Fixed Prefix support, and marked ~x86-macos and ~x64-macos
(Portage version: 2.2.01.19120-prefix/cvs/Darwin i386)
Diffstat (limited to 'sys-devel/gdb')
-rw-r--r--sys-devel/gdb/ChangeLog6
-rw-r--r--sys-devel/gdb/gdb-7.2.ebuild18
-rw-r--r--sys-devel/gdb/gdb-7.3.ebuild20
-rw-r--r--sys-devel/gdb/gdb-9999.ebuild18
4 files changed, 45 insertions, 17 deletions
diff --git a/sys-devel/gdb/ChangeLog b/sys-devel/gdb/ChangeLog
index 960929cb04c6..19d037384f24 100644
--- a/sys-devel/gdb/ChangeLog
+++ b/sys-devel/gdb/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/gdb
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/ChangeLog,v 1.189 2011/08/23 16:21:56 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/ChangeLog,v 1.190 2011/09/03 14:54:16 grobian Exp $
+
+ 03 Sep 2011; Fabian Groffen <grobian@gentoo.org> gdb-7.2.ebuild,
+ gdb-7.3.ebuild, gdb-9999.ebuild:
+ Fixed Prefix support, and marked ~x86-macos and ~x64-macos
23 Aug 2011; Mike Frysinger <vapier@gentoo.org> gdb-7.3.ebuild,
gdb-9999.ebuild:
diff --git a/sys-devel/gdb/gdb-7.2.ebuild b/sys-devel/gdb/gdb-7.2.ebuild
index 8cb48290c9af..445bf533ec52 100644
--- a/sys-devel/gdb/gdb-7.2.ebuild
+++ b/sys-devel/gdb/gdb-7.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-7.2.ebuild,v 1.13 2011/08/13 17:49:23 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-7.2.ebuild,v 1.14 2011/09/03 14:54:16 grobian Exp $
EAPI="3"
@@ -40,7 +40,7 @@ LICENSE="GPL-2 LGPL-2"
is_cross \
&& SLOT="${CTARGET}" \
|| SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sparc x86 ~x86-fbsd"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sparc x86 ~x86-fbsd ~x64-macos ~x86-macos"
IUSE="expat multitarget nls python test vanilla"
RDEPEND=">=sys-libs/ncurses-5.2-r2
@@ -78,7 +78,7 @@ src_configure() {
--disable-werror \
--enable-64-bit-bfd \
--with-system-readline \
- $(is_cross && echo --with-sysroot=/usr/${CTARGET}) \
+ $(is_cross && echo --with-sysroot="${EPREFIX}"/usr/${CTARGET}) \
$(use_with expat) \
$(use_enable nls) \
$(use multitarget && echo --enable-targets=all) \
@@ -98,7 +98,7 @@ src_install() {
# Don't install docs when building a cross-gdb
if [[ ${CTARGET} != ${CHOST} ]] ; then
- rm -r "${D}"/usr/share
+ rm -r "${ED}"/usr/share
return 0
fi
@@ -112,10 +112,18 @@ src_install() {
dodoc "${WORKDIR}"/extra/gdbinit.sample
# Remove shared info pages
- rm -f "${D}"/usr/share/info/{annotate,bfd,configure,standards}.info*
+ rm -f "${ED}"/usr/share/info/{annotate,bfd,configure,standards}.info*
}
pkg_postinst() {
# portage sucks and doesnt unmerge files in /etc
rm -vf "${ROOT}"/etc/skel/.gdbinit
+
+ if use prefix && [[ ${CHOST} == *-darwin* ]] ; then
+ ewarn "gdb is unable to get a mach task port when installed by Prefix"
+ ewarn "Portage, unprivileged. To make gdb fully functional you'll"
+ ewarn "have to perform the following steps:"
+ ewarn " % sudo chgrp procmod ${EPREFIX}/usr/bin/gdb"
+ ewarn " % sudo chmod g+s ${EPREFIX}/usr/bin/gdb"
+ fi
}
diff --git a/sys-devel/gdb/gdb-7.3.ebuild b/sys-devel/gdb/gdb-7.3.ebuild
index 9a6be4f9561f..ee78345c27ca 100644
--- a/sys-devel/gdb/gdb-7.3.ebuild
+++ b/sys-devel/gdb/gdb-7.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-7.3.ebuild,v 1.5 2011/08/23 16:21:56 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-7.3.ebuild,v 1.6 2011/09/03 14:54:16 grobian Exp $
EAPI="3"
@@ -52,7 +52,7 @@ is_cross \
&& SLOT="${CTARGET}" \
|| SLOT="0"
if [[ ${PV} != 9999* ]] ; then
- KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x86-fbsd"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x86-fbsd ~x64-macos ~x86-macos"
fi
IUSE="expat multitarget nls python test vanilla"
@@ -91,8 +91,8 @@ src_configure() {
--disable-werror \
--enable-64-bit-bfd \
--with-system-readline \
- --with-separate-debug-dir=/usr/lib/debug \
- $(is_cross && echo --with-sysroot=/usr/${CTARGET}) \
+ --with-separate-debug-dir="${EPREFIX}"/usr/lib/debug \
+ $(is_cross && echo --with-sysroot="${EPREFIX}"/usr/${CTARGET}) \
$(use_with expat) \
$(use_enable nls) \
$(use multitarget && echo --enable-targets=all) \
@@ -112,7 +112,7 @@ src_install() {
# Don't install docs when building a cross-gdb
if [[ ${CTARGET} != ${CHOST} ]] ; then
- rm -r "${D}"/usr/share
+ rm -r "${ED}"/usr/share
return 0
fi
@@ -128,10 +128,18 @@ src_install() {
fi
# Remove shared info pages
- rm -f "${D}"/usr/share/info/{annotate,bfd,configure,standards}.info*
+ rm -f "${ED}"/usr/share/info/{annotate,bfd,configure,standards}.info*
}
pkg_postinst() {
# portage sucks and doesnt unmerge files in /etc
rm -vf "${ROOT}"/etc/skel/.gdbinit
+
+ if use prefix && [[ ${CHOST} == *-darwin* ]] ; then
+ ewarn "gdb is unable to get a mach task port when installed by Prefix"
+ ewarn "Portage, unprivileged. To make gdb fully functional you'll"
+ ewarn "have to perform the following steps:"
+ ewarn " % sudo chgrp procmod ${EPREFIX}/usr/bin/gdb"
+ ewarn " % sudo chmod g+s ${EPREFIX}/usr/bin/gdb"
+ fi
}
diff --git a/sys-devel/gdb/gdb-9999.ebuild b/sys-devel/gdb/gdb-9999.ebuild
index a74b39afd593..a6b7bf61b3d9 100644
--- a/sys-devel/gdb/gdb-9999.ebuild
+++ b/sys-devel/gdb/gdb-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-9999.ebuild,v 1.3 2011/08/23 16:21:56 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-9999.ebuild,v 1.4 2011/09/03 14:54:16 grobian Exp $
EAPI="3"
@@ -91,8 +91,8 @@ src_configure() {
--disable-werror \
--enable-64-bit-bfd \
--with-system-readline \
- --with-separate-debug-dir=/usr/lib/debug \
- $(is_cross && echo --with-sysroot=/usr/${CTARGET}) \
+ --with-separate-debug-dir="${EPREFIX}"/usr/lib/debug \
+ $(is_cross && echo --with-sysroot="${EPREFIX}"/usr/${CTARGET}) \
$(use_with expat) \
$(use_enable nls) \
$(use multitarget && echo --enable-targets=all) \
@@ -112,7 +112,7 @@ src_install() {
# Don't install docs when building a cross-gdb
if [[ ${CTARGET} != ${CHOST} ]] ; then
- rm -r "${D}"/usr/share
+ rm -r "${ED}"/usr/share
return 0
fi
@@ -128,10 +128,18 @@ src_install() {
fi
# Remove shared info pages
- rm -f "${D}"/usr/share/info/{annotate,bfd,configure,standards}.info*
+ rm -f "${ED}"/usr/share/info/{annotate,bfd,configure,standards}.info*
}
pkg_postinst() {
# portage sucks and doesnt unmerge files in /etc
rm -vf "${ROOT}"/etc/skel/.gdbinit
+
+ if use prefix && [[ ${CHOST} == *-darwin* ]] ; then
+ ewarn "gdb is unable to get a mach task port when installed by Prefix"
+ ewarn "Portage, unprivileged. To make gdb fully functional you'll"
+ ewarn "have to perform the following steps:"
+ ewarn " % sudo chgrp procmod ${EPREFIX}/usr/bin/gdb"
+ ewarn " % sudo chmod g+s ${EPREFIX}/usr/bin/gdb"
+ fi
}