summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-03-08 23:09:01 +0000
committerMike Frysinger <vapier@gentoo.org>2014-03-08 23:09:01 +0000
commitfdbff504135311ced46b2b3c6020a5dd123ec117 (patch)
treee686092f91ea6858c5c87533d72713de29f79a01 /sys-devel/gdb
parentDrop ~ia64 keyword until rekeyword bug #503916 is solved. (diff)
downloadgentoo-2-fdbff504135311ced46b2b3c6020a5dd123ec117.tar.gz
gentoo-2-fdbff504135311ced46b2b3c6020a5dd123ec117.tar.bz2
gentoo-2-fdbff504135311ced46b2b3c6020a5dd123ec117.zip
Add USE=lzma to control lzma linkage support #503850 by Nikoli.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'sys-devel/gdb')
-rw-r--r--sys-devel/gdb/ChangeLog7
-rw-r--r--sys-devel/gdb/gdb-7.6.1.ebuild6
-rw-r--r--sys-devel/gdb/gdb-7.6.2.ebuild6
-rw-r--r--sys-devel/gdb/gdb-7.6.ebuild6
-rw-r--r--sys-devel/gdb/gdb-7.7.ebuild6
-rw-r--r--sys-devel/gdb/gdb-9999.ebuild6
-rw-r--r--sys-devel/gdb/metadata.xml1
7 files changed, 27 insertions, 11 deletions
diff --git a/sys-devel/gdb/ChangeLog b/sys-devel/gdb/ChangeLog
index 48472c614f2a..3f83e802ea1d 100644
--- a/sys-devel/gdb/ChangeLog
+++ b/sys-devel/gdb/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/gdb
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/ChangeLog,v 1.259 2014/03/05 15:53:52 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/ChangeLog,v 1.260 2014/03/08 23:09:01 vapier Exp $
+
+ 08 Mar 2014; Mike Frysinger <vapier@gentoo.org> gdb-7.6.1.ebuild,
+ gdb-7.6.2.ebuild, gdb-7.6.ebuild, gdb-7.7.ebuild, gdb-9999.ebuild,
+ metadata.xml:
+ Add USE=lzma to control lzma linkage support #503850 by Nikoli.
05 Mar 2014; Agostino Sarubbo <ago@gentoo.org> gdb-7.6.2.ebuild:
Stable for ppc, wrt bug #501528
diff --git a/sys-devel/gdb/gdb-7.6.1.ebuild b/sys-devel/gdb/gdb-7.6.1.ebuild
index a787cad341e3..2d61737dc9d4 100644
--- a/sys-devel/gdb/gdb-7.6.1.ebuild
+++ b/sys-devel/gdb/gdb-7.6.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-7.6.1.ebuild,v 1.5 2014/01/14 14:54:26 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-7.6.1.ebuild,v 1.6 2014/03/08 23:09:01 vapier Exp $
EAPI="3"
@@ -52,12 +52,13 @@ SLOT="0"
if [[ ${PV} != 9999* ]] ; then
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
-IUSE="+client expat multitarget nls +python +server test vanilla zlib"
+IUSE="+client expat lzma multitarget nls +python +server test vanilla zlib"
RDEPEND="!dev-util/gdbserver
>=sys-libs/ncurses-5.2-r2
sys-libs/readline
expat? ( dev-libs/expat )
+ lzma? ( app-arch/xz-utils )
python? ( =dev-lang/python-2* )
zlib? ( sys-libs/zlib )"
DEPEND="${RDEPEND}
@@ -131,6 +132,7 @@ src_configure() {
--with-system-readline
--with-separate-debug-dir="${EPREFIX}"/usr/lib/debug
$(use_with expat)
+ $(use_with lzma)
$(use_enable nls)
$(use multitarget && echo --enable-targets=all)
$(use_with python python "${EPREFIX}/usr/bin/python2")
diff --git a/sys-devel/gdb/gdb-7.6.2.ebuild b/sys-devel/gdb/gdb-7.6.2.ebuild
index 3f6a638f2551..f719b8fd96e1 100644
--- a/sys-devel/gdb/gdb-7.6.2.ebuild
+++ b/sys-devel/gdb/gdb-7.6.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-7.6.2.ebuild,v 1.8 2014/03/05 15:53:52 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-7.6.2.ebuild,v 1.9 2014/03/08 23:09:01 vapier Exp $
EAPI="3"
@@ -52,12 +52,13 @@ SLOT="0"
if [[ ${PV} != 9999* ]] ; then
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ~ppc64 ~s390 ~sparc x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
-IUSE="+client expat multitarget nls +python +server test vanilla zlib"
+IUSE="+client expat lzma multitarget nls +python +server test vanilla zlib"
RDEPEND="!dev-util/gdbserver
>=sys-libs/ncurses-5.2-r2
sys-libs/readline
expat? ( dev-libs/expat )
+ lzma? ( app-arch/xz-utils )
python? ( =dev-lang/python-2* )
zlib? ( sys-libs/zlib )"
DEPEND="${RDEPEND}
@@ -131,6 +132,7 @@ src_configure() {
--with-system-readline
--with-separate-debug-dir="${EPREFIX}"/usr/lib/debug
$(use_with expat)
+ $(use_with lzma)
$(use_enable nls)
$(use multitarget && echo --enable-targets=all)
$(use_with python python "${EPREFIX}/usr/bin/python2")
diff --git a/sys-devel/gdb/gdb-7.6.ebuild b/sys-devel/gdb/gdb-7.6.ebuild
index 8b46e8635363..e3d5c310491d 100644
--- a/sys-devel/gdb/gdb-7.6.ebuild
+++ b/sys-devel/gdb/gdb-7.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-7.6.ebuild,v 1.5 2014/01/14 14:54:26 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-7.6.ebuild,v 1.6 2014/03/08 23:09:01 vapier Exp $
EAPI="3"
@@ -52,12 +52,13 @@ SLOT="0"
if [[ ${PV} != 9999* ]] ; then
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
-IUSE="+client expat multitarget nls +python +server test vanilla zlib"
+IUSE="+client expat lzma multitarget nls +python +server test vanilla zlib"
RDEPEND="!dev-util/gdbserver
>=sys-libs/ncurses-5.2-r2
sys-libs/readline
expat? ( dev-libs/expat )
+ lzma? ( app-arch/xz-utils )
python? ( =dev-lang/python-2* )
zlib? ( sys-libs/zlib )"
DEPEND="${RDEPEND}
@@ -120,6 +121,7 @@ src_configure() {
--with-system-readline
--with-separate-debug-dir="${EPREFIX}"/usr/lib/debug
$(use_with expat)
+ $(use_with lzma)
$(use_enable nls)
$(use multitarget && echo --enable-targets=all)
$(use_with python python "${EPREFIX}/usr/bin/python2")
diff --git a/sys-devel/gdb/gdb-7.7.ebuild b/sys-devel/gdb/gdb-7.7.ebuild
index 14e8f9e3acac..26b198034e7a 100644
--- a/sys-devel/gdb/gdb-7.7.ebuild
+++ b/sys-devel/gdb/gdb-7.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-7.7.ebuild,v 1.1 2014/02/06 07:45:43 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-7.7.ebuild,v 1.2 2014/03/08 23:09:01 vapier Exp $
EAPI="4"
@@ -52,12 +52,13 @@ SLOT="0"
if [[ ${PV} != 9999* ]] ; then
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
-IUSE="+client expat multitarget nls +python +server test vanilla zlib"
+IUSE="+client expat lzma multitarget nls +python +server test vanilla zlib"
RDEPEND="!dev-util/gdbserver
>=sys-libs/ncurses-5.2-r2
sys-libs/readline
expat? ( dev-libs/expat )
+ lzma? ( app-arch/xz-utils )
python? ( =dev-lang/python-2* )
zlib? ( sys-libs/zlib )"
DEPEND="${RDEPEND}
@@ -136,6 +137,7 @@ src_configure() {
--with-system-readline
--with-separate-debug-dir="${EPREFIX}"/usr/lib/debug
$(use_with expat)
+ $(use_with lzma)
$(use_enable nls)
$(use multitarget && echo --enable-targets=all)
$(use_with python python "${EPREFIX}/usr/bin/python2")
diff --git a/sys-devel/gdb/gdb-9999.ebuild b/sys-devel/gdb/gdb-9999.ebuild
index 912714895413..13e471a68f63 100644
--- a/sys-devel/gdb/gdb-9999.ebuild
+++ b/sys-devel/gdb/gdb-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-9999.ebuild,v 1.21 2014/02/06 07:44:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-9999.ebuild,v 1.22 2014/03/08 23:09:01 vapier Exp $
EAPI="4"
@@ -52,12 +52,13 @@ SLOT="0"
if [[ ${PV} != 9999* ]] ; then
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
-IUSE="+client expat multitarget nls +python +server test vanilla zlib"
+IUSE="+client expat lzma multitarget nls +python +server test vanilla zlib"
RDEPEND="!dev-util/gdbserver
>=sys-libs/ncurses-5.2-r2
sys-libs/readline
expat? ( dev-libs/expat )
+ lzma? ( app-arch/xz-utils )
python? ( =dev-lang/python-2* )
zlib? ( sys-libs/zlib )"
DEPEND="${RDEPEND}
@@ -136,6 +137,7 @@ src_configure() {
--with-system-readline
--with-separate-debug-dir="${EPREFIX}"/usr/lib/debug
$(use_with expat)
+ $(use_with lzma)
$(use_enable nls)
$(use multitarget && echo --enable-targets=all)
$(use_with python python "${EPREFIX}/usr/bin/python2")
diff --git a/sys-devel/gdb/metadata.xml b/sys-devel/gdb/metadata.xml
index ab9c41a6cadc..c8877de66f36 100644
--- a/sys-devel/gdb/metadata.xml
+++ b/sys-devel/gdb/metadata.xml
@@ -4,6 +4,7 @@
<herd>toolchain</herd>
<use>
<flag name='client'>Install the main "gdb" program (most people want this)</flag>
+ <flag name='lzma'>Support lzma compression in ELF debug info</flag>
<flag name='multitarget'>Support all known targets in one gdb binary</flag>
<flag name='python'>Enable support for the new internal scripting language, as well as extended pretty printers</flag>
<flag name='server'>Install the "gdbserver" program (useful for embedded/remote targets)</flag>