summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2014-10-12 01:37:17 +0000
committerAnthony G. Basile <blueness@gentoo.org>2014-10-12 01:37:17 +0000
commit5cfda905bec0140ce9e4f4a546172cf198789baa (patch)
tree30aae86a7fe266b5c308587950b70276c74f829e /sys-devel/gettext
parentbup (diff)
downloadgentoo-2-5cfda905bec0140ce9e4f4a546172cf198789baa.tar.gz
gentoo-2-5cfda905bec0140ce9e4f4a546172cf198789baa.tar.bz2
gentoo-2-5cfda905bec0140ce9e4f4a546172cf198789baa.zip
Add support for musl which now provides internal libintl
(Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'sys-devel/gettext')
-rw-r--r--sys-devel/gettext/ChangeLog6
-rw-r--r--sys-devel/gettext/gettext-0.19.1.ebuild6
-rw-r--r--sys-devel/gettext/gettext-0.19.2.1_rc1.ebuild6
-rw-r--r--sys-devel/gettext/gettext-0.19.2.ebuild6
4 files changed, 14 insertions, 10 deletions
diff --git a/sys-devel/gettext/ChangeLog b/sys-devel/gettext/ChangeLog
index 76403c5a6a51..4a03a895cffe 100644
--- a/sys-devel/gettext/ChangeLog
+++ b/sys-devel/gettext/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/gettext
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/ChangeLog,v 1.249 2014/10/02 19:59:53 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/ChangeLog,v 1.250 2014/10/12 01:37:17 blueness Exp $
+
+ 12 Oct 2014; Anthony G. Basile <blueness@gentoo.org> gettext-0.19.1.ebuild,
+ gettext-0.19.2.1_rc1.ebuild, gettext-0.19.2.ebuild:
+ Add support for musl which now provides internal libintl
*gettext-0.19.2.1_rc1 (02 Oct 2014)
diff --git a/sys-devel/gettext/gettext-0.19.1.ebuild b/sys-devel/gettext/gettext-0.19.1.ebuild
index 579b597f94a1..502f9110a7e5 100644
--- a/sys-devel/gettext/gettext-0.19.1.ebuild
+++ b/sys-devel/gettext/gettext-0.19.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/gettext-0.19.1.ebuild,v 1.2 2014/06/18 20:47:33 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/gettext-0.19.1.ebuild,v 1.3 2014/10/12 01:37:17 blueness Exp $
EAPI="4"
@@ -13,7 +13,7 @@ SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
LICENSE="GPL-3 LGPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
-IUSE="acl -cvs doc emacs git java nls +cxx ncurses openmp static-libs elibc_glibc"
+IUSE="acl -cvs doc emacs git java nls +cxx ncurses openmp static-libs elibc_glibc elibc_musl"
if [[ ${PV} =~ _rc ]] ; then
SRC_URI="mirror://gnu-alpha/${PN}/${P/_/-}.tar.gz"
@@ -61,7 +61,7 @@ multilib_src_configure() {
)
# Build with --without-included-gettext (on glibc systems)
- if use elibc_glibc ; then
+ if use elibc_glibc || use elibc_musl ; then
myconf+=(
--without-included-gettext
$(use_enable nls)
diff --git a/sys-devel/gettext/gettext-0.19.2.1_rc1.ebuild b/sys-devel/gettext/gettext-0.19.2.1_rc1.ebuild
index 4f56a7851737..40d1d433329e 100644
--- a/sys-devel/gettext/gettext-0.19.2.1_rc1.ebuild
+++ b/sys-devel/gettext/gettext-0.19.2.1_rc1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/gettext-0.19.2.1_rc1.ebuild,v 1.1 2014/10/02 19:59:53 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/gettext-0.19.2.1_rc1.ebuild,v 1.2 2014/10/12 01:37:17 blueness Exp $
EAPI="4"
@@ -13,7 +13,7 @@ SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
LICENSE="GPL-3 LGPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
-IUSE="acl -cvs doc emacs git java nls +cxx ncurses openmp static-libs elibc_glibc"
+IUSE="acl -cvs doc emacs git java nls +cxx ncurses openmp static-libs elibc_glibc elibc_musl"
if [[ ${PV} =~ _rc ]] ; then
SRC_URI="mirror://gnu-alpha/${PN}/${P/_/-}.tar.xz"
@@ -61,7 +61,7 @@ multilib_src_configure() {
)
# Build with --without-included-gettext (on glibc systems)
- if use elibc_glibc ; then
+ if use elibc_glibc || use elibc_musl ; then
myconf+=(
--without-included-gettext
$(use_enable nls)
diff --git a/sys-devel/gettext/gettext-0.19.2.ebuild b/sys-devel/gettext/gettext-0.19.2.ebuild
index 9e89dc391f08..7fb3349077cd 100644
--- a/sys-devel/gettext/gettext-0.19.2.ebuild
+++ b/sys-devel/gettext/gettext-0.19.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/gettext-0.19.2.ebuild,v 1.1 2014/07/14 21:36:32 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/gettext-0.19.2.ebuild,v 1.2 2014/10/12 01:37:17 blueness Exp $
EAPI="4"
@@ -13,7 +13,7 @@ SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
LICENSE="GPL-3 LGPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
-IUSE="acl -cvs doc emacs git java nls +cxx ncurses openmp static-libs elibc_glibc"
+IUSE="acl -cvs doc emacs git java nls +cxx ncurses openmp static-libs elibc_glibc elibc_musl"
if [[ ${PV} =~ _rc ]] ; then
SRC_URI="mirror://gnu-alpha/${PN}/${P/_/-}.tar.gz"
@@ -61,7 +61,7 @@ multilib_src_configure() {
)
# Build with --without-included-gettext (on glibc systems)
- if use elibc_glibc ; then
+ if use elibc_glibc || use elibc_musl ; then
myconf+=(
--without-included-gettext
$(use_enable nls)