summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-06-05 01:55:49 +0000
committerMike Frysinger <vapier@gentoo.org>2010-06-05 01:55:49 +0000
commite7bfa1c6649e8db57c3ca128e69e213d9ff8c325 (patch)
tree1ac382cb6bd3624cd438c912a8e7d6dd6121ae67 /sys-devel/gettext
parentVersion bumped. Removed old versions. (diff)
downloadgentoo-2-e7bfa1c6649e8db57c3ca128e69e213d9ff8c325.tar.gz
gentoo-2-e7bfa1c6649e8db57c3ca128e69e213d9ff8c325.tar.bz2
gentoo-2-e7bfa1c6649e8db57c3ca128e69e213d9ff8c325.zip
Version bump.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel/gettext')
-rw-r--r--sys-devel/gettext/ChangeLog7
-rw-r--r--sys-devel/gettext/gettext-0.18.1.ebuild92
2 files changed, 98 insertions, 1 deletions
diff --git a/sys-devel/gettext/ChangeLog b/sys-devel/gettext/ChangeLog
index 4d33b97d7a2b..c138d923919a 100644
--- a/sys-devel/gettext/ChangeLog
+++ b/sys-devel/gettext/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/gettext
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/ChangeLog,v 1.178 2010/05/24 02:07:29 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/ChangeLog,v 1.179 2010/06/05 01:55:49 vapier Exp $
+
+*gettext-0.18.1 (05 Jun 2010)
+
+ 05 Jun 2010; Mike Frysinger <vapier@gentoo.org> +gettext-0.18.1.ebuild:
+ Version bump.
*gettext-0.18 (24 May 2010)
diff --git a/sys-devel/gettext/gettext-0.18.1.ebuild b/sys-devel/gettext/gettext-0.18.1.ebuild
new file mode 100644
index 000000000000..862df3727e0d
--- /dev/null
+++ b/sys-devel/gettext/gettext-0.18.1.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/gettext-0.18.1.ebuild,v 1.1 2010/06/05 01:55:49 vapier Exp $
+
+EAPI="2"
+
+inherit flag-o-matic eutils multilib toolchain-funcs mono libtool
+
+DESCRIPTION="GNU locale utilities"
+HOMEPAGE="http://www.gnu.org/software/gettext/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3 LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="acl doc emacs nls nocxx openmp elibc_glibc"
+
+DEPEND="virtual/libiconv
+ dev-libs/libxml2
+ sys-libs/ncurses
+ dev-libs/expat
+ acl? ( virtual/acl )"
+PDEPEND="emacs? ( app-emacs/po-mode )"
+
+src_prepare() {
+ epunt_cxx
+}
+
+src_configure() {
+ local myconf=""
+ # Build with --without-included-gettext (on glibc systems)
+ if use elibc_glibc ; then
+ myconf="${myconf} --without-included-gettext $(use_enable nls)"
+ else
+ myconf="${myconf} --with-included-gettext --enable-nls"
+ fi
+ use nocxx && export CXX=$(tc-getCC)
+
+ # --without-emacs: Emacs support is now in a separate package
+ # --with-included-glib: glib depends on us so avoid circular deps
+ # --with-included-libcroco: libcroco depends on glib which ... ^^^
+ econf \
+ --docdir="/usr/share/doc/${PF}" \
+ --without-emacs \
+ --disable-java \
+ --with-included-glib \
+ --with-included-libcroco \
+ $(use_enable acl) \
+ $(use_enable openmp)
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "install failed"
+ use nls || rm -r "${D}"/usr/share/locale
+ dosym msgfmt /usr/bin/gmsgfmt #43435
+ dobin gettext-tools/misc/gettextize || die "gettextize"
+
+ # remove stuff that glibc handles
+ if use elibc_glibc ; then
+ rm -f "${D}"/usr/include/libintl.h
+ rm -f "${D}"/usr/$(get_libdir)/libintl.*
+ fi
+ rm -f "${D}"/usr/share/locale/locale.alias "${D}"/usr/lib/charset.alias
+
+ if [[ ${USERLAND} == "BSD" ]] ; then
+ libname="libintl$(get_libname)"
+ # Move dynamic libs and creates ldscripts into /usr/lib
+ dodir /$(get_libdir)
+ mv "${D}"/usr/$(get_libdir)/${libname}* "${D}"/$(get_libdir)/
+ gen_usr_ldscript ${libname}
+ fi
+
+ if use doc ; then
+ dohtml "${D}"/usr/share/doc/${PF}/*.html
+ else
+ rm -rf "${D}"/usr/share/doc/${PF}/{csharpdoc,examples,javadoc2,javadoc1}
+ fi
+ rm -f "${D}"/usr/share/doc/${PF}/*.html
+
+ dodoc AUTHORS ChangeLog NEWS README THANKS
+}
+
+pkg_preinst() {
+ # older gettext's sometimes installed libintl ...
+ # need to keep the linked version or the system
+ # could die (things like sed link against it :/)
+ preserve_old_lib /{,usr/}$(get_libdir)/libintl$(get_libname 7)
+}
+
+pkg_postinst() {
+ preserve_old_lib_notify /{,usr/}$(get_libdir)/libintl$(get_libname 7)
+}