summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <msterret@gentoo.org>2003-09-05 02:03:59 +0000
committerMichael Sterrett <msterret@gentoo.org>2003-09-05 02:03:59 +0000
commitab34bd0c03a91a3ff9df58a8adbdb7f04f112109 (patch)
tree2dfcf80d45dfae57f217b4b8c5938976002e7894 /sys-devel/m4
parentNew revision with experimental gtk2 support. should be kept hard masked for a... (diff)
downloadgentoo-2-ab34bd0c03a91a3ff9df58a8adbdb7f04f112109.tar.gz
gentoo-2-ab34bd0c03a91a3ff9df58a8adbdb7f04f112109.tar.bz2
gentoo-2-ab34bd0c03a91a3ff9df58a8adbdb7f04f112109.zip
whitespace cleanup
Diffstat (limited to 'sys-devel/m4')
-rw-r--r--sys-devel/m4/Manifest8
-rw-r--r--sys-devel/m4/m4-1.4.ebuild8
-rw-r--r--sys-devel/m4/m4-1.4o-r2.ebuild46
-rw-r--r--sys-devel/m4/m4-1.4p-r1.ebuild11
-rw-r--r--sys-devel/m4/m4-1.4p.ebuild9
5 files changed, 38 insertions, 44 deletions
diff --git a/sys-devel/m4/Manifest b/sys-devel/m4/Manifest
index 239cddb75081..d7a26658936a 100644
--- a/sys-devel/m4/Manifest
+++ b/sys-devel/m4/Manifest
@@ -1,8 +1,8 @@
MD5 45f1eac72b4f9c81f6419b649302cbd9 ChangeLog 1796
-MD5 344c141dde2ead7ccaae2099abdbffa0 m4-1.4.ebuild 1197
-MD5 1222af6850824e44d2b117f21f38c874 m4-1.4o-r2.ebuild 1224
-MD5 91d641fdce19dae3b3af35d2106bc064 m4-1.4p-r1.ebuild 1545
-MD5 cdea44a8d06d1c5ec63b8665f0c5f396 m4-1.4p.ebuild 1534
+MD5 c06a03afd689cdc67c6b7a84166b6edf m4-1.4.ebuild 1193
+MD5 b33c32e0dba826ef64ae97f086ffa9d1 m4-1.4o-r2.ebuild 1142
+MD5 87d74d52dce6222d7e15acaa42aa65cc m4-1.4p-r1.ebuild 1540
+MD5 5eb850fad04a28f579500e015309f71b m4-1.4p.ebuild 1529
MD5 bb66a9e8ca60b752e95b5234d7f7b0b0 files/digest-m4-1.4 118
MD5 fd56a0a7848beda0e23b0c9efdb286df files/digest-m4-1.4o-r2 59
MD5 df58525b27b74338c793376824215b78 files/digest-m4-1.4p 63
diff --git a/sys-devel/m4/m4-1.4.ebuild b/sys-devel/m4/m4-1.4.ebuild
index 8c4dcaecbb92..d747fe33a6ac 100644
--- a/sys-devel/m4/m4-1.4.ebuild
+++ b/sys-devel/m4/m4-1.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/m4/m4-1.4.ebuild,v 1.6 2003/06/22 06:18:39 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/m4/m4-1.4.ebuild,v 1.7 2003/09/05 02:03:56 msterret Exp $
IUSE="nls"
@@ -33,14 +33,14 @@ src_unpack() {
src_compile() {
local myconf=
-
+
use nls || myconf="--disable-nls"
-
+
./configure --host=${CHOST} \
--prefix=/usr \
--enable-changeword \
${myconf} || die
-
+
emake || die
}
diff --git a/sys-devel/m4/m4-1.4o-r2.ebuild b/sys-devel/m4/m4-1.4o-r2.ebuild
index b18dae993e74..7a821c52289a 100644
--- a/sys-devel/m4/m4-1.4o-r2.ebuild
+++ b/sys-devel/m4/m4-1.4o-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/m4/m4-1.4o-r2.ebuild,v 1.13 2003/02/13 16:33:35 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/m4/m4-1.4o-r2.ebuild,v 1.14 2003/09/05 02:03:56 msterret Exp $
IUSE="nls"
@@ -14,38 +14,34 @@ SLOT="0"
KEYWORDS="x86 sparc "
DEPEND="virtual/glibc
- nls? ( sys-devel/gettext )
- >=sys-devel/libtool-1.3.5-r2"
+ nls? ( sys-devel/gettext )
+ >=sys-devel/libtool-1.3.5-r2"
RDEPEND="virtual/glibc"
src_compile() {
- local myconf
- if [ -z "`use nls`" ]
- then
- myconf="--disable-nls"
- fi
- try ./configure --prefix=/usr --libexecdir=/usr/lib \
- --mandir=/usr/share/man --infodir=/usr/share/info \
- --with-modules --host=${CHOST} ${myconf}
- try make ${MAKEOPTS}
+ local myconf
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ fi
+ try ./configure --prefix=/usr --libexecdir=/usr/lib \
+ --mandir=/usr/share/man --infodir=/usr/share/info \
+ --with-modules --host=${CHOST} ${myconf}
+ try make ${MAKEOPTS}
}
src_install() {
+ cd ${S}
- cd ${S}
+ try make prefix=${D}/usr libexecdir=${D}/usr/lib \
+ mandir=${D}/usr/share/man infodir=${D}/usr/share/info install
- try make prefix=${D}/usr libexecdir=${D}/usr/lib \
- mandir=${D}/usr/share/man infodir=${D}/usr/share/info install
-
- rm -rf ${D}/usr/include
-
- dodoc AUTHORS BACKLOG ChangeLog COPYING NEWS README* THANKS TODO
- docinto modules
- dodoc modules/README modules/TODO
- docinto html
- dodoc examples/WWW/*.htm
+ rm -rf ${D}/usr/include
+ dodoc AUTHORS BACKLOG ChangeLog COPYING NEWS README* THANKS TODO
+ docinto modules
+ dodoc modules/README modules/TODO
+ docinto html
+ dodoc examples/WWW/*.htm
}
-
-
diff --git a/sys-devel/m4/m4-1.4p-r1.ebuild b/sys-devel/m4/m4-1.4p-r1.ebuild
index 923999aabd99..283d168b5a66 100644
--- a/sys-devel/m4/m4-1.4p-r1.ebuild
+++ b/sys-devel/m4/m4-1.4p-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/m4/m4-1.4p-r1.ebuild,v 1.6 2003/03/11 21:11:47 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/m4/m4-1.4p-r1.ebuild,v 1.7 2003/09/05 02:03:56 msterret Exp $
inherit gnuconfig
@@ -34,9 +34,9 @@ src_unpack() {
src_compile() {
local myconf=
-
+
use nls || myconf="--disable-nls"
-
+
./configure --prefix=/usr \
--libexecdir=/usr/lib \
--mandir=/usr/share/man \
@@ -44,7 +44,7 @@ src_compile() {
--with-modules \
--host=${CHOST} \
${myconf} || die
-
+
make ${MAKEOPTS} || die
}
@@ -62,9 +62,8 @@ src_install() {
dodoc modules/README modules/TODO
docinto html
dohtml examples/WWW/*.htm
-
+
# mkconfig.sh creates this file in other revisions...
# It shouldn't be there, so we delete it.
rm -f /tmp/env
}
-
diff --git a/sys-devel/m4/m4-1.4p.ebuild b/sys-devel/m4/m4-1.4p.ebuild
index 49849fa42129..4086fdaee442 100644
--- a/sys-devel/m4/m4-1.4p.ebuild
+++ b/sys-devel/m4/m4-1.4p.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/m4/m4-1.4p.ebuild,v 1.15 2003/02/24 10:11:26 carpaski Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/m4/m4-1.4p.ebuild,v 1.16 2003/09/05 02:03:56 msterret Exp $
inherit gnuconfig
@@ -36,7 +36,7 @@ src_compile() {
then
myconf="--disable-nls"
fi
-
+
./configure --prefix=/usr \
--libexecdir=/usr/lib \
--mandir=/usr/share/man \
@@ -44,7 +44,7 @@ src_compile() {
--with-modules \
--host=${CHOST} \
${myconf} || die
-
+
make ${MAKEOPTS} || die
}
@@ -62,9 +62,8 @@ src_install() {
dodoc modules/README modules/TODO
docinto html
dohtml examples/WWW/*.htm
-
+
# mkconfig.sh creates this file in other revisions...
# It shouldn't be there, so we delete it.
rm -f /tmp/env
}
-